02-24-2016 05:11 PM
385 ... 7891011 ...
tools
  1. Braydon525's Avatar
    So I got thru a bunch to try and get froyo onto my phone. I was at post #5: How to install zip from recovery. (Froyo, themes, other kernels) ... step #4.

    My screen says:
    Andriod system recovery <2e>

    Samsung Recovery Utils
    -for BML-

    reboot system now
    apply sdacrd:update.zip
    wipe data/factory reset
    wipe cache partition


    under that i have a little andriod guy with a white triangle and an orange ! that say #manual mode#

    I tried hitting the back button on apply sdcard:update.zip and reboot system now, and nothing happens.
    Thats the stock recovery. Are you sure you ran both CWM.app and Kernel.app in the 1-click? In stock recovery you have to press the home button to select. Try selecting update.zip and see if it loads red recovery.
    03-21-2011 11:49 PM
  2. alpina0560's Avatar
    i was finally able to load red recovery, now i just can't seem to find where the ROM is located in my phone. i did the 1-click-pushtosd, dropped in "super_frackenclean_2_9nv" was able to push all the files to my sd card. now i am lost on going into red recovery, and selecting my ROM zip file
    03-21-2011 11:55 PM
  3. DroidXcon's Avatar
    i was finally able to load red recovery, now i just can't seem to find where the ROM is located in my phone. i did the 1-click-pushtosd, dropped in "super_frackenclean_2_9nv" was able to push all the files to my sd card. now i am lost on going into red recovery, and selecting my ROM zip file
    was my section on flashing a zip not helpful?
    03-21-2011 11:57 PM
  4. alpina0560's Avatar
    no no no no! not not helpful! I just can't seem to find it on my phone, for your example shows tw_clock_package.zip. that isn't coming up on my screen. i've tried clicking on every link available on the "choose a zip to apply" screen and they all say "no file found"
    03-22-2011 12:00 AM
  5. DroidXcon's Avatar
    no no no no! not not helpful! I just can't seem to find it on my phone, for your example shows tw_clock_package.zip. that isn't coming up on my screen. i've tried clicking on every link available on the "choose a zip to apply" screen and they all say "no file found"
    ok so when you turn on your phone, and mount your sdcard you are unable to see the files on card?
    03-22-2011 12:02 AM
  6. alpina0560's Avatar
    yeah I can see the files on my phone if i go to "my files" ... is that what you are asking?
    03-22-2011 12:04 AM
  7. DroidXcon's Avatar
    yeah I can see the files on my phone if i go to "my files" ... is that what you are asking?
    when you open my files, is do you see the file right away or do you have to enter a folder,,,,the other question do you see it as a .zip file

    like franken_clean29.zip
    03-22-2011 12:06 AM
  8. alpina0560's Avatar
    nope not seeing any .zip, if i open the files it leads to me folders than have more folders and then files but none of them say .zip
    03-22-2011 12:08 AM
  9. DroidXcon's Avatar
    what are the files not in the folder, it sounds like the zip files maybe opened themselves
    03-22-2011 12:12 AM
  10. alpina0560's Avatar
    there are three main files that i downloaded from the superclean pack..
    system - which has xbin (folder), usr (folder), media (folder), seh (folder), sem (folder), tts(folder), lib(folder), framework(folder), fonts(folder), etc(folder), bin(folder), cameradata(folder), app(folder), build.prop, default.prop
    meta-inf - which has com/google/andriod/update-script
    kernel_update - which has zImage2, zImage, redbend_ua, bmlunlock.
    03-22-2011 12:17 AM
  11. DroidXcon's Avatar
    yeah thats the problem ,,,,when you downloaded superclean, either it opened itself or you opened it,,,but i think it opened itself, i dont remember to keep it zipped on a mac,,,

    what you can do is go to your browers, go to android central, go to the superclean file and try to download the file directly from the phone
    03-22-2011 12:22 AM
  12. alpina0560's Avatar
    okay going to give that a try! i've only been trying to root this phone for three and a half hours =( boo but thanks for your help!
    03-22-2011 12:23 AM
  13. ls5012's Avatar
    running 10.58. Just saw a post on the phone not mounting thread about downloading the original DL30 leak. Gonna try it.
    03-22-2011 09:09 AM
  14. alpina0560's Avatar
    so, as of this morning i finally figured out how to put superclean on my phone, and I'm pretty sure it is working, but when i hit my menu button to go to my settings for the phone...nothing happens?
    03-22-2011 11:06 AM
  15. newBjo3's Avatar
    Alpina, so you just left your terminal open to this until it worked through the install? ( Sorry, this was for post #178). I am attempting this now and am ending up with the same message.

    EDIT

    And patience is a virtue. It worked after about 30 seconds of waiting.

    To all of you who have posted your insight and assistance, many thanks! It's amazing!
    03-22-2011 11:55 AM
  16. Braydon525's Avatar
    so, as of this morning i finally figured out how to put superclean on my phone, and I'm pretty sure it is working, but when i hit my menu button to go to my settings for the phone...nothing happens?
    Has it started working? What kernel version is currently on the phone?
    03-23-2011 03:05 PM
  17. etmarcr's Avatar
    I'm seriously thinking about rooting my Fascinate and don't know much about it. I've read several threads on rooting but most of what I see gives instructions using a PC, with installing drivers & such.

    Unless I just haven't found the right place, is there an up-to-date guide with easy step-by-steps for rooting on a Mac, especially with the mounting issues and the workarounds?

    Thanks for any help!
    03-23-2011 05:56 PM
  18. DroidXcon's Avatar
    03-23-2011 05:59 PM
  19. etmarcr's Avatar
    Thanks for the quick reply, DroidXcon!! When I have more questions I'll know where to bring them!
    03-23-2011 06:13 PM
  20. DroidXcon's Avatar
    Thanks for the quick reply, DroidXcon!! When I have more questions I'll know where to bring them!
    very welcome
    03-23-2011 06:14 PM
  21. newBjo3's Avatar
    Okay, I'm having an issue installing the cw 2.1-2.2 (post #4). I dl to my mac, installed the 1-clish push to sd and that installed fine (post #2). When I click the kernel in cw 2.1-2.2, the terminal has the same message everyone (including me) experienced when running the 1-click root (post #3) and the terminal just sits. I tried waiting longer than I waited for the 1-click to run through (which installed after about 5 minutes), but nothing happens. Any suggestions?
    I booted into recovery (blue) and second option is "apply sd card:update.zip" with wipe cache partition being the last option. Do I install the update.zip file? Obviously cw 2.1-2.2 didn't take because recovery isn't red. Is that correct?

    this is the message:

    :~ owner1$ cd '/Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files' ; clear
    /Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files/kernel.sh



    :Files owner1$ /Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files/kernel.sh
    Starting installation...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    failed to copy 'zImage' to '/sdcard/zImage': Permission denied
    238 KB/s (313888 bytes in 1.284s)
    0 KB/s (24 bytes in 0.106s)[*] CVE-2010-EASY Android local root exploit (C) 2010 by 743C
    [*] checking NPROC limit ...
    [+] RLIMIT_NPROC={3712, 3712}[*] Searching for adb ...
    [+] Found adb as PID 4385[*] Spawning children. Dont type anything and wait for reset![*][*] If you like what we are doing you can send us PayPal money to[*] 7-4-3-C@web.de so we can compensate time, effort and HW costs.[*] If you are a company and feel like you profit from our work,[*] we also accept donations > 1000 USD![*][*] adb connection will be reset. restart adb server on desktop and re-login.
    03-24-2011 03:35 PM
  22. Braydon525's Avatar
    Okay, I'm having an issue installing the cw 2.1-2.2 (post #4). I dl to my mac, installed the 1-clish push to sd and that installed fine (post #2). When I click the kernel in cw 2.1-2.2, the terminal has the same message everyone (including me) experienced when running the 1-click root (post #3) and the terminal just sits. I tried waiting longer than I waited for the 1-click to run through (which installed after about 5 minutes), but nothing happens. Any suggestions?
    I booted into recovery (blue) and second option is "apply sd card:update.zip" with wipe cache partition being the last option. Do I install the update.zip file? Obviously cw 2.1-2.2 didn't take because recovery isn't red. Is that correct?

    this is the message:

    :~ owner1$ cd '/Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files' ; clear
    /Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files/kernel.sh



    :Files owner1$ /Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files/kernel.sh
    Starting installation...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    failed to copy 'zImage' to '/sdcard/zImage': Permission denied
    238 KB/s (313888 bytes in 1.284s)
    0 KB/s (24 bytes in 0.106s)[*] CVE-2010-EASY Android local root exploit (C) 2010 by 743C
    [*] checking NPROC limit ...
    [+] RLIMIT_NPROC={3712, 3712}[*] Searching for adb ...
    [+] Found adb as PID 4385[*] Spawning children. Dont type anything and wait for reset![*][*] If you like what we are doing you can send us PayPal money to[*] 7-4-3-C@web.de so we can compensate time, effort and HW costs.[*] If you are a company and feel like you profit from our work,[*] we also accept donations > 1000 USD![*][*] adb connection will be reset. restart adb server on desktop and re-login.
    looks like red recovery never got installed. you can try it again, and if you get another permission denied try typing
    chmod -R 755 /path/to/1-click-folder/
    in terminal. then try again.
    03-24-2011 10:35 PM
  23. Braydon525's Avatar
    I tried waiting longer than I waited for the 1-click to run through (which installed after about 5 minutes), but nothing happens.
    I remember my first time rooting using the manual method took up to about 5 minutes as well. I didnt remember this until just now, but maybe there is something about the phone that requires more time for the exploit to run when rooting for the first time? Very interesting.
    03-24-2011 10:37 PM
  24. newBjo3's Avatar
    waited 15 minutes and nothing.
    typed in the command you suggested and this is the result

    Starting installation...
    failed to copy 'zImage' to '/sdcard/zImage': Permission denied
    235 KB/s (313888 bytes in 1.299s)
    0 KB/s (24 bytes in 0.135s)

    and my phone froze

    rebooted and ran the program again... my Mac kicked my phone out (after 10 minutes) and the phone rebooted...

    terminal says: failed to read from /sdcard/zImage (Bad file number)

    ran cwm app and get this:

    120-MacBook-2:Files owner1$ /Users/owner1/Desktop/1-click-clockworkmod-2.1-to-2.2/Files/cwm.sh
    Starting installation...
    failed to copy 'zImage-recovery' to '/sdcard/zImage-recovery': Permission denied
    RedBend Update Agent 6,1,14,1

    FOTA : Make Block Device Nodes
    lcd_init(498): start!
    lcd_init(507): fb0 open success
    lcd_init(514): width = 480, height = 800
    open device file: Permission denied
    bmldevice_get_size: bmldevice_open failed!src: /sdcard/zImage-recovery
    dst: /dev/block/bml8 partition size: 0x0
    part_size: 0x0
    reboot: Operation not permitted
    120-MacBook-2:Files owner1$

    I think the problem is coming from the kernel still working to write to the phone, but the phone gets disconnected from the Mac right before it reboots (casued by the EA28 update). Therefore, the installation cannot be completed. Therefore, I can't run cwm.app to finish the install.

    Is there any way to fix this?
    03-25-2011 12:10 PM
  25. Braydon525's Avatar
    I think the problem is coming from the kernel still working to write to the phone, but the phone gets disconnected from the Mac right before it reboots (casued by the EA28 update). Therefore, the installation cannot be completed. Therefore, I can't run cwm.app to finish the install.

    Is there any way to fix this?
    Well the zImage never gets copied, and thats the kernel that gets installed. So the phone is just freezing after the root exploit is run...

    I'm out of town this weekend, but I will be back on Monday and I can screen share with you to try and get this working. I've also been updating the scripts that check for phone connection before continuing the installation. So I finish, that alone will probably make it work.
    newBjo3 likes this.
    03-26-2011 10:57 AM
385 ... 7891011 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD