1. semmelbroesel's Avatar
    Hi.
    My wife and I like to take our phones on walks and record them using GPS and My Tracks.
    Next time we'll try the compass calibration to improve GPS accuracy - thanks for that! :-)
    But here's the question:
    Last week, I couldn't get a good read on my location. It sorta knew where I was, but not very accurately.
    So I closed My Tracks and opened GPS Status to reset the GPS state and re-download the GPS information. It took me a while to realize that GPS Status was not getting a GPS response at all.
    I turned GPS off and back on - still no response. None of my programs could access GPS information anymore.
    Later I rebooted the phone, and GPS was back again.
    So my guess is that some part of the GPS system (hardware or software) had frozen.

    Does anyone know of a program or method to fix a seemingly frozen GPS system?
    I'm thinking that maybe restarting a background task or something might do that, but I don't know enough about the Android system to know what to mess with.

    Thanks!
    07-05-2011 08:20 PM
  2. atomD21's Avatar
    How are you turning it off and on? If you're only using the status bar pull down, try going into Settings>Location & Security and turn it on and off that way. If you're using both, then I'm not sure.
    07-07-2011 07:35 PM
  3. semmelbroesel's Avatar
    Oh, good point - I'm only using the status bar pull down...
    Would have been nice if I had seen your reply 30 minutes ago :-) My car dashboard sometimes doesn't work, so I use my phone's GPS as a speedometer - and of course my GPS also failed :-/
    I had to reboot the phone. I'll try the Settings next time and report here.
    Thanks!
    07-07-2011 10:41 PM
  4. semmelbroesel's Avatar
    OK, I tried it, and it did not do it for me...
    I had to reboot my phone to get GPS to work again.
    My symptoms were: The app Speedview couldn't get a proper location, so I closed it and ran GPS Status - which found 0 satellites. So I turned that off, too, and tried the fix suggested here (use the Phone Settings to turn off GPS). Turned it back on, still 0 satellites found by GPS Status (also tried the program reset and GPS data download features without success).

    So at least in my case, I'm still looking for a program or trick that can potentially detect if the GPS chip or service or whatever is in fact frozen and can unfreeze it or otherwise make it available for use again. My phone is rooted, so maybe there's a terminal entry I can use...?
    07-10-2011 07:21 PM
LINK TO POST COPIED TO CLIPBOARD