1. hawkphotography's Avatar
    I have some apps that show update available, and I've got the auto-update feature checked but the auto-update doesn't in fact update them.

    Google shopper is one, and now Shazam. Any way to force the update other than uninstalling and reinstalling the new version of the app?
    09-12-2011 08:45 AM
  2. mikethemedic's Avatar
    Did it need for you to access permissions? Auto update will not work if there are permission changes.
    09-12-2011 03:08 PM
  3. hawkphotography's Avatar
    huh? both apps waiting for update have auto-update turned to yes.
    09-13-2011 09:02 AM
  4. Kevin Gossett's Avatar
    What mikethemedic was talking about is a bit different from just having the auto-update feature turned on. If the permissions of the update have changed from the previous version, you have to confirm the permission changes before it will update. When you click on update, it should ask you to allow certain permissions if this is the case
    09-13-2011 11:10 PM
  5. hawkphotography's Avatar
    it doesn't even get to that point. It shows there's an update, but never downloads software to initiate the update.
    09-14-2011 07:48 AM
  6. hawkphotography's Avatar
    I NEVER use the android app website but I tried today. I tried to download shazam straight from the site, and it says my device has some content rating that prevents it from dowloading-- incompatible content rating. WTF is that???
    09-14-2011 09:46 AM
  7. hawkphotography's Avatar
    ok- just did a factory reset, since I had some other things wrong too. Apps now updating like they should,.
    09-14-2011 11:35 AM
  8. Sta11i0n's Avatar
    What others were trying to say is even if you have the option to update automatically enabled, if there's any changes to the permissions for the app (what it can access on your phone) you need to manually update it. To do this you have to select the app from your "My Apps" section and actually press the update button. It will then have you press another button to agree to the permissions access and download it. It won't download first and ask you to agree later like I'm assuming you're thinking. It's just like when you install an app for the first time.
    09-14-2011 11:39 PM
  9. hawkphotography's Avatar
    I understand what should happen, but that didn't happen. No button showed up to manually update. Anyway- it's fine now after the reset.
    09-15-2011 06:25 AM
  10. Landshark's Avatar
    I understand what should happen, but that didn't happen. No button showed up to manually update. Anyway- it's fine now after the reset.
    You may need to uncheck the auto-update box before the button for manually updating will appear. Also with the new market I have found some apps show up in my update list, but when I click on them I also have that issue of no update button being there. For those apps, I wait until I have one other app to update beside that one, then click the "Update x2" button above the apps which will update all the apps manually
    09-17-2011 01:37 PM
  11. hawkphotography's Avatar
    yeah- I tried both version you mentioned, but no luck. Either way, I'm not going to sweat it anymore- appears I'm not alone.
    09-17-2011 04:10 PM