1. firephoenix's Avatar
    Ever since i updated to GB and updated Google maps to 6.0 i have not been able to use google maps. When i open maps it freeze's my phone and have to do a battery pull and reset to get phone working again. Is anyone else having this problem ? I have uninstalled and re installed Google maps several times but same thing keeps happening. Anyone have any idea's?
    12-18-2011 05:09 PM
  2. double p's Avatar
    I had the same problem. I had to delete it and started using waze Not as accurate but it works.

    Sent from my SCH-I500 using Tapatalk
    firephoenix likes this.
    12-18-2011 11:33 PM
  3. Nightscape's Avatar
    My phone has been doing that even before the GB update. sigh..
    12-19-2011 03:16 AM
  4. firephoenix's Avatar
    I'm wishing i could go back to pre 6.0 google maps it worked fine till i updated. I used google navigation alot at work so now i'm stuck using mapquest.
    12-19-2011 02:02 PM
  5. itderanged's Avatar
    Similar problem here, but with navigation part. I got it to work for part of a day by uninstalling, rebooting, and installing again. Wonder if anyone is actually working to resolve the issue. Counting the months until my upgrade, 6 to go....
    12-28-2011 11:13 AM
  6. icu's Avatar
    I know there is a package that can help with this, but it requires root.

    I would be surprised if older versions of maps weren't available somewhere but I don't know where they would be.

    Also don't battery pull hold down Volume Up and power to restart.

    SCH-I500 Tap, Tap, Taparoo
    12-28-2011 11:57 AM
  7. firephoenix's Avatar
    I finally got maps to work for me. I rooted phone and reinstalled google maps, then used tibu to wipe app data and so far so good has been work last few days. No freezing or locking phone up, both nav and maps working fine. I stayed stock after root just used tibu to freeze and delete unwanted apps.
    12-28-2011 03:51 PM
  8. frizzlei's Avatar
    What is tibu and how do you root the phone. Could you please supply a bit more detail for the new guy......

    01-01-2012 02:10 PM
  9. semmelbroesel's Avatar
    It took me a while, but I think tibu means Titanium Backup. You can backup, restore, freeze and delete apps and data, but it requires root access.
    You'll find rooting instructions all over the place - there's even a sub forum to this one (on top of the topic list for this forum) specifically for rooting and other hard core topics.
    01-03-2012 08:48 AM
  10. semmelbroesel's Avatar
    Ah, thanks for confirming my suspicion :-)
    01-03-2012 08:44 PM
  11. fascinatej's Avatar
    I have this same problem , google maps hasn't worked since the gb update. I hate this it worked flawlessly before. never had any of the gps problems others had. It looks like my gps is broken. tried the waze that froze up to
    01-27-2012 08:02 AM
  12. firephoenix's Avatar
    The method i discribed in above post worked for about a 3 days but then started the same problems all over again. So i uninstalled and evenually found a google map 5.0 apk and installed. its been one week and so far so good no problems yet.
    01-31-2012 05:03 AM