1. Pendraegon's Avatar
    Hey guys, just picked up the Fascinate yesterday. I love the phone but I'm having a problem that may be a dealbreaker for me. I can't connect to the work guest network, and just briefly talking to an IT guy they don't support phones on the full network. The network has an initial redirect for you to agree to the terms of the network whenever you log on. I figured out the IP address for this and got the agreement to come up but then I still get the "can't connect to secure network" error afterwards. (I think that's the error message, I didn't write it down and I'm not at work right now). I had an I pod touch that would go through the redirect just fine and allow me to get on the wifi. Do I need to root the phone? I've tried the default browser and dolphin hd, but get the same error on both. Thanks for any help.
    10-30-2010 10:04 AM
  2. o4liberty's Avatar
    You should have no problem connecting did you try to pull your battery? I have to do it every few weeks for some reason.
    10-30-2010 10:19 AM
  3. Pendraegon's Avatar
    I tried removing the battery without luck. I still get the error" Data connectivity problem. A secure connection could not be established" Is there any way that I can set this thing so that it doesn't care if the connection is secure? I've also performed the one click root and have launcher pro running if that makes a difference. Thanks
    10-31-2010 09:15 AM
  4. o4liberty's Avatar
    I am not sure but rooting might of changed your settings I would look at that first.
    11-01-2010 09:27 AM
  5. NickA's Avatar
    Rooting is most likely not the cause. Does your network want to download some kind of certificate for authentication? Go into your browser settings and allow popups temporarily. Maybe you are being prompted for verfication and don't know it.

    Also, there are some other security settings when setting up the wi-fi, enterprise is one of them I think. Maybe try that setting and see what happens.

    Make sure you are able to accept cookies as well.
    11-01-2010 09:56 AM
  6. Pendraegon's Avatar
    Thanks for the replies. It didn't work before rooting and I haven't had any change since then. I have cookies enabled and popup enabled as well. When I manually enter the address of the redirect page it comes up. The initial page shows a link to "access internet" when I click that I get a screen with terms and conditions, when I hit accept I get the error message and can't access the internet. I can't find enterprise in any of the internet settings on the default browser or dolphin HD.
    11-02-2010 01:15 PM
  7. joebob2000's Avatar
    Do they send all traffic through a proxy? It might not be a question of whether or not you can connect to the wireless network; if you cannot get your browser to work through the proxy you will never see the "internet at large" for all intents and purposes. Knowing what security mechanism is in use is critical.
    11-02-2010 01:23 PM
  8. gmr2048's Avatar
    I'm the IT guy at work, and I couldn't get my Fascinate to connect to the wireless network that *I* built. I originally had the network set to not broadcast its SSID (name). When I enabled SSID broadcast, I was able to connect no problem.

    11-02-2010 01:33 PM
  9. joebob2000's Avatar
    I'm the IT guy at work, and I couldn't get my Fascinate to connect to the wireless network that *I* built. I originally had the network set to not broadcast its SSID (name). When I enabled SSID broadcast, I was able to connect no problem.

    You can absolutely use non-broadcasting networks with the Fascinate; you just need to force the settings in instead of waiting for the scan to find it. Hint: the fields are case-sensitive and the keyboard likes to flip between capitalizing words and not.
    11-02-2010 01:39 PM
  10. Pendraegon's Avatar
    Just talked to a friend here with the HTC evo, she's able to connect with no problem. My phone says it's connected to the wifi, just can't see anything other than the log in screens and that's only when I manually enter the IP address. I'll try to talk to the IT guys today to get an answer on the security.
    11-02-2010 02:21 PM
  11. Mu9enx's Avatar
    I have the same problem when I try to login to my school's network. What I do is keep reloading the page, and sooner or later I am actually able to get into the login screen where I enter my user and pass. After that I'm set; but initially it's a piece of work to even get to the logging in screen
    11-02-2010 04:31 PM
  12. Pendraegon's Avatar
    So I talked to some it guys and they couldn't figure out what was going on either.one has an old android phone that hooks up with no issues. Is my phone defective or something? Why does it seem like all other android phones connect and this one doesn't should I wait for 2.2 or is my phone a lemon?
    11-02-2010 06:35 PM
  13. Mu9enx's Avatar
    My friend says this works with his phone, as we go to the same school and has trouble connecting. He told me to download the Firefox browser, and that he uses that to initially get to the login screen. After he's set, he just uses the stock browser to surf, etc.
    11-03-2010 06:10 PM
  14. Pendraegon's Avatar
    Thanks for your help. firefox actually will connect. I wonder why the others wouldn't. Oh well, I have my solution.
    11-10-2010 10:19 PM