1. zagfan's Avatar
    Please Help.

    My Fascinate works fine for a few days but frequently I try to wake phone with power button but screen stays blank. Buttons across bottom light but screen stays blank. Pulled battery and tried to restart and could hear startup but nothing on screen. Sometimes keep pressing power button repeatedly and screen will turn on. Will work for a day or so but then above problem repeats. Last phone could never get screen to turn on so they sent me a replacement.

    This is second phone with same problem. I deleted all my downloaded apps but this has not solved problem. Please I don't want to return to my BB Storm.

    Phone is stock:

    Firmware: 2.1-update1
    baseband version s:i500.04 V.EA28
    build number SCH-I500.EA28

    Thanks for your help.
    03-08-2011 12:48 PM
  2. MrSmith317's Avatar
    You might have a bad power switch, take it back to a verizon store and get a replacement.
    03-08-2011 02:44 PM
  3. gunnermike53's Avatar
    Please Help.

    My Fascinate works fine for a few days but frequently I try to wake phone with power button but screen stays blank. Buttons across bottom light but screen stays blank. Pulled battery and tried to restart and could hear startup but nothing on screen. Sometimes keep pressing power button repeatedly and screen will turn on. Will work for a day or so but them above problem repeats. Last phone could never get screen to turn on so they sent me a replacement.

    This is second phone with same problem. I deleted all my downloaded apps but this has not solved problem. Please I don't want to return to my BB Storm.

    Phone is stock:

    Firmware: 2.1-update1
    baseband version s:i500.04 V.EA28
    build number SCH-I500.EA28

    Thanks for your help.
    broke phone. warrenty replace.
    03-08-2011 02:47 PM
  4. zagfan's Avatar
    I had the same problem with my old phone. Now the replacement is doing the exact same thing leading me to think that there is a problem with my google account, facebook account, contacts, emails, or something that is causing the problem.
    03-08-2011 03:07 PM
  5. Drootz's Avatar
    I had the same problem with my old phone. Now the replacement is doing the exact same thing leading me to think that there is a problem with my google account, facebook account, contacts, emails, or something that is causing the problem.
    Are you running NoLed? If so try hitting the power button on the side so the bottom buttons light up,
    then press either the home button on the bottom,
    or the back button on the bottom. Hopefully your screen should illuminate after that. But only if you are using NoLed.

    If not, I would take it back and ask for a another phone.

    Also you gotta remember once you replace your phone you are getting re-furbished units which may have been returned by someone else because of some issue (maybe they found and fixed the issue maybe they didn't if they couldn't replicate it) so it may take a couple of phone replacements.
    03-08-2011 03:28 PM
  6. zagfan's Avatar
    Originally I thought noled was causing the problem in my old phone so I deleted it. That did not solve the problem. On my replacement phone I have no apps except the ones that came preinstalled on the phone.

    Sometimes the screen comes on when I press power button and sometimes it doesn't. Kind of hit and miss. Both phones (original and replacement) behave exactly the same. When the screen does turn on sometimes it has lots of bright horizontal lines and the touchscreen doesn't work. I have to turn screen off and on several times until it works properly.
    03-08-2011 09:29 PM
  7. Kevin Gossett's Avatar
    Definitely sounds like a hardware failure, and you should try again for a replacement
    03-08-2011 09:35 PM
  8. tnez21's Avatar
    yep take it back for another one. my wife went through 3 Fascinates all wit the same issue.
    03-08-2011 09:53 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD