1. RadRacer513's Avatar
    My wife has had her Fascinate for about 6 months now and has liked it. Until the dreaded 2.2 update that is. Ever since, her battery life is ****, camera doesn't work, slow as hell, and she's ready to toss it out of the car (wishing I kept the insurance on it now so she could). The phone's never been rooted, and she doesn't want it rooted. I've gone through and messed with the usual settings; brightness down, black wall paper, gps off, wifi on at home and her office (poor 3G in both spots, so this should save battery, right?), syncing turned off or to the absolute minimum, etc etc. Any other suggestions? Before the phone lasted a solid day with her usage (quite abit), but now she barely makes it through work. It's been off the charger for 6hrs and is at 13%... I'm going to try and recalibrate the battery tonight, but any other suggestions? I'm very tempted to go to Verizon tonight and complain; the phone was fine until this update. And, no matter how much I try to convince her, she does not want me to root it
    05-05-2011 01:12 PM
  2. NickA's Avatar
    Mine did the same thing. I would end the day with around 60%. After the update I'm be between 15-20%. I turned off wi-fi and that helped a lot. But lately it seems like the battery has been getting better. So maybe after a few charge cycles it will get back to normal.

    I did root and debloat as well, but was still getting poor battery life even after that. But like I said, for the last week the batter has been pretty good.
    05-05-2011 01:41 PM
  3. RadRacer513's Avatar
    Yeh, I wanted to debloat it for her too, but installed launcher pro just to hide them all for her :P
    05-05-2011 02:08 PM
  4. Stain77's Avatar
    My wife has had her Fascinate for about 6 months now and has liked it. Until the dreaded 2.2 update that is. Ever since, her battery life is ****, camera doesn't work, slow as hell, and she's ready to toss it out of the car (wishing I kept the insurance on it now so she could). The phone's never been rooted, and she doesn't want it rooted. I've gone through and messed with the usual settings; brightness down, black wall paper, gps off, wifi on at home and her office (poor 3G in both spots, so this should save battery, right?), syncing turned off or to the absolute minimum, etc etc. Any other suggestions? Before the phone lasted a solid day with her usage (quite abit), but now she barely makes it through work. It's been off the charger for 6hrs and is at 13%... I'm going to try and recalibrate the battery tonight, but any other suggestions? I'm very tempted to go to Verizon tonight and complain; the phone was fine until this update. And, no matter how much I try to convince her, she does not want me to root it
    Does she use the "Feeds And Updates" widget? I had all kinds of trouble with my battery life and my phone being bogged down and sluggish when I was running that widget with 2.2. Once I removed it from one of my home screens the problems started clearing up... Just a suggestion...
    05-05-2011 02:11 PM
  5. RadRacer513's Avatar
    Does she use the "Feeds And Updates" widget? I had all kinds of trouble with my battery life and my phone being bogged down and sluggish when I was running that widget with 2.2. Once I removed it from one of my home screens the problems started clearing up... Just a suggestion...
    No, shes using Launcher Pro and nearly no widgets; Just the calendar and Tesla LED I believe
    05-05-2011 03:00 PM
  6. Landshark's Avatar
    Did you go into menu=>settings=>wireless & network=>wifi settings=>advanced=>wi-fi sleep policy and set it to when screen turns off? No sense in having the phone try to pull a wifi signal when the screen is off. With that setting, the wifi will wake up with the screen.
    05-05-2011 03:45 PM
  7. RadRacer513's Avatar
    Did you go into menu=>settings=>wireless & network=>wifi settings=>advanced=>wi-fi sleep policy and set it to when screen turns off? No sense in having the phone try to pull a wifi signal when the screen is off. With that setting, the wifi will wake up with the screen.
    Just did that. Didn't realize you could
    05-05-2011 07:13 PM
  8. thornbeck's Avatar
    One caveat with the Wi-fi sleep policy, if you are in a bad cell reception area it uses less battery when wi-fi is on and connected to an AP and the screen goes blank.

    - Tim
    Landshark likes this.
    05-06-2011 11:28 AM
  9. NickA's Avatar
    Did you go into menu=>settings=>wireless & network=>wifi settings=>advanced=>wi-fi sleep policy and set it to when screen turns off? No sense in having the phone try to pull a wifi signal when the screen is off. With that setting, the wifi will wake up with the screen.
    Thanks Landshark! I didn't realize you could do that either. Is that new in 2.2? I wondered why lately when I look at my phone the wi-fi is on, no matter how long it's been off.
    05-06-2011 02:58 PM
  10. TheANARCHY's Avatar
    There is a caveat to this tip from Landshark. If you are on an open, non-secure wifi network, such as say a Mcdonalds hotspot, the phone will wake from off an reconnect to the wifi. If however it is a secured wifi that requires you to accept a security certificate to use (which is better honestly for security purposes), then you will have to do that every time you wake the phone. It's a minor annoyance at first but like he says this does help the battery life.
    Landshark likes this.
    05-06-2011 04:32 PM
  11. ew.scott's Avatar
    I also found I was having poor battery life after 2.2 update. After screen adjustments, wifi, Bluetooth, gps ect settings I still was getting less than stellar battery life. I too am using Launcher Pro and remembered a suggestion when using launcher pro to remove all icons and widgets from touch wiz. I had previously removed them when on 2.1 but the 2.2 update put them back on TW and they were all running and updating. I removed them again and battery life is better.

    I would suggest if you havent done so already is grab a home switcher and go back to TW and make sure all icons and widgets have been removed.

    Also thanks Landshark, going to give the wifi sleep policy a try and see how that works. I pretty much stopped using wifi at home due to battery life since I get great 3g signal at home anyway.
    05-07-2011 03:07 AM
  12. cfox10's Avatar
    I was also getting poor battery life, and this is what worked for me.

    Download Screen Filter in market, it allows you to lower brightness even more than normal settings..It also allows you to turn off soft key back-lights, I use this until it's dark and I need the lights.

    Keeping as many colored things off the main screen as possible ie; icons, widgets, wallpaper, etc. really helped too, while having the black background.

    The one that helped me the most was charging my phone to 100 while it was on, turning the phone off, allowing it to 'finish' charging, turning it back on, and continuing to do so about 4-5 times. My battery seems to last MUCH longer after this.

    Hope it helps!
    05-07-2011 04:22 AM
  13. Rebelvis's Avatar
    I tried Landshark's advice yesterday and found it made a significant difference in battery life. Previously, I was ending the day with around 20% battery life post 2.2. Yesterday, I had over twice that. Thanks!
    05-07-2011 07:25 AM
  14. RadRacer513's Avatar
    Did the wifi sleep policy and while her battery's a little better, I still believe it should be better. With my Droid X I can get through a day with 80% left if I don't use it; with my usual email, browsing, etc I end with about 40% on the average day. She's usually close to 10%. I was told the fascinate has a Mich better battery, and I think I was lied to
    05-25-2011 07:18 AM
  15. piizzadude's Avatar
    the only things I can say are just because you hide the apps with LauncherPro, it doesnt mean they arent starting up in the background. I have gotten better life out of some of the kernels around here instead of the stock one, might wanna consider swapping it out
    05-25-2011 01:49 PM
LINK TO POST COPIED TO CLIPBOARD