1. JamesBob02's Avatar
    Hey everyone, first post here - I just picked up my first Android device (Verizon Galaxy Nexus) and I'm PSYCHED to get this thing going with some custom stuff!

    Anyways, first thing I did was the fastboot oem unlock, then rooted using SuperBoot. When I went to flash CWM Recovery, fastboot gives me the following: "error: cannot load [img filename]" (where [img filename] is whatever image I typed in). I've ruled out the possibilities that this is due to a file naming problem, file extension, upper case/lower case, etc. Also the image is in the same directory as fastboot. I've tried renaming the image to something simpler like "recovery.img" but that doesnt work either - it's like fastboot simply can't find any images.

    Any ideas? I'm completely stuck as of now. Thanks in advance!
    12-17-2011 01:40 AM
  2. Cyber Warrior's Avatar
    You could use the app ROM Manager if you want to flash CWM Recovery.
    12-17-2011 01:46 AM
  3. JamesBob02's Avatar
    Ok thanks I'll give that a try. In the meantime, any ideas why I'd get this error?
    12-17-2011 01:51 AM
  4. ajw20's Avatar
    I'm having the same problem. Anyone know why this could be?
    12-18-2011 12:56 AM
  5. davidnc's Avatar
    So using Rom Manager is another way of getting CWR on nexus and making a backup.
    It flashes the same Clockwork ?

    I guess will still have to delete or rename the file in root exployer "recovery-from-boot.p "?

    Sent from my Galaxy Nexus using Tapatalk
    12-18-2011 01:51 AM
  6. reverepats's Avatar
    yeah u gotta delete the file first. I fastbooted it. For anyone whos is trying to fastboot it, amek sure its in the same folder as your fasboot.exe Or else it won work
    12-18-2011 09:25 AM
  7. mailliw1996's Avatar
    I have an mid7022 and I flashed a bad recovery (a version of Clockworkmod) and this wont load the stock recovery i downloaded or a new Clockworkmod and it gives me the same error message "cannot load blah blah blah" I really need a recovery.
    05-24-2012 06:00 PM
  8. hashDefine's Avatar
    I did put the CWM image file in the same folder as my adb and fastboot files. but I get the same error .. working on Nexus 7
    09-19-2013 07:24 AM
  9. hashDefine's Avatar
    Solved .. after rebooting .. navigate through the fastboot, using volume buttons in Nuxus 7, to the Recovery Mode option .. then type in the shell in your PC the command to flash the image file to the tablet and VOILA ..

    NOTE: don't use the full path of the file (i.e.: c:\bla\bla\recovery.img) and make sure the recovery file is in the same folder where adb and fastboot files are ..
    09-19-2013 07:37 AM
  10. scarryman04's Avatar
    If your using Windows make sure you put your recovery.img in the same directory as ADB:
    cd to the adb/fastboot directory ie. cd C:\ADB
    adb reboot bootloader
    fastboot flash recovery recovery.img

    If your using Linux/Unix:
    cd to where your recovery.img is ie. cd /home/username/Desktop
    adb reboot bootloader
    fastboot flash recovery recovery.img
    09-21-2013 12:02 AM
  11. hashDefine's Avatar
    when I tried to flash the recovery into the second Nexus 7 tablet .. it fails to flash the recovery-image file .. I am working on windows and I followed my solution up there but it is not working .. either your solution ..
    the image file is in the same folder as adb and fastboot

    here are the steps I am following:
    - start the tablet's OS, and the device works fine
    - I restart the tablet into the bootloader using: adb reboot bootloader
    - browse to the Recovery Mode and then check if the adb sees the tablet: fastboot devices (adb is working fine and can detect the device and read its serial number)
    - then when I flash: fastboot flash recovery recovvery-clockwork.img: I get this error:
    error: cannot load 'recovvery-clockwork': No error

    am I doing something wrong
    09-26-2013 06:48 AM