1. androidluvr2's Avatar
    4.2.2 has a security feature called a debugging whitelist such that USB debugging is not allowed unless you have specifically allowed it for the computer your phone is plugged into based on its RSA fingerprint. What this means is if you have USB debugging enabled, when you plug your phone into your computer's USB port, you are supposed to get a prompt asking you to allow USB debugging for your computer based on the RSA fingerprint of your computer.

    I did not get this prompt when I plugged my phone into my computer and it was preventing me from rerooting after I lost root when I flashed the OTA 4.2.2 update. It has something to do with the drivers. I can't tell you why the drivers don't act right for some people but for me they don't and I know I have the right drivers installed.

    When I connected my GNex to my computer and typed the command "adb devices" at the command prompt, it showed me the serial number of my Galaxy Nexus and said that it was offline but I did not get the prompt.

    Here is the fix I used to get the prompt. I made sure I had the latest versions of adb.exe and fastboot.exe on my computer, connected my phone to my computer and typed adb reboot bootloader to get into the bootloader. Then I uninstalled any drivers for Galaxy Nexus or Samsung Android Phone that were installed in Device Manager and checked delete the drivers, disconnected my phone from my computer and then reconnected it. When I did, my computer tried to reinstall the drivers but couldn't and identified the device as "Android 1.0." in my Device Manager. I right clicked Android 1.0 and hit update drivers and then "browse my computer" and then "let me pick." I picked Samsung Android Phone and Samsung Android ADB interface and that driver was installed. Then I got the prompt and could allow USB debugging for my computer.

    This is a picture of the prompt I am talking about:

    03-07-2013 03:00 AM
  2. infinitely's Avatar
    I just downloaded the latest android SDK with Android SDK Platform tools version 16.0.2 and adb version 1.0.31 and I still get the 'error: device offline'.
    I tried different usb cables, different USB ports (in the back of my PC, directly to the motherboard) and have rebooted my phone and computer several times. This little program recognized my phone's adb connection and allowed me to install the driver.
    I'm using windows 7 ultimate 64 bits and my phone is the xiaomi mi-one.
    My phone bricked when I tried to install the latest MIUI v5 (3.5.10) rom with Jelly bean kernel from miuiandroid.com

    Will I ever be able to fix this brick?
    05-11-2013 06:10 PM
  3. ljschiefer's Avatar
    I recently ran into this problem with my Nexus 7 on Win7 with the latest Google USB driver (7), SDK tools (22.0.1) and SDK Platform tools (17). Try as I might it would not show up nor prompt me for the RSA keys. The really odd part is the adb driver is installed properly and bound to the device. The same device works fine under Linux. What I had to do was go on the device and pull down the status bar to look at notifications then select the item to pick "Other USB options". By default the device was connected in MTP mode. Once I switched it to be in PTP (Camera) mode, the adb driver would get "installed" and initialized like before. However, now the Nexus prompts me with the RSA key of the Win7 machine and once I accept it adb can see the Nexus and work with it.
    causa45, di3cbl and Aditya Gulia like this.
    07-02-2013 06:37 AM
  4. Shahin Ansari's Avatar
    Thanks for this post. It helped me find my way also. My situation was a little different, and so was the solution. I have a Samsung Note 3, which I had to flash with stock firmware after I messed it up:-) When I connected my phone to the pc, I would get the prompt "connected as media", and was able to connect to it with Kies. But I was not able to get an adb connection. I also did not get the prompt on the phone to authorize the debug session to my pc. ( The same message you have in the pic above ) I did not get that. So I kept deleting the drivers from device manager, but the darn things kept coming up, and every time I connected my phone I was in the same situation. The very last time, I decided to click on the message you get on the far right hand side at the bottom about not being able to install the driver successfully, and that gave me this windowWindows 7 Android 4.2.2 ADB device offline and no prompt to allow USB debugging-solution.jpg. I then clicked on "skip downloading from windows update link", and as soon as I did that voila; it worked. I saw the above prompt on my phone, and saw the phone id in the output of adb devices. Thank you so much. I sincerely hope my post helps someone else. This was annoying issue.
    04-09-2014 08:39 AM
  5. TigerG8's Avatar
    So I appreciate everything that you guys have done so far with these solutions.. but i just cannot seem to get my Sprint Note 3 to register as online in ADB. i've restarted, i've tried deleting a reinstalling different drivers. nothing seems to work for me.
    10-13-2014 08:09 PM
  6. TigerG8's Avatar
    ok, so an update:

    got it working! first, i changed the usb port.
    then, i ran these commands:
    adb kill-server
    android update sdk --no-ui
    adb start-server
    then revoke usb debugging authorizations, then disable usb debugging, and then enable usb debugging. after a few seconds of staring at my phone, the RSA dialogue appeared. back in business.
    10-13-2014 08:42 PM

Similar Threads

  1. [TOOL] [BETA] [Windows] Android Flash Recovery
    By bill.weckel in forum AT&T LG Phoenix/Thrive
    Replies: 29
    Last Post: 09-18-2013, 11:09 AM
  2. Eyecandy for Your Android
    By Addie_Goodvibes in forum Wallpapers, Ringtones, and Themes
    Replies: 2
    Last Post: 09-13-2010, 12:31 AM
  3. Android Phone Codes for your EVO
    By storino03 in forum Sprint
    Replies: 22
    Last Post: 08-20-2010, 06:50 PM
  4. Replies: 3
    Last Post: 07-16-2010, 09:41 AM
  5. Replies: 3
    Last Post: 06-01-2010, 01:49 AM
LINK TO POST COPIED TO CLIPBOARD