07-06-2013 01:18 PM
40 12
  1. sicario666's Avatar
    hmmm... clearing data... does that delete the text messages? (i have some that can not be deleted)
    sadly...yes. but it may clear your problems. Unless there's another fix. I'll test it out now and let you know if it erases everything.

    Sent from my Galaxy Nexus using Tapatalk
    01-25-2012 10:10 PM
  2. sicario666's Avatar
    OK...do this at your own risk. It did not delete my conversations. I hope it doesn't delete yours. But at your own risk... I'm not sure what info you have that can't be erased.

    Sent from my Galaxy Nexus using Tapatalk
    01-25-2012 10:12 PM
  3. Coleus's Avatar
    I had this problem a couple of times, too. MMS just sat there saying "sending" but never got sent.
    01-26-2012 01:16 AM
  4. Nothing2Lose's Avatar
    Yea, i have the same problem. I think its not switching to 3g/4g while on wi-fi. Its been mentioned a few times in the bug tracker thread. No real solutions yet.
    01-26-2012 02:08 AM
  5. sisblub's Avatar
    Dumb question: are you supposed to be able to receive and send MMS on wifi?

    Sent from my Galaxy Nexus using Tapatalk
    01-26-2012 03:27 PM
  6. alphanu22's Avatar
    Dumb question: are you supposed to be able to receive and send MMS on wifi?

    Sent from my Galaxy Nexus using Tapatalk
    nope, MMS is a Carrier Service-
    sisblub likes this.
    01-26-2012 03:27 PM
  7. sicario666's Avatar
    nope, MMS is a Carrier Service-
    Beat me to the punch :thumbup:

    Sent from my Galaxy Nexus using Tapatalk
    01-26-2012 03:30 PM
  8. ScottiePP7's Avatar
    I have had this problem too, never even realised it was only when I was on wifi but now it all makes (some kind of) sense
    01-26-2012 04:21 PM
  9. rahlquist's Avatar
    Wifes bone stock nexus S does this too. I have tried with wifi on and off, I have not tried deleting all of her messages. Between this bug and the way they jacked the screen colors over with the updates google is starting to get under my skin.
    02-09-2012 02:46 PM
  10. fivegear's Avatar
    I know this thread is a little old but I have a couple things to add. Just before leaving Sprint for Verizon I had a Samsung Epic (1st gen Galaxy) and had no carrier data at all, none, was not set up on the phone. I could send MMS whenever I was connected to WiFi but never any other time due to Sprint data not being active on the phone. Now this leads me to believe that MMS can be sent over WiFi if the carrier allows it. Now on to the Verizon phones. We have 3 Samsung Galaxy S3 phones on the account, 1 Galaxy Note 2, and a HTC Droid DNA. All of the S3 phones suffer from MMS issues, you never know what your luck will be sending or receiving them. Most times a reboot is required to send anything. The Note 2 and the DNA don't seem to have any issues at all with this. I don't know if this helps or not but I thought I would share.
    phathands likes this.
    02-21-2013 09:55 AM
  11. phathands's Avatar
    I've had issues sending MMS, multiple recipient text messages. They seem to hang up, and may send days later. It's embarrassing. I don't seem to have any trouble receiving them. I try rebooting (doesn't seem to fix it), force stopping messaging app (again, no fix). When I turn off Wi-Fi they still don't send, until I try to send another. At that point they all go through. What a mess. My brother (also a VZW GNex) has a similar issue. My other brother (iPhone on VZW) doesn't.
    04-04-2013 06:02 PM
  12. Pollster's Avatar
    Just had this on vacation after turning WiFi on for the first time in a year. FYI, I was not near the WiFi when I sent the MMS.
    I've read a similar thread in the Nexus 4 forum, so it may be a 4.2.2 thing.
    04-05-2013 01:39 PM
  13. phathands's Avatar
    Just pinging back on this thread. On the G Nexus (still on VZW), the MMS thing has been better and we as a family can group message most of the time. Occasionally messages get hung as "sending", but making switching to 4G from WiFi and then entering another message helps.

    However, just bought a used S3 to play with, and sending a group message (though it says "group message" and MMS on my phone) is received by the recipients as SMS (or in the case of a group photo sent to several people, they receive it as an individual message sent to them alone). Very annoying.

    Any ideas? Or is this thread entirely dead?
    06-30-2013 02:15 PM
  14. jlgraham's Avatar
    I have never been able to send pictures over wifi with my Gnex. No matter which network I am connected to, I always have to switch WiFi off (usually before I even try to send, for best results) before the picture will go out. Can't remember if I can receive pictures while on wifi, but I think so, don't remember that being an issue.
    phathands likes this.
    07-05-2013 04:46 PM
  15. rockdiesel's Avatar
    I also have this issue. When I want to send a MMS I need to turn off my wifi on my GNex, the phone connects to mobile network, then send the message. If I do this it will send with no problems. If I try to send with wifi on, it will just sit there and say 'sending'. I am able to send SMS with problems when connected to wifi.
    I have also had issues receiving MMS. Sometimes not receiving them at all and a handful of times where I would see the message in the notification bar, pull the notification bar down, see who it's from, tap on the notification, it opens up the messaging app and there is no message there. Very strange and annoying.
    07-06-2013 01:18 PM
40 12