1. octo996's Avatar
    Whenever I run google places and search for something (ex: car wash), it runs a search but then nothing happens.

    I will have to repeat the search 3-4 times before it "goes through" and I'm given a list of places; but even then, when I try to map it or get the address, it "resets" and I'm back at the google places search page.

    This problem happened before the google maps update yesteray, and continues today.

    I have google+ disabled, but the problem persists even with it enabled.

    Anyone have a similar problem, or am I the only one?
    01-11-2012 05:37 PM
  2. Danv1369's Avatar
    I just tried this out. the first time it did fail to do anything. I tapped the arrow next to the word places and it gave a list of map related apps. I chose places and tried again and it seems to work now.
    01-11-2012 06:21 PM
  3. samix's Avatar
    i had the same issue, tried what danv1369 suggested and now it works great
    01-11-2012 06:43 PM
  4. greydarrah's Avatar
    I have this same issue sometimes, and when it's doing it, even trying the suggestion above doesn't fix the problem. What does always work for me is to add a search (menu, add a search) with what I'm looking for and then clicking the new search. Most of the time I'm always using places to find the same types of things anyway (book store, cuban sandwich, gyro, etc...)
    01-11-2012 07:56 PM
  5. ragnarokx's Avatar
    I've noticed this in ICS as well. I usually just manually open Maps after doing a search in Places, and all the results are waiting for me in the Maps app.
    01-11-2012 08:49 PM
  6. Danv1369's Avatar
    Played with the app again this morning. Had the same issue as before, tried the same fix as I mentioned previously but this time tapped on Maps and then tapped on Places and search worked. I noticed when it searches it flashes Google maps then the goes back to Places and the search results appear. Anyone else notice this?

    Seems like there is some odd disconnect between places and maps causing the issue. Hopefully a fix comes soon. I went into settings and used the feedback option and sent the issue to google. Hopefully others do or have done same.
    01-12-2012 10:50 AM