1. barchamb's Avatar
    I've had my Nexus for about a week now. Under Accounts & Sync, I have a Corporate account for my work email. The Email app has been working find until a day or two ago. I have 4 messages in the app that won't go away. I mark them as deleted, the app says they are deleted, but a few seconds later, they all come back.

    If it was an app I downloaded from the Market, I would just clear updates and/or data from the app, or uninstall it and reinstall it. But, it's the built-in Email app so I can't do any of those things. Any ideas?
    02-06-2012 11:00 PM
  2. yosteve's Avatar
    Have you tried clearing the cache?
    02-07-2012 01:24 AM
  3. barchamb's Avatar
    Have you tried clearing the cache?
    I hadn't before - but I just tried that. Rebooted into recovery and cleared both the regular cache and the Dalvik cache. Restarted the phone and then went into the Email app and deleted the messages. Sat there for a few seconds and they all came back. :-(
    02-07-2012 09:42 AM
  4. barchamb's Avatar
    It appears to be a multi-select issue. If I open the ones that keep coming back when I delete them, and then delete them individually, it works. But if I multi-select some with the checkbox, then delete, they come back. Is there a Google site where I can file bugs like this?
    02-07-2012 12:02 PM
  5. barchamb's Avatar
    I lied - it's doing it again. And, I'm not multi-selecting or anything. I open the message, read it, then press delete. The little "Message deleted." toast pops up, the message disappears from the list, then about 5 seconds later, it comes back.

    There's got to be somewhere I can report this and get help. The only way I've found to fix it is to remove the corporate account and re-add it. Lame.
    02-24-2012 01:28 AM