1. STC09's Avatar
    This had happened a couple of times in the last month but 5x or more since yesterday. It happens for no apparent reason and forces a reboot which does not reestablish a data connection. The phone then needs a second reboot to work properly.

    I'm guessing this is simply a case of getting a new SIM but this is a rooted phone. Would I really need to relock it before taking it to the store? The year warranty expires in a couple of weeks but is this even part of that?
    12-04-2012 10:30 AM
  2. ConTejas's Avatar
    I haven't experienced one of these in ages, but IIRC just hit the back button and continue on, don't hit ok. That said, did you clean or dirty flash your current rom? Which rom? Either way, start with simply dirty flashing your current rom/gapps package. Wipe cache, wipe dalvik, flash rom/flash gapps, reboot. If it persits I'd clean flash a new rom. Also, did you bother pulling the battery and sim (leave out ~90secs)? Couldn't hurt, at the very list it'll ensure you "PRL" (preferred roaming list) is up to date. That's how it's done on LTE devices. I've seen recommendations to do it occasionally.
    12-04-2012 11:20 AM
  3. STC09's Avatar
    It's stock android via the latest OTA. Backing out of the prompt works but there's no data connection and rebooting is necessary anyway.

    I had pulled the card before but only for 30 sec so I'm trying it again.
    12-04-2012 11:53 AM
  4. ConTejas's Avatar
    It's stock android via the latest OTA. Backing out of the prompt works but there's no data connection and rebooting is necessary anyway.

    I had pulled the card before but only for 30 sec so I'm trying it again.
    Let us know how it goes. Also, personally I would unroot/relock my device to get a new sim card. Only if I was returning it for warranty etc.
    12-04-2012 03:09 PM
  5. STC09's Avatar
    It seems to have worked - no more data drops.

    ConTejas likes this.
    12-06-2012 11:03 AM
  6. mark425's Avatar
    This also happed to me, 3 times so far. I contacted Verizon and they sent out a new sim card. Works fine now

    Sent from my Galaxy Nexus using Android Central Forums
    12-08-2012 11:07 AM
  7. STC09's Avatar
    It's starting again.

    Other issues: screen not registering initial touches and Swype ignoring the personal dictionary.
    12-14-2012 11:51 AM
  8. AndroidSF09's Avatar
    Hi STC09,

    Sorry to re-start a dead thread, but I'm having the same trouble and it likewise started happening a few times a day yesterday vs. once in a blue moon previously. Were you able to resolve your issue or did you end up needing to get the SIM card replaced?

    m.c.rime likes this.
    05-07-2013 02:00 PM
  9. STC09's Avatar
    It's cropped up a couple of times since but pulling the card for a minute takes care of it until the next time.
    05-07-2013 06:14 PM
  10. Steve Innes's Avatar
    this issue is happening all over e nothing but a headache. My carrier is Singtel and they have no resolution for the problem
    m.c.rime likes this.
    07-07-2013 03:39 AM
  11. jabailo's Avatar
    This happened to me today on my LG F3.

    Background was that I removed the cover and battery and lightly sprayed some keyboard cleaner to remove the grime that had built up around the edge.

    After drying and reassembling, that message would come on after restarting.

    Multiple reboots did not fix, and removing battery again did not fix.

    Also pushing card half way out and reseating did not work.

    Finally, I took the card all the way out and noticed that it was grimy on the contacts side. Some of the cleaner might have gotten in there and dissolved the grimey bits and caused it not to connect.

    I used compressed air on it and and on the mounting slot on the phone. And I used very minimal cleaner and a soft cloth to clean the mess off the card. Then I reinserted the SIM card firmly, added the battery and restarted.

    So far, no more SIM card messages.
    06-25-2015 03:13 AM
  12. medupedia's Avatar
    I got the same issue, after doing cache cleaning (i.e settings>General>Storage & USB>Cached Data) and forced disabled "Lookout" security app. i have restarted my phone.
    It worked for me.
    Hope it helps everyone.:-
    05-26-2017 01:04 PM

Similar Threads

  1. Random "No Sim Card" Icon and dropping signal randomly
    By PalmPrePlusPwns in forum Verizon Droid DNA
    Replies: 47
    Last Post: 09-11-2014, 05:15 PM
  2. SIM card removed error
    By veblenian in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 12-29-2011, 07:18 AM
  3. remove "please insert a sim card" mytouch 4g
    By bxborn31 in forum General Help and How To
    Replies: 2
    Last Post: 12-16-2011, 12:57 PM
  4. Had SIM card replaced due to data signal issues.
    By Clak in forum Verizon Droid Charge
    Replies: 7
    Last Post: 11-19-2011, 06:09 PM
  5. Contacts, sim card, SD card, and Google sync issues
    By metalhead0 in forum AT&T Inspire 4G
    Replies: 1
    Last Post: 04-14-2011, 09:33 PM