1. androidluvr2's Avatar
    This sucks. Never had a problem with my bluetooth before 4.2.2. Now my devices (motorola and plantronics) won't stay connected even right next to the phone.

    It happened on the leaked 4.2.2 OTA and now on the official 4.2.2 OTA. It did not happen on 4.1.1 before I updated to the leaked 4.2.2 OTA or when I went back to 4.1.1 to receive the official 4.2.2 OTA.

    This I can't live with because I use bluetooth almost exclusively for my calls since the external speaker is so bad.
    03-22-2013 05:28 PM
  2. famouzstarz#AC's Avatar
    BT in JB is a known issue revert back to 4.1.1

    or root and flash a custom rom, isnt that why you have a nexus anyway?
    androidluvr2 likes this.
    03-22-2013 05:51 PM
  3. pontiac005's Avatar
    Try turning on BT on the phone and then turn on the headset. If that does not work, do the opposite. I don't use BT very often but when I do, it will sync and stay connected. I am also running 4.2 2 on my Nexus.
    androidluvr2 likes this.
    03-22-2013 06:00 PM
  4. waldo15's Avatar
    Something I have noticed on my GNex regarding BT

    • When I updated from 4.0 to 4.1, and then to 4.1.1 I had to clear out any BT devices I had in there and pair them up again from scratch. This helped improve connectivity (though not quality of connection).
    • Even in 4.1.1, there are certain instances that if the phone is connected to a hands free/wireless headset it will soft-reboot itself.
    • As of recent, my Jawbone will show up as connected to the phone but yet the phone will not route audio to the Jawbone. Time to remove the headset and pair up again.



    I'd suggest you try clearing up your BT stored devices and pair them again. See if that helps with your troubles.
    roberts68 and androidluvr2 like this.
    03-22-2013 06:09 PM
  5. androidluvr2's Avatar
    BT in JB is a known issue revert back to 4.1.1

    or root and flash a custom rom, isnt that why you have a nexus anyway?
    yeah, I need to do that; just testing the 4.2.2 OTA. Although 4.1.1 is JB and the BT worked fine for me on 4.1.1. I don't see how they can release something with such a bug in it. BT is vital!
    03-22-2013 06:55 PM
  6. androidluvr2's Avatar
    I'd suggest you try clearing up your BT stored devices and pair them again. See if that helps with your troubles.
    will do!
    03-22-2013 07:00 PM
  7. Amir Kolsky's Avatar
    I get this after the update without even pairing... I turn BT on. Wait for 30 seconds... Voila - it's off....
    Given the Google broke my phone, I really expect them to fix the damn thing.
    04-08-2013 11:07 PM
  8. androidluvr2's Avatar
    I get this after the update without even pairing... I turn BT on. Wait for 30 seconds... Voila - it's off....
    Given the Google broke my phone, I really expect them to fix the damn thing.
    yeah, nothing fixes this so far. This is a real problem.
    04-08-2013 11:30 PM
  9. mzdrati's Avatar
    Same problems as you. I reverted back to 4.1.1, and everything went back to "normal". My suggestion would be the longer you wait for Verizon to offer a fix, the longer you will be unhappy as it pertains to the functionality that you lost with 4.2.2.

    Best of luck!

    TONY
    androidluvr2 likes this.
    04-09-2013 05:39 PM
  10. Alexander Meladze's Avatar
    Relax, it has nothing to do with custom rom or rooting. i developed that issue ever since i updated to ICS and nothing helps. literally nothing. i have been thru 2 hard resets and upgrade to JB but the problem persists. It is like a rat problem in NYC. seems impossible to get rid of it. I just saw somebody complain about a similar problem on their xparia z or zr. that's a bummer considering it's a brand new phone. BTW, I AM AN EXTREMELY HEAVY BLUETOOTH USER ALSO. Welcome to bluetooth hell!

    Sorry couldnt give better news
    08-06-2013 07:45 AM
  11. DiGi71's Avatar
    I've updated to 4.1.2 and S2 started to disconnect after 2 min. Repairing with BT didn't help.
    08-12-2013 05:34 PM
  12. blueglacia's Avatar
    I use Razr HD Maxx and used to have bluetooth disconnect problems during the calls. I tried everything I could think of, all in vein. Factory-reset solved the problem only for a while. Finally, I have found that some communication apps like Viber have the nasty habit of asserting itself every few minutes during non-Viber calls and reset both the bluetooth and speakerphone state to the default mode. This causes bluetooth to disconnect or turn off the speakerphone a few minutes into every non-Viber call. If you have an app like Viber, try either freezing it or uninstalling it. Uninstalling Viber was the only permanent solution to my bluetooth disconnect problems.
    08-30-2013 06:28 PM
  13. satendra verma's Avatar
    May be you are right. but i have no viber app. in my phone. but the applications i have are Facebook, skype, true caller and WhatsApp. so can you suggest me which application should be uninstall from my phone??

    Thanks in advance.....
    09-11-2013 05:20 AM
  14. satendra verma's Avatar
    Hi Guys i have a good news for 4.1.2 user.
    found the solution for the Bluetooth reboot issue.
    Just follow this process
    Settings >Power Saving (Under Device) > select close option and that's all.
    It's working for me hope this will help you all......
    09-30-2013 07:45 AM
  15. Dominique Vernier's Avatar
    Disabling the "Power Saving" doesn't made any change for me.
    I keep being disconnect, I have to tap "headset" twice for my HM3300 to get connect again and hear sound through my bluetooth device.
    11-14-2013 09:10 AM
  16. amyjo158's Avatar
    Unpairing and repairing is not a fix.
    there is no option that I can see for power saver.

    Phone will constantly switch from the Bluetooth or speaker to the handset. the screen says I am still connected to Bluetooth or speaker when I am not. sometimes changing audio sources back again will work for a little bit, but then the screen will be wrong.
    sometimes the Bluetooth will be connected and will not work at all.
    noticed that my notifications rarely work now too.

    recently udated from 4.0.4 to 4.1.2 but I was having these same issues prior to update.
    really need a fix. cannot get a thing done all day without Bluetooth or speaker. going crazy.
    Aamir Refai likes this.
    12-27-2013 02:18 PM
  17. amyjo158's Avatar
    Just saw and app in google play that claims may help called "Bluetooth keepalive" do you think this may help? if so what about the speaker getting shut off too?
    Aamir Refai likes this.
    12-27-2013 02:24 PM
  18. Daniel Okubo's Avatar
    Hi amyjo158, I'm facing the same problem with my Xperia SP. No device keep stable by bluetooth connection, switch constanly between BT and speaker. I tried "bluetooth Keepalive" and did not work properly. Please, let me know if worked for you.
    Thanks.
    Aamir Refai likes this.
    01-03-2014 10:32 PM
  19. Aamir Refai's Avatar
    Hey amyjo158, I downloaded the app. It didnt work for me =/
    01-04-2014 08:16 AM
  20. lowenuf's Avatar
    Update to 4.3! I'm running the shiny 4.3 ROM with no issues BT or other. There's also a shiny 4.4 ROM that I may try soon but my phone is so much better that I'm not in a hurry. Battery got better too.
    01-06-2014 03:27 PM
  21. Mohammad Fazlur Rahman's Avatar
    Thanks bro.

    your suggestion did work for me. I just unselected the two options in my power saver mode...

    1. CPU power saving
    2. Turn off haptic feedback...

    and now I am able to talk on my bluetooth headset beyond 2 mins. I just now talked for more than 3 mins and it was alright for me...

    It must be noted that my power saver as a whole is still ON and two of its options

    1. Screen power saving and
    2. Background colour

    is still checked in for the power saving mode...

    I hope it will help others also.
    07-01-2014 02:32 PM
  22. blueglacia's Avatar
    I used to lose bluetooth connection during calls. Discovered that wifi calling apps such as Viber or Hangouts Dialier periodically resets the phone mode in teh background to default (= handset earphone) every few minutes. When I removed these apps, my bluetooth problems went away. The only wifi calling app I have found that did not aggressively reset the phone mode to default is WePhone.
    01-10-2015 03:28 PM
  23. Josh Spencer's Avatar
    thankyou for this simple yet very effective solution to my blue tooth dilemma. I was in the process of buying a new phone because I couldn't figure it out. all I did was turn off the power save option and all was fixed.
    08-16-2015 04:10 AM

Similar Threads

  1. Why does Wi-fi keep disconnecting/
    By Charmed Juan in forum Verizon Droid Incredible
    Replies: 9
    Last Post: 10-21-2016, 09:41 AM
  2. WiFi keeps disconnecting...
    By Jolokia in forum Verizon Droid Incredible
    Replies: 6
    Last Post: 05-29-2012, 04:24 PM
  3. Bluetooth keeps crashing my EVO after putting cyanogen 6. 1 stable.... what gives?
    By hawaiijedi in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 5
    Last Post: 12-12-2010, 08:45 PM
  4. Keep app running after screen turns off
    By drjim in forum HTC Aria
    Replies: 0
    Last Post: 08-02-2010, 03:57 PM
  5. Bluetooth headset disconnects on outbound calls
    By Rudolphe in forum Motorola Droid
    Replies: 2
    Last Post: 03-25-2010, 11:59 AM
LINK TO POST COPIED TO CLIPBOARD