1. vNaK's Avatar
    I'll be using the stock browser and every now and then after I click on a link it'll load maybe 10% (looking at the loading bar) and then it hangs up. It doesn't load the rest and after awhile a message will pop up saying the browser is being unresponsive and asks me to wait or close it. And while it's trying to load, I cant click back, change websites or anything. Sometimes if I wait awhile, it will go, but more often than not, it freezes up.

    Anyone have this problem?

    I'd hate to use a different browser, as it won't work with multi-view and I use that feature a lot.
    12-01-2012 01:15 PM
  2. vNaK's Avatar
    Hmm, no one hasn't had any problems with their stock browser or know a fix to this?
    12-01-2012 07:41 PM
  3. collett's Avatar
    I actually have not had this problem with the stock browser. First phone I've ever had that didn't have this problem. On my old phones I had to clear the browser cache every day to reduce the frequency of it happening. Sorry you're having the problem. Hopefully someone will chime in with a solution for you.
    12-01-2012 08:20 PM
  4. DaRkL3AD3R's Avatar
    Having this problem on my Thunderbolt right now. Just think it's an Android thing to be honest.
    12-01-2012 08:45 PM
  5. aimeeinohio's Avatar
    Im not having this problem BUT i've had to do a battery pull twice this week from the phone freezing up after using the web!!

    Sent from my SCH-I535 using Android Central Forums
    12-01-2012 09:31 PM
  6. burwil's Avatar
    If the same thing is happening with other browsers my guess is that you are not using wifi and your signal is poor. Check your signal level.

    Sent from my Galaxy Note 2.
    12-01-2012 11:50 PM
  7. cdf3's Avatar
    Had this problem with a particular site while trying out the demo version in a Verizon store.

    Sent from my DROID RAZR using Tapatalk 2
    12-02-2012 08:42 AM
  8. MrSmith317's Avatar
    I'll be using the stock browser and every now and then after I click on a link it'll load maybe 10% (looking at the loading bar) and then it hangs up. It doesn't load the rest and after awhile a message will pop up saying the browser is being unresponsive and asks me to wait or close it. And while it's trying to load, I cant click back, change websites or anything. Sometimes if I wait awhile, it will go, but more often than not, it freezes up.

    Anyone have this problem?

    I'd hate to use a different browser, as it won't work with multi-view and I use that feature a lot.
    Have you tried clearing data on your browser? Also as someone else suggested this could be due to poor signal issues. I've had nothing that even remotely counts as a problem with this phone at all.
    12-02-2012 08:47 AM
  9. vNaK's Avatar
    Have you tried clearing data on your browser? Also as someone else suggested this could be due to poor signal issues. I've had nothing that even remotely counts as a problem with this phone at all.
    I don't have terrible signal, but not the best signal either. Using my home wifi gives me same problem.

    I'll try clearing the cache and see what happens. And I'll give another browser a try and see if i get the same results. Thanks for the inputs.
    12-02-2012 11:28 AM
  10. burwil's Avatar
    I think the stock browser might keep webpages in hidden windows even after you have rebooted. Make sure you don't have a boatload of websites loaded up in the stock browser.

    Sent from my Galaxy Note 2.
    12-02-2012 11:50 AM
  11. Pete Willus's Avatar
    It is definatly the browser . Im having issues with it freezing up and loadin slow . Ur not he only one . Sgsmini
    08-17-2014 09:03 AM

Similar Threads

  1. stock web browser it reloads over and over
    By jserrick in forum Verizon Galaxy S III
    Replies: 1
    Last Post: 12-01-2012, 03:33 PM
  2. Stock Web Browser Issues
    By duketreo in forum Verizon Droid DNA
    Replies: 1
    Last Post: 11-30-2012, 04:40 PM
  3. stock web browser - desktop view
    By dragonsamus in forum Droid RAZR MAXX
    Replies: 2
    Last Post: 02-18-2012, 11:01 AM
  4. Replies: 2
    Last Post: 01-20-2012, 02:11 PM
  5. Viewing PDF in stock web browser
    By mtrog in forum AT&T Galaxy S II
    Replies: 1
    Last Post: 10-08-2011, 09:46 PM
LINK TO POST COPIED TO CLIPBOARD