1. btgarris's Avatar
    For some reason my note 2 is having a hard time determining my current location. I dont have the gps turned on but I have never needed it on before with my old thunderbolt. I have the vzw locations on and google locations on but still no luck. I use weatherbug and google maps a lot which both rely heavily on current location. Any ideas?
    12-22-2012 08:39 AM
  2. jneusch's Avatar
    Please don't take this the wrong way, turn on GPS. That's my idea. I know a lot of people keep it turned off, but like you I use apps that are location based. I have had many devices and any time I turned off GPS I had problems, either the time or accuracy to locate me. I never turn mine off and with the battery life of this phone it shouldn't be a problem.



    Sent from my iPad using Tapatalk
    12-22-2012 09:34 AM
  3. btgarris's Avatar
    No offense taken. Im just used to the thunderbolt where I didnt need gps turned on unless I was actually using the navigation. It still usually had my location correct to within a couple hundred meters. I know the battery life is excellent it just seems to me it shouldn't be needed 100% of the time.
    12-22-2012 09:52 AM
  4. btgarris's Avatar
    Update: even with gps on it still says current location unavailable.
    12-22-2012 10:12 AM
  5. anon(394005)'s Avatar
    I only use Google location services and had that happen a couple times, in particular with Beweather, after the phone has been up for two or more days. The only solution was to power off/on. Had the same setup on the Thunderbolt and never had the problem. Then again, it was never powered up for days. I'd swap out for a fresh battery about once a day. I think it may be a bug in the Note 2 that sometimes pops up after an extended uptime.
    12-22-2012 11:31 AM
  6. jneusch's Avatar
    Agreed, try a restart and see if that resolves the issue. I have had mine for about 11 days, but I forgot I had a couple location issues when I first got it. I'm pretty sure a restart fixed it, no problems since then.


    Sent from my iPad using Tapatalk
    12-22-2012 11:51 AM
  7. btgarris's Avatar
    I'm at work currently so I'm just messing with stuff in my down time. I did do a restart and at first I still had the problem. It seems to be a little better now but I'll mess with it a little more throughout the day and report back. Thanks for all the help everyone.
    12-22-2012 01:19 PM
  8. kgk1985's Avatar
    Is dumb how it sometimes works. Cuz gps doesn't do a damn thing when you're indoors. You would think it wouldn't help then voila. I think it's just flawed software

    sent from Galaxy Note 2
    12-23-2012 07:58 AM
  9. Coug's Avatar
    I had the same problem and almost returned the phone the first week. Went to a local VZW store and they said to pull the battery to reestablish connection with the LTE network, and that it was a common problem with LTE. Did that and it worked.
    fofjjsr likes this.
    12-23-2012 09:59 AM
  10. fofjjsr's Avatar
    I had the same problem and almost returned the phone the first week. Went to a local VZW store and they said to pull the battery to reestablish connection with the LTE network, and that it was a common problem with LTE. Did that and it worked.
    This. It happens a lot. This is the first thing I tell people to do, because I was having the same exact issue.
    12-23-2012 10:53 AM
  11. Coug's Avatar
    What good thing that came out of this is I found a cool GPS app. Was using it to figure out if I had a hardware problem, but really like the app.

    https://play.google.com/store/apps/d...sim.gpsstatus2
    12-23-2012 04:14 PM
  12. btgarris's Avatar
    So all of a sudden it just all of a sudden started working. Seems to be okay at the moment so we'll see what the next few days bring.
    12-23-2012 05:06 PM
  13. bulldogmoe7's Avatar
    had the same issue on friday, i use weather bug and be weather and it was putting me in tx, i live in florida. i turned gps on and off, i did find the weather apss defaulted to network location instead of gps. switch that and still no work. then all of a sudden i worked right. hmmm
    12-23-2012 05:17 PM
  14. kgk1985's Avatar
    Weatherbug sucks. Use accuweather or something else

    sent from Galaxy Note 2
    12-24-2012 10:25 PM

Similar Threads

  1. How do I enable location services?
    By kabe in forum T-Mobile Vibrant
    Replies: 17
    Last Post: 01-08-2016, 09:16 PM
  2. Service issue?
    By JGR4444 in forum Motorola Droid
    Replies: 7
    Last Post: 05-21-2013, 02:10 AM
  3. location services icon, can it be removed?
    By Libuff in forum Verizon Droid Incredible
    Replies: 13
    Last Post: 09-30-2010, 09:40 AM
  4. Post Froyo zip update / Foursquare location update issue
    By bobafett90210 in forum Verizon Droid Incredible
    Replies: 2
    Last Post: 09-01-2010, 03:08 PM
  5. Location services...
    By dancurry in forum General Help and How To
    Replies: 2
    Last Post: 07-13-2010, 10:40 AM
LINK TO POST COPIED TO CLIPBOARD