1. elvisgp's Avatar
    I've read over and over again how this phone has amazing battery life and while it has been a heck of a lot better than my gnex, it hasn't met my expectations. Now this isn't horrible battery life but it's not the amazing 24 hour 5 hour on screen time other people are getting.Oh and I don't even use all share and it is using up battery and I can't figure out how to turn it off. Please help.


    Sent from my SCH-I605 using Tapatalk 2
    01-12-2013 10:30 PM
  2. crl95's Avatar
    I would say to put ur screen brightness in the middle and then flip on auto if you dont already have it set like that
    01-12-2013 10:35 PM
  3. elvisgp's Avatar
    I would say to put ur screen brightness in the middle and then flip on auto if you dont already have it set like that
    Thanks. I've had my brightness almost on full. I will put it in the middle but auto brightness is just too dim for me.

    Sent from my SCH-I605 using Tapatalk 2
    01-12-2013 10:41 PM
  4. crl95's Avatar
    Thanks. I've had my brightness almost on full. I will put it in the middle but auto brightness is just too dim for me.

    Sent from my SCH-I605 using Tapatalk 2
    haha yea I hear you I usually keep it in the middle but bc its so easy to change it in the notification area I try to make it as dim as I can while still being happy... With full brightness all day theres no way to really get better battery life than what your having. Hope this helps
    01-12-2013 10:45 PM
  5. elvisgp's Avatar
    Anyone else have any suggestions?

    Sent from my SCH-I605 using Tapatalk 2
    01-13-2013 08:15 AM
  6. Bond32's Avatar
    You can disable the all cast stuff in the app manager. Just go to the "all" tab

    Sent from my SCH-I605 using Tapatalk 2
    01-13-2013 08:24 AM
  7. jneusch's Avatar
    Try turning off Allshare Cast and file sharing in settings, more settings.

    Brightness is huge though. You could also try power saving mode and see if that helps too.


    Sent from my SCH-I605 using Android Central Forums
    01-13-2013 08:27 AM
  8. elvisgp's Avatar
    When I turn it off in settings it just comes back on every time I click on the setting.
    And I can't disable it in settings.
    Sent from my SCH-I605 using Tapatalk 2
    01-13-2013 08:44 AM
  9. fwhomeboy's Avatar
    When I turn it off in settings it just comes back on every time I click on the setting.
    And I can't disable it in settings. http://img.tapatalk.com/d/13/01/13/ysu9y2az.jpg
    Sent from my SCH-I605 using Tapatalk 2
    I have the same problem with Y-Mail. No matter what, it still runs
    01-13-2013 08:47 AM
  10. jneusch's Avatar
    It's also in the notification toggles. You have to scroll to the right to see it. You can turn it off in settings and make sure it is off in notification bar.



    Sent from my iPad using Tapatalk
    01-13-2013 10:11 AM
  11. elvisgp's Avatar
    It's also in the notification toggles. You have to scroll to the right to see it. You can turn it off in settings and make sure it is off in notification bar.



    Sent from my iPad using Tapatalk
    I have that turned off too.
    01-13-2013 12:15 PM

Similar Threads

  1. Removing the sd card might help with battery life
    By moonoverparma00 in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 30
    Last Post: 08-01-2012, 11:12 PM
  2. Need help with battery life and email
    By soloz2 in forum Samsung Galaxy S II Skyrocket
    Replies: 32
    Last Post: 04-16-2012, 08:23 PM
  3. New SGS2 user gutted with battery life. HELP!!!
    By mpshah in forum Samsung Galaxy S II
    Replies: 9
    Last Post: 10-14-2011, 10:50 AM
  4. apps to help with battery life
    By kristi in forum HTC EVO Shift 4G
    Replies: 5
    Last Post: 02-18-2011, 06:16 AM
  5. Does 2.1 Help With Battery Life?
    By its_miller_time in forum Samsung Moment
    Replies: 20
    Last Post: 05-24-2010, 09:37 PM
LINK TO POST COPIED TO CLIPBOARD