1. Python49's Avatar
    I ordered this Samsung Note 2 LTE Verizon version from USA and had a friend bring it over for me as I am living abroad. I've done this with iphone numerous times and no issues. This time with the Note 2, the phone is working with the local GSM sim card for making/receiving calls and texts, except for when I want to call a #, I can't dial it as "0123 456 789" for the phone number, I can only dial it when doing +xxx for the local area code. If I dial it with the 0123 it will randomly pop up as though it's calling something like +1250 123 456 789 or even more random numbers than that and call won't go through.

    When I am trying to text people though it's the opposite. If I try to text them with the local area code prefix + their number it fails and doesn't go through. I have to text their # with the 0 first instead. The problem though is when they reply it comes through as the local area code + number and creates a real pain because I can't just hit reply to text them since it replies to the local area code which doesn't go through and only comes in through local area code. Anyone know how to sort this? My iphone just dials/texts with both the "0" and local area code interchangeably.
    09-12-2013 10:35 AM
  2. dpham00's Avatar
    I am not really familiar, but have you disabled assisted dialing?

    Sent from my Verizon Samsung Galaxy Note II via Tapatalk 4
    09-12-2013 09:54 PM
  3. Python49's Avatar
    no still not working unfortunately, any other ideas?
    09-14-2013 02:43 AM
  4. Python49's Avatar
    if it matters at all, I downlaoded SMS pro to test to see if I can send texts there and I was able to send them just fine. In there when I try to text to 0123 456 789 it automatically switches the area code to +255 123 456 789 and the text goes through. In my normal messages with galaxy I try to just text to +255 123 456 789 and it fails everytime. I have restored phone to factory settings.

    Also, the phone seems to be unlocked since I can make calls and receive them just fine with my sim card here, but for some reason it still says unknown non-verizon sim card.

    Also,this same sim card I was able to use with my iphone for texting to +255 prefix and it worked without an issue -- would that mean that the sim card and SMSC settings are fine?
    09-14-2013 04:10 AM
  5. Python49's Avatar
    Apologies for numerous consecutive posts, but am still trying to resolve this and am posting as more info comes in.

    So I put in a different sim card from a different carrier into my phone and it's able to send text messages and receive them just fine. I then took the sim card I was previously using and put it into my girlfriends galaxy note 2, which she bought locally here, and that's ALSO able to send text messages just fine. So it seems to only be a specific problem with this particular carrier's SIM and MY particular phone. Surely the problem should be easy to identify here and correct? I'd like to not have to get a different phone number and sim. This carrier also has the best deals on minutes/usage.
    09-14-2013 05:28 AM
  6. dpham00's Avatar
    if it matters at all, I downlaoded SMS pro to test to see if I can send texts there and I was able to send them just fine. In there when I try to text to 0123 456 789 it automatically switches the area code to +255 123 456 789 and the text goes through. In my normal messages with galaxy I try to just text to +255 123 456 789 and it fails everytime. I have restored phone to factory settings.

    Also, the phone seems to be unlocked since I can make calls and receive them just fine with my sim card here, but for some reason it still says unknown non-verizon sim card.

    Also,this same sim card I was able to use with my iphone for texting to +255 prefix and it worked without an issue -- would that mean that the sim card and SMSC settings are fine?
    The unknown sim message is normal when using a non Verizon sim

    Sent from my Verizon Samsung Galaxy Note II via Tapatalk 4
    09-14-2013 01:39 PM
  7. Python49's Avatar
    ended up getting it fixed by just getting a new sim card from same carrier and worked fine, no idea why old one didn't.
    09-18-2013 09:29 AM

Similar Threads

  1. Portland Oregon Lte
    By bigmatt503 in forum Verizon
    Replies: 11
    Last Post: 09-16-2013, 09:37 PM
  2. Lag on my DNA
    By mikekrafick in forum Verizon Droid DNA
    Replies: 3
    Last Post: 09-15-2013, 10:19 PM
  3. Restoring after wiping phone
    By dcrudolph9 in forum Google Nexus 4
    Replies: 6
    Last Post: 09-12-2013, 05:28 PM
  4. Got an OTA Update, No Version Change, But Phone Getting Stuck Frequently
    By Avi_Samocha in forum Samsung Galaxy SIII I9300
    Replies: 3
    Last Post: 09-12-2013, 10:00 AM
  5. paste/clipboard icons blocking my view in galaxy tab 3
    By Juggernaught Crush in forum General Help and How To
    Replies: 1
    Last Post: 09-12-2013, 09:36 AM
LINK TO POST COPIED TO CLIPBOARD