1. snowwy66's Avatar
    is there a solution for the LONG delay in gps function on the note 2.

    i'm on my 3rd phone now. and the delay is just unacceptable. i've got google nav, copilot, truckerstop, and any other navigation software i try.

    every time i reboot the phone. it takes about 5 minutes before the gps chip kicks in.

    i'm using a unactivated sprint note 2 as a permanent gps now. it has no problem IMMEDIATELY functioning. i doin't need to use my V phone as a permanent gps. but it be nice to use gps when i want too. and not have to wait 5 minutes. specially when i'm looking for my destination. but have to sit and wait for the darn thing to function.

    my sprint note is my gps for the semi. so that's where it stays.
    03-04-2014 11:48 PM
  2. viper31573's Avatar
    are you rooted? you could use an app called topntp. open it, change from global to north america, then change the 2nd option to US(assuming you are in US) then click install.leave generic and google as is. there will be a 20 second count down, then apply and reboot phone. it may take a little while to lock the 1st time, but after that you should be good. here is a youtube video about topntp

    03-07-2014 11:34 PM
  3. snowwy66's Avatar
    no, i don' thave root. i don't play around with my phone that much anymore.

    i also have a problem with drivers working on the phone. i'm lucky to get my computer to recognize the phone. been that way since day 1. so maybe i'll just see about swapping it out. if possible. since V just loves to argue.
    03-11-2014 10:22 PM
  4. jlost's Avatar
    I'm lucky that my phone locks on this fast without having by on use this app... -_-
    03-16-2014 08:03 AM
  5. CarrierPigeon's Avatar
    I had this "problem" on my other Verizon Note II. took almost 10 seconds to get a GPS lock even when I'm outside.(standing at a Walmart parking lot, for example)

    Verizon shipped me a replacement (CLNR) Galaxy Note II. First thing I noticed about the phone was that GPS lock always took just 1 or 2 seconds. So I suspect the previous one had problems. Just tried it right now. The "GPS Test" app was able to get a lock in just 1 second. I'm indoors. (first floor of a 6-story building)
    03-16-2014 04:35 PM
  6. snowwy66's Avatar
    my sprint unactivated phone has no problem immediately running my copilot software.

    i'm on my second note2. the problem isn't gps lock. the problem is gps malfunction. it has no problem locking on. once it comes to life.

    you can tell becuase the circle doesn't even light up in the notification bar. meaning it's not there. once it comes on. it flashes once or twice then goes solid.
    03-24-2014 11:28 PM
  7. EdTheC's Avatar
    I began to have issues with GPS as well. It would not lock, Google maps would freeze and show me in a river, etc. The solution for me was HARDWARE and quite simple. First, turn off the unit, open the back. Tighten all the screws (some of mine were loose). BE CAREFUL and use a proper tool! Finally, the GPS antenna is on the back case cover (two little gold contacts identify it), so make sure the connections are good - clean the contacts, and CAREFULLY bend the spring contacts (phone side) to get a better connection.

    I did those things now it works perfectly!
    08-15-2015 02:29 PM

Similar Threads

  1. Replies: 13
    Last Post: 05-24-2014, 08:52 PM
  2. Replies: 3
    Last Post: 03-05-2014, 09:30 AM
  3. Galaxy S4 GP Edition : Which apps do you have disabled?
    By rob damiani in forum Samsung Galaxy S4 Google Edition
    Replies: 2
    Last Post: 03-04-2014, 04:18 PM
  4. Replies: 2
    Last Post: 03-04-2014, 02:58 AM
  5. Fix broken screen on Nexus 7 (2012) - how hard is it?
    By kimikookskookis in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 03-03-2014, 08:59 AM