1. CypherMax's Avatar
    So I am trying to root my GS3 on my Intel Mac running 10.5.8. I downloaded the casual file from the guide. When I open it java says it can't unzip check for errors on system. All my software is up to date. So I looked around and found I can unzip the file using Archive utility. That worked and I now have a Casual S3 folder in my applications now. However when I open it there is no application to run just tons of files. Any ideas?

    My goal is root/unlocked bootloader and flash clean rom 5 and the new jellybean camera. I would be extremely grateful if anyone can help get to that point. Thanks.

    Sent from my SCH-I535 using Android Central Forums
    12-09-2012 03:27 PM
  2. pank's Avatar
    12-10-2012 07:01 PM
  3. Trees's Avatar
    Nice share. Worked fine for me too, although the script did throw the following:
    debugfs: debugfs: debugfs: debugfs: reboot #2 - DO NOT DISCONNECT YOUR DEVICE!
    All Done rooting Galaxy S3, install SuperUser or SuperSU app from Play Store to get full root!
    RootMac.sh: line 40: unexpected EOF while looking for matching `"'
    RootMac.sh: line 42: syntax error: unexpected end of file

    I confirmed that root=true by running Root Checker Basic.
    12-13-2012 11:38 AM

Similar Threads

  1. Thunderbolt root on mac
    By android_monkey in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 11-16-2011, 02:28 PM
  2. S-off/root on Mac?
    By boobie1292 in forum HTC EVO 3D Rooting, ROMs, and Hacks
    Replies: 13
    Last Post: 08-18-2011, 07:48 PM
  3. help rooting on mac
    By usagiakumu in forum Verizon Fascinate
    Replies: 4
    Last Post: 01-11-2011, 09:54 PM
  4. Rooting on mac
    By boobie1292 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 10-13-2010, 12:46 AM
  5. Rooting on mac
    By boobie1292 in forum HTC EVO 4G
    Replies: 0
    Last Post: 10-10-2010, 11:50 PM