1. kre23's Avatar
    Hi there,
    I have a factory unlocked Verizon Samsung GS3 that I've brought with to Switzerland, where I'll be for the next year. Upon arrival, I had to root the phone and install APN Manager as a system app in order to connect to the local carrier's (Sunrise Mobile) data network. (This is a common, well documented problem on the internet, though Verizon is useless at fixing it.) After finding this solution posted in these forums, I was able to insert the new APN and everything was working. Then I got greedy.

    I got rid of the original ROM and installed CM10.1-experimental. After much fiddling, the phone boots, connects, to wifi, and everything is good--except that I can no longer connect to Sunrise. No voice, text, or data. I have tried to go into (Preferred) Network Mode and change it to Global or GSM like I could under the old Verizon altered OS, but those options are no longer presented to me. I only see LTE/CDMS/EvDo or CDMA/EvDo auto--nothing else. I've tried both "Home only" and "automatic" under System Select to no avail. I suspect the problem is that I cannot get the correct radio to activate and connect to the non-CDMA network, but that's just my hunch.

    I'm at the point where I'd like to just revert back, but the CWM restore fails each time. So it appears I'm stuck.

    I've rebooted with and without the Verizon and Sunrise sim cards, and googled and explored forums extensively without finding this exact same problem. I'd really appreciate any help you guys/gals could provide. The ideal solution would be to get everything working under CM, but I'm also willing to downgrade back to the stock ROM if need be. I'm not super savvy with these things so please let me know if there's more info I could be providing.

    Much, much thanks in advance!
    04-29-2013 11:52 AM
  2. Ataraxia212's Avatar
    I'm not sure if this would help, but user dpham00 has graciously posted an app called "Phone Info" in this thread. Sideload it, choose "Device information" and then you can scroll down to "Set preferred network type" with a whole bunch of options. I use the CDMA auto (PRL) option to force 3G. Hope it helps.
    04-30-2013 05:19 PM

Similar Threads

  1. [Guide] Root/Unroot/Recovery/Unlock Bootloader for the Verizon Galaxy S3 (SCH-i535)
    By Cyber Warrior in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 197
    Last Post: 02-27-2016, 02:29 AM
  2. How do you update the galaxy s3 SCH-I535 to 4.1.2 jelly bean?
    By jonnel1234 in forum Verizon Galaxy S III
    Replies: 3
    Last Post: 02-04-2013, 12:58 PM
  3. Replies: 4
    Last Post: 12-14-2012, 11:08 PM
  4. Kies will not connect to my Samsung Galaxy S3 ( SCH-I535 )
    By gblaca in forum Verizon Galaxy S III
    Replies: 3
    Last Post: 10-05-2012, 09:25 PM