12-28-2014 08:43 PM
46 12
  1. mo chorney's Avatar
    RESPONSE to Cheryl Pelly
    I have this problem too (S3 MAIL app with new phone with JellyBean) ... using my sympatico.ca email which is hosted on Hotmail...
    I use Outlook Express to access my mail on my PC...
    I did go in on Outlook Express "tick the box to keep emails on the server for your chosen time limit" (none specified).
    However, I still have the problem...

    Anyone else have any ideas???
    02-02-2013 01:43 PM
  2. BBSeattle's Avatar
    Thanks for that info!

    I chatted with Samsung Support this morning and it has nothing to do with your email clients. Confirmed that the Galaxy S3 deletes old emails automatically as soon as it receives new emails and there is no fix for this issue. The Chat support person I talked to said he will forward the issue to the support team, so don't bang your heads around trying to figure this one out - it's not an Android issue.

    Here's a quirky little way around this. Open the email you want to keep and delete it. Click the "Trash Can" icon and it will go into your "Trash" Folder. Do it quick because if you get another email, it will be automatically deleted to who knows where. So far, all my emails stayed in the "Trash" folder that I wanted to keep.

    Samsung didn't really think this one out to well, going back to my iPhone tomorrow!
    I think I am misunderstanding you, or at least I hope I am.
    Your statement regarding the GS3 automatically deleting emails (regardless of who you heard it from) after a new one is received is completely incorrect.
    I have 3 email accounts set up, a POP3, corporate and Gmail. 2 of the three are set up through Outlook and I have never had a single email deleted "automatically". I have had the GS3 since day one.
    I would tend to believe that your issues ARE in fact with your email server or Outlook settings.
    02-03-2013 10:33 AM
  3. LoriRedRaider's Avatar
    I found the solution on my phone....I upgraded phones from the Galaxy to the Galaxy S3 and I was using the same e-mail account on both which is a live.com account (hotmail)...the S3 was removing the e-mails after just a few days which my Galaxy phone did not do.

    Here is what I had to do....on the phone go to the e-mail app (I am using the one that came on my phone) and select "Settings" then click on the account under the "Added accounts" section then go down to the "Exchange ActiveSync settings" then click on "Period to sync Email" and change it to All. Now all of your e-mails will show back up. I was very happy to finally find this setting.
    deanosig and derloopkat like this.
    02-07-2013 06:34 PM
  4. Admagic3's Avatar
    I think I've solved this... try this scenario:

    Let's say you have your mail on a pop server and you have a local laptop/desktop and a smartphone.

    Now, your POP gathers your emails and they are synced with BOTH your desktop/laptop and your phone (when they sync).

    If your laptop is set up as a POP email type, once you have read/accessed the mail on your laptop, it is deleted from the server the next time the laptop syncs.

    And the next time your phone (even if it's set to IMAP) syncs to the server, the message is no longer there, so it "scrubs it" from the phone as well.

    Does this make sense?

    The obvious test to see if this is your problem, is to reconfigure the account on both the laptop/desktop AND the phone as IMAP accounts. Because if either one is a POP account, the other will sync with your empty server all the time. This way, whether it is the laptop or the phone that's syncing, they will each still have messages to download from the server, because neither device will signal a deletion. On Macs (in Mac Mail) there is actually a checkbox that you can "untick" called "Remove downloaded messages from the server" (unticking this will anable IMAP status without needing to recreate the mailbox).

    This was my problem, because reconfiguring the Mac Mail account as an IMAP has stopped the problem.

    So fa.

    Hope this helps.

    02-07-2013 09:41 PM
  5. Manya Gakavian's Avatar
    me and my friend do have same problem the emails disappears from our phones which is Samsung Galaxy note 2 please need help asap
    02-17-2013 07:23 AM
  6. KellySD's Avatar
    Go to email settings and change number of emails before it "pushes" them out.
    Go to Settings and tap email account, "RECENT MESSAGES" start at 25 (default) Max number is 200 or you can set to TOTAL. Done no more "disappearing messages"
    05-25-2013 09:52 PM
  7. Diane O's Avatar
    the same was happening to me on my Samsung Galaxy S3...went to (windows mail)email tools on my computer>>accounts>>properties>>advanced..and checked "leave a copy of message on server"...and it seems to have fixed my disappearing emails!! I have to delete them manually now....yea!!
    06-11-2013 11:53 PM
  8. Max Rebos's Avatar
    I got a brand new att s4. two weeks old and all read mail disappear from my phone. my iphone never had that problem. definitely a sofrware bug
    07-29-2013 05:29 PM
  9. NellieRose's Avatar
    Not sure if this will help everyone (or anyone) but we both switched from BB to the Galaxy S4. Only one of us had the disappearing email issue and only on the hotmail account. I found the hotmail account was set to Sync 1 day...I switched that to Automatic and all the emails reappeared & have since stopped disappearing.
    08-04-2013 10:37 AM
  10. lucidme's Avatar
    I am aware this is an Android forum, but oddly enough I am having this same issue with my iPhone 5 using the native iOS Mail app with both of my Cox.net email accounts.

    I have verified all settings are correct (i.e.: keep on server, number of messages shown, etc). Oddly enough these email accounts worked fine for nearly a year on my iPhone 5. Then suddenly, this started happening.

    I will change the settings, or re-add the account, or reset the iPhone, and it will seem fine, and appear fixed. A couple hours later all my emails are gone.

    I do not use Outlook, though I do use the Mac Mail application on my computer. I am skeptical that any settings in the Mac Mail app could resolve this, since I haven't changed any settings and this issue began out of nowhere.

    Calling Cox was no help. At the point of restoring the iPhone, but from seeing that this is an issue affecting other OS's I have to say I am concerned that is not the fix either.

    I am aware of how POP works when its being used with multiple devices - Using a POP account with multiple devices
    again though, it is all very suspicious to me since this happened so abruptly.

    I am going to check my other Mail app settings, then if it continues, I think I am going to configure my Cox accounts as IMAP accounts, found the instructions for this here, if anyone needs them - IMAP Email Server Settings.

    Does anyone have any further suggestions? Thanks!
    08-16-2013 05:00 AM
  11. blueman2's Avatar
    Has no one found a solution??
    Just got this S4. Everything has been quadruple checked. All solutions on this thread have been tried.. I am using the "recent:" prefix in both my gmail accounts. I have two gmail accounts set up pop 3 and they are both set up exactly the same in my email client (thunderbird) in the gmail settings and on the phone. The emails come in and then they disappear on the the phone. They are still obviously in thunderbird and they are still on the server when I check the web based inbox. This is why I was hesitant to switch from a blackberry and despite everything else I like about this phone it is enough to drive me back. I have about 7 days left to return it. Hopefully someone either at google (I posted there as well with no luck) or here will have a solution.If there is a glitch with the software, they should say so or fix it.
    08-25-2013 10:30 AM
  12. GSDer's Avatar
    I just use Gmail: https://play.google.com/store/apps/d...gle.android.gm without all of this POP/IMAP overhead and have no problems with disappearing email. Perhaps I'm missing something about why you need a different solution.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    08-25-2013 12:47 PM
  13. blueman2's Avatar
    switched to maildroid. No problems anymore.
    08-26-2013 08:34 AM
  14. Lance N's Avatar
    Email disappears  from phone after a few hours-05-09-2013-10-11-12-am.jpg

    Try deselecting the 14 day removal from server check box.
    09-05-2013 12:18 PM
  15. Gianni C's Avatar
    I have recently been having the similar problems, Although mine were an abrupt change after having changed from previously using BlackBerrys, Droid-X and most recently HTC to using the new Samsung S4. I have recently (several days ago) upgraded to the Samsung 4S and use several emails Gmail, Hotmail, Yahoo and an original email that is out of the NYC area through Transbeam.com, which happens to be a POP based email server.

    Here is the situation, because I do not have a lot of storage available on my Transbeam.com email server, I have my PC software (Outlook) set to remove all emails from the server after downloaded onto my computer. I use my S4 to download these emails first and then use computer in the evening to clear the online cue and save the emails I want to keep on my computer. The problem is, once this is done and my S4 then Syncs up with the email server, it removes all the emails that had previously been downloaded on the S4.

    I have just reviewed this with Samsung online that there are no setting on the S4 to change this, as this is part of the current android version 4.2.2 and it does not support a time delay email erase from the device. In other words, the other phones mentioned above have a "keep email on phone for X days" which is what we need for our POP email accounts. Google and Hotmail have this sort of feature on the S4 in the settings, but it is not as necessary as the POP mail account... because the POP account does not have the amount of free storage as the other mail accounts mentioned.

    The result: This will force me to return the S4 (which I like very much with the above exception) to change to the HTC ONE! All in All, it means configuring and transferring data / programs over to a new phone again and also taking several days to get familiarized with another phone and to a efficient operating space.

    If anyone finds that there is an app that can correct this or if there is another email client app that can be loaded onto the S4 that retains the emails for "X" days, I would deeply appreciate knowing ASAP.

    Thank you,


    Noisemaker... Thank you for suggesting using K-9 app as my email client! I had looked into this solution yesterday morning prior to you mentioning it, and You gave me the last push to pulling the trigger to just doing it. After a little bit of time becoming familiar with all the features and options that K-9 has, it worked out perfectly. I now am retaining my emails on my cell phone without the use of the Samsung S4 standard internal POP email client.

    My only concern is if K-9 makes my email more susceptible to being monitors anymore than we are already being monitors... ;-)

    Any other suggestion? If not, thank you for your suggestion.


    09-08-2013 03:08 PM
  16. AxlMyk's Avatar
    OT, but does the S4 mail icon show -1 emails when there are no unread messages? Damn, I wish they would fix that.

    --Tapatalk on SGS3.
    09-09-2013 09:31 PM
  17. Christine Mulligan's Avatar
    Thank you for this solution! This has been driving me crazy for months. I had an iPhone and all of a sudden it started deleting my Cox email from my phone every time I would log into Outlook on my laptop. I then switched to a Samsung Galaxy 5s and it did the same thing so I knew it was a setting in either Outlook or my Cox account. I don't think I would have found that setting on my own.
    Thanks again!
    07-22-2014 09:35 AM
  18. GSDer's Avatar
    Thank you for this solution!
    (Hmm, 41 previous posts - I wonder which one she was referring to? Too bad she didn't quote the pertinent part of the post that had the solution, to make it easy to figure out what she meant. Drat! Guess I'll have to recreate the wheel and start at the beginning. Sigh.)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-23-2014 12:42 AM
  19. AxlMyk's Avatar
    Guess I'll have to recreate the wheel and start at the beginning. Sigh.)
    What I'm wondering is why the emoji in your post isn't showing up. 😕

    AC App on SGS3
    07-23-2014 05:15 PM
  20. kobyj's Avatar
    All mail servers attach a unique id to each email. A well written client will save these ids and create a list which it will use to determine if the mail has been previously downloaded. The entries in this list are compared to the ids of mail on the server. If the id on the sever is not in the list the mail is downloaded to the server and the id added to the client list. If the id is not on the server the id is removed from the client list. If the id is both on the server and in the client list the mail is not downloaded to the client. The client should never be able to delete mail that it has stored locally unless directed to do so by an operator. Mail is always left on the server unless the client is configured to tell the server to delete the mail after it is downloaded. This method will allow multiple clients to access the same mailbox on the server with only one of the clients configured to delete mail from the server. In the past I wrote an application in Visual Basic using the above technique for retrieving only the mail where the subject line contained specific information. It appears that something in these android clients is failing when it comes to tracking downloaded mail.
    12-15-2014 07:50 PM
  21. markg143's Avatar
    I have the same problem with both iPhone and Samsung Galaxy of deleting my e-mails from the inbox of COX.net. I performed the recommended instructions for both POP and IMAP with SSL, I send multiple test e-mails, the e-mails are received on my work account, I send e-mails to my COX account, they are received and remain for a small period of time. They then are deleted/vanish from COX e-mail completely. I have both an iPhone 5S, and a Samsung Galaxy Tab. This issue isn't just with Samsung it's a problem with remote phones/tablets overall, and I don't know what the fix would. The suggestion is to move e-mails from inbox to trash immediately but when you don't manage your e-mails on a daily basis then this approach doesn't work. I have since deleted the e-mail accounts, I see this as the only fix.
    12-28-2014 08:43 PM
46 12