1. ulpian's Avatar
    Try transfer dome files to the s3, when plug in the phone via usb, it report mtp install fail. Anyone know a fix?
    07-14-2012 02:28 AM
  2. krusej23's Avatar
    I got the same thing. I downloaded the android file transfer application for mac and it doesn't work with MTP even though it says it should. I had to switch it to the other transfer protocol and it worked with android file transfer. Still haven't found a solution for MTP.
    07-14-2012 10:00 AM
  3. micheliu's Avatar
    It may not work for you, but did you use the Setup Wizard when you got your phone? I had tried everything to get mine to work, and discovered that it worked for like that first few minutes after I factory rest the phone. So I factory rest it again and backed out of the setup wizard as soon as it would let me (somewhere just after the, "Your phone number is XXX-XXX-XXXX"), and it's worked ever since.
    07-22-2012 01:18 PM
  4. montanaxvi's Avatar
    Same situation here. Unable to install MTP to save my life. I used to have a Samsung Epic on Sprint then switched to an Atrix on AT&T and now to a S3 on VZW so I've not had issues with phones/drivers before and had even rooted the Atrix.

    All I want to be able to do is add some ringtones and pics to my phone but it won't install MTP and the phone never shows up in my devices when plugged in. I installed the driver from Samsung already, even got an updated driver from Windows update for Samsung but no luck on getting MTP installed. When I plug the phone in, it says installing drivers and everything installs except MTP and the phone sits there.

    FWIW, I'm running a home built Win 7 64bit machine that is about 2 years old. Never had any problems with any of the phones in the past either as far as installing drivers or accessing them via USB.

    **UPDATE**
    Just for kicks, I decided to install Kies on to my PC and play with it, once Kies installed the phone shows up now and MTP apparently works. I'd say give that a shot for anyone having issues, install Kies on the PC and see if that fixes the issue.

    **New update**
    Copied over some files, ejected the phone. Went back a little later to add some more stuff and MTP and drivers try to install again when I plug phone in and of course, you guessed it, MTP fails. A little frustrating.
    07-29-2012 12:10 AM
LINK TO POST COPIED TO CLIPBOARD