1. leggy's Avatar
    Activated the phone per the instruction but the activation did not go smooth. Tried to activate the phone several time, restarted and pulled out the sim card, but still not activating. Ended up calling the 877 number to activate it then phone lastly got activated.

    4G and 3G wordk normal (highest got on 4G is 10m down and 7m up, and they are similar to the bionic that I have).

    Now the lemon part, I can't make or receive phone calls or text messages. The phone says dialling but nada. Calling from another phone to mine keep rining but nothing on my phone then it goes to VM. Restart it pull sim card did not work.

    Went to VZW store and they tested it and said the phone is with the phone and not the sim card but they could not replace it because they have none. Will check with them tomorrow or a different store.

    The signal majority of the time is around -90 to -120. Battery went down to 30% in 7 hours without using the phone.
    Data is working normal but no phone calls or messages.


    It does not look like there is a solution other than replacing the phone.

    Anyone had similar problem?
    07-23-2012 08:44 PM
  2. dpham00's Avatar
    if you can't make or receive calls, then seems like something majorly wrong. i would try a factory data reset as a last resort. if that doesn't work, then pretty much you will have to have it warrantied.
    07-23-2012 11:42 PM
  3. Jowlah's Avatar
    That sounds like a phone hardware issue. The good thing is that if you go to get a replacement phone, you'll get a new phone, since there aren't many to refurbish. The bad news is, if you need a replacement phone, you'll get a new phone since there aren't many to refurbish.

    I haven't heard of the problem you are descibing. But I can look it up to see.
    07-23-2012 11:43 PM
  4. Fillyo's Avatar
    Did you call Verizon tech support, that would be your first step. I am sure it is something with the activation process, or the SIM.
    07-24-2012 12:31 PM
  5. leggy's Avatar
    Did you call Verizon tech support, that would be your first step. I am sure it is something with the activation process, or the SIM.
    I went to VZW store last night and they determined it is the deivce, neither the activation nor the sim card.

    I did factory reset and deleted everything but that did not help either.

    Today I replaced the device with a new one and so far everything is working or at least previous problem is not occuring. Keeping fingers crossed.
    07-24-2012 07:42 PM
  6. glassygurl's Avatar
    man... that sucks that you finally got your hands on that phone and it's broken.. and now you can't get another one cuz it's out of stock.... I know how that feels... you just want to scream "WHY MEEEEE?!! WHY THIS ONE?!!" but at least you'll be getting a replacement one.. hopefully soon.. but like someone said, you should try calling verizon tech support.. just cuz someone works at the verizon store doesn't mean they know what they are talking about.
    07-25-2012 03:55 PM
  7. leggy's Avatar
    The replacement phone is worrking fine although couple of people called me but it did not ring with me other than that everything is good.
    07-25-2012 09:08 PM
LINK TO POST COPIED TO CLIPBOARD