1. AWitlock's Avatar
    I was wondering if anyone had a solution to this problem.... I flashed CM10 the day before yesterday and it decided to lose the signal. O.o so what I did was flashed a stock Rom from recovery and noticed that it was trying to activate every time I rebooted or turned the phone on. ected to WiFi I can't access the internet... whenever I try to make a call it says something like 'welcome to Verizon Wireless. Please wait while we direct your call to an external operator where yout can complete it with a calling card or credit card'. I can't send any txt and under About Device the network is unknown. It still reads the correct IMEI number and has my cellphone number. I've tried flashing stock Rom with Odin and it's still saying that it's roaming. I'm running stock rooted ICS on SCH-I535.
    12-07-2012 01:27 PM
  2. jay_aye's Avatar
    I've had the exact same problem just happen to me.
    I flashed the miui rom to try something different, and it says i wasn't connected to any network and that my phone number wasn't registered.
    then i reflashed the old rom or restored back to another rom and now it says exactly what the OP says in his post.

    anyone have a clue?
    12-10-2012 05:34 AM
  3. ellocogato's Avatar
    I can only provide another sad voice to the crowd. My experience is exactly as jay_aye describes, as a result of trying out the Miui rom. I tried flashing via Odin (as when originally rooting the device) and that did not fix the problem. I also tried the utility at [Tool][Win] Repair IMEI & Roaming ERI issues - xda-developers, but there didn't seem to be a problem with my IMEI or ERI to begin with, and using that utility did not change anything.
    12-11-2012 11:17 PM
  4. mduranso's Avatar
    Hi, I had the same problem after flashing CM 10.1 and it lasted for a few days. However I was able to eventually solve it by doing the following:
    1) Wipe all (data, cache, dalvik)
    2) Flash latest KT747 kernel
    3) Wipe cache and dalvik again (do not wipe data/factory reset this time)
    4) Fix permissions
    5) Flash ROM again (in my case I went back to CM10)
    6) Flash GAPPS
    7) Boot. Use four corner touch to bypass activation screens.
    8) Power down, pull battery, remove sd card, pull then re-insert SIM
    9) Power up without re-inserting sd card
    10) Bypass activation screens again. 10 seconds later I had signal back. I then re-mounted my SD with no problem.

    I'm not sure if some of the steps I took were redundant or unnecessary but it worked. I hope it might for you all as well.
    12-23-2012 12:42 PM

Similar Threads

  1. Stuck on "Waiting for Device" trying to unlock bootloader
    By internettoughguy in forum Google Nexus One Rooting, ROMs, and Hacks
    Replies: 42
    Last Post: 09-21-2016, 03:35 PM
  2. Stuck on sending
    By nickf126 in forum Motorola Droid
    Replies: 11
    Last Post: 03-01-2012, 03:02 PM
  3. Google Voice stuck on install
    By ckale1 in forum Motorola Droid
    Replies: 2
    Last Post: 06-04-2010, 08:59 AM
  4. Eris Stuck on Android Screen
    By ericg1840 in forum HTC Droid Eris
    Replies: 0
    Last Post: 06-03-2010, 10:30 AM
  5. Stuck on sending
    By nickf126 in forum Motorola Droid
    Replies: 1
    Last Post: 12-28-2009, 11:08 PM