1. designwebs's Avatar
    This morning I boot up my phone and I see a msg. error. I open it and it says Samsung Link - Package file is invalid. I go into the play store and try the update again and get the same error. I reboot the phone and still get this error.

    Any idea on what is going on?
    08-07-2013 11:25 AM
  2. pkcable's Avatar
    I got an update also on my S4. It went fine for me. Are you on any alternate ROMs or anything like that?
    08-07-2013 12:41 PM
  3. GSDer's Avatar
    They've posted another update in the Google Play Store that fixes that problem.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4 Beta
    08-07-2013 12:42 PM
  4. designwebs's Avatar
    That fixed it. Thanks
    08-07-2013 12:53 PM
  5. hotrm0's Avatar
    Not for me. I still get the same error though I "uninstalled" and reinstalled.
    08-07-2013 06:22 PM
  6. anderd's Avatar
    This and other apps like Google+ and a few others are doing the same thing on my S3, i've reinstalled, cleared all caches even odin'd in a fresh stock rom, same results and nothing has fixed it yet.

    Annoying as all hell to say the least when you have 5 apps that dont want to install/update.
    08-08-2013 02:09 PM
  7. Philippe Lacoude's Avatar
    Same issue here. New today. I have four apps that give me the error over 4G on a S4:
    1. AT&T Messages
    2. Facebook
    3. Netflix
    4. SoundHound

    Eleven other apps updated just fine, some after a few tries, earlier today. I rebooted, I cleared the cache, etc... I am not rooted.
    08-08-2013 05:24 PM
  8. resturg's Avatar
    I am also getting package file is invalid when updating Samsung Link (AllShare Play). I have gone into setting and have cleared data and cache for Google Play application, but again I just got the same error message on attempt to update. I have got AT&T Galaxy S3 with latest OS 4.1.2 phone.
    08-08-2013 11:32 PM
  9. qualityresults's Avatar
    I found the solution on the phone go to samsung hub select apps click on the download arrow (installed apps) at the top and update manually from here it will work you may have to update your samsung hub.

    Hope this helps
    08-09-2013 12:15 AM
  10. bmoremu's Avatar
    I tried a number of things including those listed above but the only way I finally got it to work was by updating via 4G and not wifi.
    08-09-2013 10:40 AM
  11. jsc1429's Avatar
    Turning off Wi-Fi and manually updating worked for me as well
    08-10-2013 02:52 AM
  12. missmia87's Avatar
    08-11-2013 09:56 AM
  13. missmia87's Avatar
    I tried a number of things including those listed above but the only way I finally got it to work was by updating via 4G and not wifi.

    I had the same problem, none of the fixes above worked for me - so tried this. Turn wi-fi off, connect via mobile network (4G) and BOOM the update went through without a hitch. Thanks for posting!
    08-11-2013 09:57 AM
  14. Ann Rehder's Avatar
    turn off wifi... BOOM DONE
    08-11-2013 06:10 PM
  15. jcochran1977's Avatar
    Ok so why all of a sudden can we not install over WiFi? This is not good for those of us without Unlimited Data!
    08-11-2013 07:45 PM
  16. Mark Zagotti's Avatar
    I was having the same problem and I did this: went into settings, apps, selected Google play and cleared out the data. I was able to install the app I wanted.

    Sent from my EVO using AC Forums mobile app
    08-11-2013 10:35 PM
  17. montanaxvi's Avatar
    Getting package file error on my updates the past week or so on wifi or 4G. Tried several of the suggestions listed here and on other sites with no real solid solution. The app eventually updates after several failed attempts. I'm thinking it's a bug that Google needs to get worked out on their end of things.

    Edited to add....

    On 4G while at work and Twitter and Drippler continue to give package error, however, Samsung Push Service updated on the first attempt with no problem.

    Sent from my SCH-I535 using Tapatalk 2
    08-13-2013 07:39 AM
  18. jpriest007's Avatar
    Google knows about it already. They said they have no solution yet.

    Sent from my SCH-I605 using AC Forums mobile app
    Nanashi1231 and montanaxvi like this.
    08-13-2013 04:19 PM
  19. montanaxvi's Avatar
    Don't know if Google took care of something on the back end of things but for the last 10-12 hours or so, all updates are going without a hitch.

    Sent from my SCH-I535 using Tapatalk 2
    08-14-2013 11:08 AM

Similar Threads

  1. Is Nexus 5 Really Coming Along? (Please Read)
    By JasoLag in forum Rumored Devices Lounge
    Replies: 45
    Last Post: 08-30-2013, 10:12 AM
  2. Sound is too low on GalTab2 10.1" tablet
    By barnkeeperof10 in forum Samsung Galaxy Tab 2 10.1
    Replies: 4
    Last Post: 08-10-2013, 07:41 PM
  3. FB Messenger app Update Aug 6 2013...invalid package?
    By mccornwall in forum Android Apps
    Replies: 3
    Last Post: 08-08-2013, 09:44 AM
  4. PLEASE HELP.samsung galaxy s4 serious battery drain
    By jayid in forum New to the Forums? Introduce Yourself Here!
    Replies: 8
    Last Post: 08-07-2013, 07:01 PM
  5. samsung s3 update cannot view anything in gallery
    By elinen in forum General Help and How To
    Replies: 2
    Last Post: 08-07-2013, 11:59 AM