1. Jared Streisfeld's Avatar
    Hello just received a CLNR phone from VZW. My old S3 would take around 2 hrs to charge fully. However this replacement device takes 8 plus hrs to charge fully. I have tried different chargers and idk whats up with this? Any insights?
    04-14-2014 09:21 AM
  2. Mooncatt's Avatar
    Did you try a new cable with those chargers too? Usually it's the cable and not the charger that's bad. Otherwise it could be the charger port or maybe the battery itself.
    04-14-2014 02:31 PM
  3. GSDer's Avatar
    I'd call Verizon Customer Service, describe the problem and ask for another replacement. The replacement they sent you probably didn't come with a battery or charger or cable, so you're using your original stuff which worked fine - problem is in the phone they sent you, and frankly it's not YOUR job to troubleshoot it.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-14-2014 09:30 PM

Similar Threads

  1. Nexus 5: Unable to connect to Google Services
    By Anil Sabharwal in forum Google Nexus 5
    Replies: 20
    Last Post: 01-30-2016, 07:13 AM
  2. Charging S5 with micro USB (not micro USB3) charger from S4
    By Dualmonitors in forum Samsung Galaxy S5
    Replies: 59
    Last Post: 09-04-2015, 09:28 PM
  3. Tmobile putting an end to overages
    By dpham00 in forum T-Mobile
    Replies: 13
    Last Post: 04-21-2014, 09:02 AM
  4. Replies: 2
    Last Post: 04-14-2014, 11:27 AM
  5. how to disable 'sent from galaxy tablet' on note 10.1 2014
    By dibbs66 in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 3
    Last Post: 04-14-2014, 10:40 AM