1. hydrochetta's Avatar
    "The international call you are attempting to place is not allowed from this line. Please dial 00 for operator assistance or call 611 for Customer Service." Message 26G3XXX"

    This is the error message I get when attempting to return calls via my recent call list. The numbers are local, they are in the same town as me. I am located in the United States. I am using a Samsung Galaxy S3 from Verizon on Straight talk via GSM on a micro sim card. The phone works fine, I am able to call people, use data and mms after setting up the apn. But when I receive calls the phone automatically places them in my call list with a + in front of the number like, +6035550555. Even if I save the number in my contacts, the number still comes up as international with the + in front. I have tried saving the number with two number entries, the primary number being without the + and the secondary being the + to hopefully override the listing in the recent call list. I have verified in the call settings --> Other call settings --> Current country - United States of America.

    Verizon S3 on Straight Talk Via GSM / Calls coming in as International?! ='(-internationalproblem02.png

    So a quick overview,
    Verizon Samsung Galaxy S3 SCH-i535
    Straight Talk plan via GSM AT&T micro sim card
    Dialing calls works fine, Data works fine
    ALL calls are received with a + in front logging them as international.

    Verizon S3 on Straight Talk Via GSM / Calls coming in as International?! ='(-internationalproblem.png

    Considering I don't have international calling, when I attempt to call a person back via recent call list I receive the error message posted above. The error message is an AT&T error message I imagine via the AT&T compatible sim card. In turn I quickly contacted AT&T, they informed me they believed it was an error with my activation process and StraightTalk had somehow configured me out of range, or in roaming somehow. I contacted StraightTalk, StraightTalk of course dodged any ownership of the problem and quickly directed me to the manufacturer of the phone. I contacted Samsung who then reassured me this issue has never been logged into their database and he was unable to assist me.

    So here I am, looking for assistance. Any and all help would be appreciated.
    05-19-2014 07:41 PM
  2. gozirra's Avatar
    Phone icon, Menu button, Call Settings, Current Country (United States Of America).
    Right below that, Assisted Dialing (tap On), then tap the words then:
    Reference Country USA
    Country Code 1
    IDD Prefix 011
    NDD Prefix 1
    City/Area code (looks like you live in 603)
    National Number Length 10

    Hope that fixes it.
    05-19-2014 08:29 PM
  3. hydrochetta's Avatar
    No, that didn't help. Thank you for trying though. I was sure that was going to work too.
    05-19-2014 09:05 PM
  4. AxlMyk's Avatar
    Try changing those settings, then change them back.
    That has worked on a few other things.
    05-20-2014 10:36 AM
  5. hydrochetta's Avatar
    Try changing those settings, then change them back.
    That has worked on a few other things.
    No luck, thanks though. =\ I feel as though this issue could be resolved with a custom firmware/rom. I feel as though Verizon Galaxy S3 only has GSM mode for being outside the US so the phone automatically takes GSM information as being international despite the physical location of the phone.
    05-21-2014 12:09 PM
  6. skreet's Avatar
    Have you figured out a fix yet for you S3? If not see if you can get prefixer on the play store, if so follow these instructions - 1. install prefixer. 2. on the bottom left tap the "+" icon and tap "manual" ( make sure that rule is enabled at the top) 3. you will see a section called conditions under that select "when number matches" enter ".*" ( period star ) Click OK 4. scroll down to Remove characters and enter "\+" click OK. Now go to your call settings and in the assisted calling feature make sure IDD has 011. The other settings shouldnt matter. Now your caller ID will still come up like "+123-456-7890 but if you swipe over to call it will correct it to (123) 456-7890.
    Also be sure to save numbers in your contacts list as (123)456-7890 or 1234567890. as far as I have tested it everything works fine on GSM Networks on unlocked Verizon phones. I currently have a Verizon note 3 with a Straight Talk AT&T SIM and when I call someone from the call log it does work. Let me know if you or anyone else has any other tricks or workarounds. Hope this or something else works for you.
    GSDer, skmcneill and Chocu1a like this.
    08-08-2014 09:31 PM
  7. GSDer's Avatar
    Guess you're referring to Prefixer https://play.google.com/store/apps/d...below.prefixer
    It's always helpful to provide a link to the app, particularly in cases like this where there are similarly named apps.

    Share Apps http://market.android.com/details?id...gers.shareapps is a good way to share kinks to apps that you have installed.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-11-2014 01:07 AM
  8. skmcneill's Avatar
    These settings worked for me with Prefixer. THANK YOU! Been looking for something like this for a little while because of the hassle it has caused. I'm running Verizon Galaxy S5 on Straight Talk service.
    08-16-2014 10:46 PM
  9. George Magill's Avatar
    Thank you! Fixed both my unlocked Verizon S4s w/ StraightTalk by following these instructions! And I found Prefixer just fine without the link...
    09-14-2014 12:30 AM
  10. taisheree's Avatar
    I am having the same issue with making phone calls on my Samsung Galaxy Note Edge. However I am operating on the Cricket Wireless network. Did you ever resolve this issue? If yes, please share.

    04-18-2016 09:01 AM
  11. Really Confused's Avatar
    I'm having the same issue and I tried Prefixer app - it didn't work.
    02-07-2017 06:43 PM

Similar Threads

  1. HELP - How Can S Memo Data from S4 be moved to S5 if S Memo no longer works on S5 !!!
    By Fifth Element 1984 in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 4
    Last Post: 06-28-2014, 10:24 PM
  2. Replies: 22
    Last Post: 05-27-2014, 03:37 PM
  3. So I can only block unwanted calls for 90 days ?
    By Scott111 in forum General Help and How To
    Replies: 6
    Last Post: 05-21-2014, 07:46 PM
  4. How to change my info picture on note 2?
    By Nick Mattingly in forum AT&T Galaxy Note 2
    Replies: 1
    Last Post: 05-19-2014, 05:57 PM
  5. Data usage on a particular wifi SSID?
    By bhyde in forum Android Apps
    Replies: 0
    Last Post: 05-19-2014, 05:22 PM