1. Skarlet32's Avatar
    I don't frequent here a lot so don't shoot me

    I got my Kit Kat update yesterday. I'm noticing that GPS takes longer to lock on than before. Before the update it was almost instant lock on, but now it's maybe 40 seconds to a minute. I'm not sure if I'm missing a setting somewhere that changed or not? I did see that the location settings got merged with the GPS so I'm not sure if its part of the issue.

    Also, has anyone else noticed Waze running considerably hotter than before? My phone used to get warm before but now it's almost too hot to touch. I tried uninstalling and reinstalling but that didn't seem to fix it.
    06-24-2014 09:28 AM
  2. gwhizkids's Avatar
    No problems with the GPS lock, but funny you mention Waze and running hotter. Usually its my camera that runs hot, but I noticed yesterday that the phone was very warm and the camera was not open, but Waze was. Hard to isolate what the issue is, since KitKat is new (for us) and Waze had a major upgrade last week.
    06-24-2014 02:58 PM
  3. Skarlet32's Avatar
    I may have found a couple things that might help someone else.

    GPS Only mode locks on much faster and is more consistent than high accuracy mode for location settings. With High Accuracy is was taking 40 seconds to a minute to lock on and even then it would bounce around. GPS Only was an almost instant lock.

    Regarding Waze, I tried a few different things. With GPS Only mode and change the theme to night and limit events to on my route only I was able to keep the temp down. It was still warm but not as hot as default settings. This was also after a fresh charge over night and I also had the car charger plugged in. I know it wasn't the charger creating the heat as I drove home with just the charger in last night and it was staying cold. So I can only imagine between the GPS settings and the Waze settings that something was not jiving.

    I have a feeling that there may be some compatibility issues with Waze and Kit Kat though that's probably adding to the heat. I was noticing that the screen would flicker a bit as I was driving.
    06-25-2014 11:20 AM
  4. nolittdroid's Avatar
    My phone has been running really hot since the update but I'm not sure why. Im going to guess the screen.

    Sent from my SCH-I535 using AC Forums mobile app
    06-25-2014 08:30 PM
  5. TimBoch's Avatar
    I have problems with all my GPS programs. Only thing that gets an accurate signal is to turn off the location and turn it back on and accept the 2 pop up alerts. Then it's good. What a pain. Wish I could just go back to 4.1.2. Also, my email keeps alerting me to old emails as if I haven't read them. Very annoying.

    Sent from my SCH-I535 using AC Forums mobile app
    06-28-2014 10:30 PM
  6. Brian Baldwin's Avatar
    Timboch I am having that exact issue same way. It's with all of my gps apps including mapmywalk did you find anything that helped?

    Posted via Android Central App
    07-26-2014 10:24 PM
  7. GSDer's Avatar
    Welcome to the forums!
    did you find anything that helped?
    Did you wipe the system cache in Recovery mode after the OS update?
    Did you try a Factory Reset?
    Those are really the best options following an OTA if you're having problems.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-27-2014 12:17 PM
  8. Brian Baldwin's Avatar
    Actually GSdr the fix didn't include any of those, especially since I was coming off of a factory reset phone with the update all things cleared which is what caused the problems first place . But thanks for sticking with the generic answer Verizon teaches. I found a thread a year ago that talked about tightening the back screws on the frame. Even though all the screws felt tight I went out and tried it and I was back to normal. Haven't had an issue since with a problem that's been plaguing me for weeks.

    Posted via Android Central App
    07-28-2014 11:18 PM
  9. Wildside's Avatar
    But thanks for sticking with the generic answer Verizon teaches.
    The reason GSdr suggested the factory reset is because it usually works - whether or not it's the generic Verizon answer.

    My phone started randomly rebooting recently. The fix was a factory reset even though I'd been using that custom ROM for months.
    GSDer likes this.
    07-30-2014 08:46 AM
  10. lebeauc's Avatar
    I have the exact same issue as Tim and Brian.

    The first thing I tried to fix the issue was a factory data reset, which didn't work. I then tried the screw tightening fix, but they all seemed tight and it didn't help at all. The last thing I tried was reflashing the phone using Odin. At first I just did a reflash, which didn't fix the issue. I then did it again but reformatted the nand and it worked.... Or so I thought. After the initial reboot, GPS turned on when expected. After using the phone for a couple days, it's back to making me have to cycle the location toggle off and back on a couple times to get the GPS to work. Very frustrating. I would try to reflash back to 4.3, but I hear you should never downgrade because it could cause problems.

    Anyone else seeing this issue and have a possible fix?
    08-01-2014 10:58 PM
  11. GSDer's Avatar
    I then tried the screw tightening fix, but they all seemed tight and it didn't help at all.
    The screw tightening fix may not be enough; a user had posted his solution which involved the actual GPS antenna. IIRC he inserted a piece of foil or something like that at the spot where the GPS antenna connects to the board. If you search within the S3 forums you should find it (he either had pictures or a link to a YouTube video).

    You're right about not downgrading to 4.3 - others have reported soft-bricking the phone after doing that.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-02-2014 11:36 AM
  12. Brian Baldwin's Avatar
    I'm still working fine few weeks after the screw tightening haven't had any issues. Ya I thought they were all tight to hit bit did then fix. Before in had done full flash, cache cleaning and all that's when the issue started

    Posted via Android Central App
    08-03-2014 12:56 AM
  13. lebeauc's Avatar
    I've had the phone for over a year with absolutely no GPS issues. I update the phone to Kit Kat and now GPS issues start. If this was a true hardware issue, then I shouldn't be able to cycle the location toggle off and back on to get the GPS to work again.

    This seems like a software issue with a small amount of S3 phones with the new KitKat update. It may be a combination of tollerence with the GPS antenna and the new update. Maybe they lowered the tollerence, and us with a slightly weaker antenna are seeing the issue. If this wasn't my work phone, I would be upgrading to something other than Samsung.
    08-06-2014 12:25 PM
  14. GSDer's Avatar
    Unfortunately Samsung, in their infinite wisdom, has made it so that you can't load down-rev firmware, so you're stuck with KitKat.

    I don't know offhand if they updated the radios in the KitKat build; I suppose it may be possible to load just those. That would be a question best posed over on XDA.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-06-2014 07:21 PM

Similar Threads

  1. Thief and Cops
    By Evgenij Vinogradov in forum Android Games
    Replies: 1
    Last Post: 06-25-2014, 03:49 AM
  2. Replies: 2
    Last Post: 06-24-2014, 04:14 PM
  3. Went to Wimbledon yesterday and man 4G killed my battery
    By thegame161 in forum Samsung Galaxy Note 3
    Replies: 6
    Last Post: 06-24-2014, 02:16 PM
  4. Toggle and Watch Styler finally show up
    By jaltman in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 1
    Last Post: 06-24-2014, 01:35 PM
  5. Help locating ringtone and music
    By tony5496 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-24-2014, 10:14 AM