Yesterday 02:50 AM
36 12
tools
  1. meinharrd's Avatar
    i fixed it by editing the wrongly spelled contact via https://contacts.google.com/

    the phone synced the fix within minutes.
    10-04-2016 04:13 PM
  2. Shalabh Jhalawad's Avatar
    This worked like a magic. Thanks a lot
    11-04-2016 06:59 AM
  3. andy3l's Avatar
    Hey, I just figured it out. Go into any app, pull up your keyboard and start typing. When the wrong email appears in the auto fill area, tap on the arrow to expand the area. You should see 'Auto replace' at the bottom of the drop down, with an on-off button. Turn it off, tap and hold the incorrect email address, select 'ok' in the 'Remove' dialogue box, and turn auto replace back on. No more wrong email auto filling. :-)
    You sir, are a genius!! Many thanks :-)
    12-02-2016 07:33 AM
  4. geoffrey@partners4nature.com's Avatar
    i fixed it by editing the wrongly spelled contact via https://contacts.google.com/

    the phone synced the fix within minutes.
    I LOVE YOU! That is the fix. So elegant. Thank you.
    07-16-2017 09:14 PM
  5. junglecat14's Avatar
    The auto correct would be stored in your keyboard app, not Google or Gmail. Try clearing the cache / data of your keyboard app and see if that helps. I use Swiftkey, so I'm not sure what the name of the app is for the stock keyboard but I'm sure someone here or on XDA could point that out if you need it.
    This worked. Deleting contacts from Gmail contact list did not.
    Settings>Apps>Gboard>Clear cache
    Problem solved.
    03-30-2018 04:53 PM
  6. Paddy333's Avatar
    BIG THANK YOU to DLeoLion. Your solution worked for me

    Using Samsung Galaxy 7 & Android 7.0
    04-10-2018 07:06 AM
  7. Paddy333's Avatar
    MY Contacts VS OTHER Contacts Labels and auto-complete

    Once I cleared out the old auto-complete email addresses (thanks DLeoLion!) there was still a lot of junk from the Other Contacts folder in Gmail (Web) in the auto-complete list on my phone.
    When you create a new contact it is added to My Contacts.
    My Contacts phone numberes are synced with the Contacts App on my phone.
    Other Contacts phone numbers are NOT synced to phone.
    For years I've have been moving old contacts out of My Contacts into Other Contacts to keep phone contacts list tidy.
    BUT Gmail scrapes all the email address info from Other Contacts and adds it to the auto-complete list on phone.
    I wanted to clear these old email addresses from auto-complete too, here's what I did:

    1) Tidied all old contacts out from My Contacts to Other Contacts
    2) Some people in My Contacts have several email addresses. I moved the extra email addresses into their description text box. Email addresses in the description box are NOT synced to your phone.
    3) Exported Other Contacts to a 2nd Gmail account:
    Other Contacts > More > Export > Other Contacts > Google CSV
    then imported into a second Gmail account:
    My Contacts > More > Import ...
    4) Deleted Other Contacts from 1st email account.
    5) Un-installed/Re-installed Gmail App
    6) Voila all nice and tidy!

    If i want an old email address I will log into my 2nd email account on the web.
    You could add the 2nd account to your phone contacts temporarily, but you'll probably drag all the old email addresses into the auto-complete list.

    Hope that may be of use to someone

    If someone knows a simpler way to do this, please post )
    04-13-2018 07:25 AM
  8. tamar#AC's Avatar
    Thanks DLeoLion! Worked great on Android 8.1 on my Pixel 2 XL.

    Here's why I was initially skeptical to try it, though: I am NOT syncing my contacts to my phone! Yet, that was the fix. Very weird operating behavior, but it did it.
    05-30-2018 06:04 PM
  9. Jeffsharpesap's Avatar
    I know Blackberry is old, old news, but I still like (and pay for) their Hub.

    Just installed it on my new Google Pixe 3. Having the same problem with Hub when sending emails, but found the answer there.

    If you don't use Hub then this isn't as useful I guess. In "Contacts" (part of Hub) go to Settings and "Manage Suggested Recipients". You can search for the email you are having problems with and delete the 2 or 3 (or in my case 6) old/bad ones.

    Then I tried email again and volia, no more old/bad suggestions, only the good one.

    It might help a few older guys like me who still love Hub.
    11-30-2018 03:43 PM
  10. Mannypl's Avatar
    This is the correct answer. Works on my Galaxy S9 too.Many thanks Sarah, this has been bugging me on my old S5 phone as well as my new one. Now it's fixed! What Sarah means is press and hold on the incorrect prediction which is in blue till the warning pops up. I had to use a magnifying glass to read it but if i had turned the phone to landscape orientation I would have read it OK. Thanks again Sarah!
    06-24-2019 06:10 PM
  11. whispering_leaves's Avatar
    For anyone still have trouble finding a way to delete autofill addresses on Android, this is what worked for me.
    None of the addresses that showed up for me when I typed a letter in the To: field on my Android appeared in ANY Contact list on either my phone or in Other Contacts when I signed into Gmail on my computer. If you've made sure that the addresses don't appear anywhere else, then try this...(phone instructions are using Lollipop on Android, so depending on software it may be different):

    On the computer, sign into your Goggle account. Open Gmail. Click the Gear icon to get to Settings, General Tab, scroll down to "Create contacts for auto-complete", Check "I'll add contacts myself". Apply. Do this for any/all Gmail accounts that you have that download/sync to your phone. Doing this makes sure that any addresses you reply to in the future are not 'saved' as auto fill possibilities.

    Now remove your Gmail account(s) from your phone. Swipe down from top of phone to access Settings, Accounts, Google, Click on the account to remove (the one or ones you have the autofill addresses you want to get rid of), Click Menu (three vertical dots), Remove Account.

    Once account is removed, click the Gmail icon, Menu (three vertical lines), Settings, Add account, Check Google, Enter email address, Enter Password. Account will be re-added. Click the Gmail icon again and compose a new message. Enter a letter into the To: field and the nuisance addresses should be gone.
    I tried this but it didn't work. I removed my gmail and when I added it back, the autofill addresses hadn't gone. What I am doing wrong? Please help.
    Yesterday 02:50 AM
36 12

Similar Threads

  1. How to shorten DTMF, tones are too long
    By mpcook in forum Moto X
    Replies: 6
    Last Post: 09-27-2013, 06:01 PM
  2. Android 4.3--Coming to Verizon S4??
    By Seth_Overbury in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 09-27-2013, 04:45 PM
  3. How well does Verizon Hotspot work on the S4?
    By Deron Baker in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-26-2013, 11:54 AM
  4. How well does Verizon Hotspot work on Moto X?
    By Deron Baker in forum Moto X
    Replies: 2
    Last Post: 09-26-2013, 09:59 AM
  5. Can't get Hangouts to update on wifes phone; update worked on mine.
    By 1812dave in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 09-26-2013, 08:44 AM
LINK TO POST COPIED TO CLIPBOARD