06-24-2019 07:10 PM
35 12
tools
  1. Half Blind's Avatar
    The thread title pretty much says it all. I have a HTC One on Verizon and I have a couple of incorrect email addresses that autofill. How can I get rid of these?
    I've looked at the contacts involved, but the incorrect email addresses don't show there for me to edit. I'm lost..... again!
    Thank you,
    HB
    09-26-2013 10:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Where are they autofilling, the browser? The Gmail or email apps?
    09-26-2013 11:17 AM
  3. Half Blind's Avatar
    Thank you for the welcome!
    They are autofilling in the Gmail app. I can't find the incorrect spelling anywhere in my contact list.

    HB
    09-26-2013 11:24 AM
  4. B. Diddy's Avatar
    Try going to System Settings/Apps/All, select Gmail, and tap "Clear Cache." Then see if it still happens.
    09-26-2013 11:32 AM
  5. Half Blind's Avatar
    Thanks for taking the time on this.
    I did all of the above, went back into Gmail and opened a new email. Got the same thing when I started to address it.
    Maybe I should just stop being so lazy.

    HB
    09-26-2013 12:02 PM
  6. B. Diddy's Avatar
    Go to your Contacts or People app, and see if there is an option to Display All Accounts. Maybe you're only looking at one account's contacts, like Gmail's. But other accounts can sync with your phone's Contacts (like Facebook or Yahoo), and they might have done so without your being fully aware of it.
    09-26-2013 01:52 PM
  7. Half Blind's Avatar
    I looked at the settings and switched to search contacts by email, then tried typing the incorrect address that is haunting me and came up with nothing.
    I appreciate your help, but there is no sense in two of us pulling our hair out. I'll putz with it when I can, and not be so lazy until I either fix it or go nuts, or live with it.

    Thank you again,
    Half Blind
    B. Diddy likes this.
    09-26-2013 05:27 PM
  8. atakin77's Avatar
    The auto correct would be stored in your keyboard app, not Google or Gmail. Try clearing the cache / data of your keyboard app and see if that helps. I use Swiftkey, so I'm not sure what the name of the app is for the stock keyboard but I'm sure someone here or on XDA could point that out if you need it.
    B. Diddy likes this.
    09-27-2013 10:16 AM
  9. Half Blind's Avatar
    Hey Thanks!
    I use Swiftkey also, so I'll work on figuring that out.

    HB
    09-27-2013 10:22 AM
  10. Half Blind's Avatar
    I got into SwiftKey and cleared the cache. Incorrect autofill still occurs.
    Time for me to man up and just type the whole email address when I need to.
    Thanks for all of the replies.
    Half Blind
    09-30-2013 12:50 PM
  11. Half Blind's Avatar
    I went into Swiftkey and deleted the cache. No change in the erroneous autofill.
    Time for me to man up and just type the complete email address when I need to.
    Thank you to all who took the time to have a look and offer suggestions.

    Half Blind
    09-30-2013 12:58 PM
  12. JBarOfficial's Avatar
    1: Go to Browser’s settings
    2: On the General section, activate Form Autofill
    3: Go to Autofill Data section
    4: Change email addresses
    5: After done, tap Save Profile
    03-05-2014 06:14 PM
  13. Sarah Fee's Avatar
    Asked my boyfriend; He just got an S5. The issue is the word is a "learned word". when the email comes up if its in blue, just press and hold on the email and it will come up with a warning saying it will be removed from "learned words" click remove or yes or whatever and problem solved
    Mannypl likes this.
    10-23-2014 12:11 PM
  14. 1234567abc's Avatar
    Annoying email autofill successfully been solved this afternoon (been a long battle and very irritating).
    Not clearing by "clear data", " clear cache", not uninstalling Emai app, NO NO NO! They won't work!

    Simply:
    Go to Phone Contact > down right bottom there are 3 dots > Filter >

    You will see there are many social apps under "Display Contacts", like Viber, ICQ, Wechat, Local Contact, Whatsapp, Facebook, Yahoo, Google, Skype etc.

    click each of them out, and tick ALL boxes, then click "Done"

    Go back to the Phone Contact, you'll find there are quite a lot unwanted contacts. Some contacts simply just with email addresses. They have all been filtered and unseen until you have just filtered them out, allowing them to be seen.

    So now you could easily find those " annoying email autofill email addresses" in the Contact, simply DELETE them. I found I have like over 20 contacts under the same email addresses, same contact names too.

    A baby shop email address which I accidentally added before. It has been saved under my personal email address, that's insane! (but it wasn't in my email contact list if I open my email in computers. It's only been saved in my Android phone) So whenever I wanna send email to myself , the autofill sends to that baby shop! It made me crazy and I was unable to solve it because the Contact filtered out email addresses and I didnt realise I had actually saved somewhere.

    Now I have figured it out and hope it will help people out there. ( since I noticed many people couldnt solve this issue)

    Cheers!
    12-20-2014 02:02 AM
  15. King Wilbur's Avatar
    I have a Moto G and having same autofill issues of email addys on my gmail account for the phone. Some addresses I have no idea what or how they got to autofill. How do I delete them? Tried the suggestions listed here so far with no luck. Any suggestions???
    01-01-2015 09:57 AM
  16. appsy31's Avatar
    Excellent work! Actually it is so easy to fix that it is almost funny.
    01-07-2015 08:33 PM
  17. NPrTech's Avatar
    I couldn't find anything named Phone Contact. When I went to Contacts, there were no three dots and Filter. Clicking on the three lines at the bottom right in Contacts did not reveal a Filter option either.

    Where might I find Phone Contact as opposed to Contacts?

    Thanks
    02-13-2015 10:56 PM
  18. jacquelineap's Avatar
    Thank you for asking this question!
    I, too, cannot find "phone contacts".
    Did you ever get any response to this question??
    THANKS!!
    01-13-2016 01:54 PM
  19. Kaell's Avatar
    Samsung Galaxy S4 mini.

    I too have no "Phone Contact".

    "Contacts" takes me to the "Contacts" tab of Phone/Groups/Contacts. There are no 3-dots or anything of the sort. There is only Search, Create contact, the list of contacts, and "displaying 12 contacts".

    There is one entry that I want gone. But it is not in Google Contacts. It ONLY appears when I start typing in gmail "to" field. I cannot otherwise find this person anywhere or via any search. On my phone or in my google account via PC.
    02-16-2016 04:06 PM
  20. Kaell's Avatar
    Clicking the alt-menu button next to the home button also gives me:

    Delete
    Accounts
    Speed dial settings
    send message/email
    Settings


    Accounts only has my gmail account listed.

    Speed dial settings only has 2 items that are not "not assigned. And neither of them are the entry I want gone.

    Send message/email just lets me create a new message/email.

    Settings has "only contacts with phones" which I don't want. "List by" option settings, "Display contacts by" option settings, "service numbers", and ATT address book, which is not setup.
    02-16-2016 04:13 PM
  21. tatowles's Avatar
    Samsung Galaxy S4 mini.

    I too have no "Phone Contact".

    "Contacts" takes me to the "Contacts" tab of Phone/Groups/Contacts. There are no 3-dots or anything of the sort. There is only Search, Create contact, the list of contacts, and "displaying 12 contacts".

    There is one entry that I want gone. But it is not in Google Contacts. It ONLY appears when I start typing in gmail "to" field. I cannot otherwise find this person anywhere or via any search. On my phone or in my google account via PC.
    Did anyone ever figure out what he means by phone contact?
    05-01-2016 05:52 PM
  22. DLeoLion's Avatar
    For anyone still have trouble finding a way to delete autofill addresses on Android, this is what worked for me.
    None of the addresses that showed up for me when I typed a letter in the To: field on my Android appeared in ANY Contact list on either my phone or in Other Contacts when I signed into Gmail on my computer. If you've made sure that the addresses don't appear anywhere else, then try this...(phone instructions are using Lollipop on Android, so depending on software it may be different):

    On the computer, sign into your Goggle account. Open Gmail. Click the Gear icon to get to Settings, General Tab, scroll down to "Create contacts for auto-complete", Check "I'll add contacts myself". Apply. Do this for any/all Gmail accounts that you have that download/sync to your phone. Doing this makes sure that any addresses you reply to in the future are not 'saved' as auto fill possibilities.

    Now remove your Gmail account(s) from your phone. Swipe down from top of phone to access Settings, Accounts, Google, Click on the account to remove (the one or ones you have the autofill addresses you want to get rid of), Click Menu (three vertical dots), Remove Account.

    Once account is removed, click the Gmail icon, Menu (three vertical lines), Settings, Add account, Check Google, Enter email address, Enter Password. Account will be re-added. Click the Gmail icon again and compose a new message. Enter a letter into the To: field and the nuisance addresses should be gone.
    05-10-2016 12:20 PM
  23. Sharpen1's Avatar
    Hey, I just figured it out. Go into any app, pull up your keyboard and start typing. When the wrong email appears in the auto fill area, tap on the arrow to expand the area. You should see 'Auto replace' at the bottom of the drop down, with an on-off button. Turn it off, tap and hold the incorrect email address, select 'ok' in the 'Remove' dialogue box, and turn auto replace back on. No more wrong email auto filling. :-)
    05-12-2016 07:47 PM
  24. tkt2786's Avatar
    I had old auto-complete addresses popping up on my Gmail app on my phone, and different ones popping up on my computer, which was completely annoying. So this is what I did, with help from this thread and a lot of other googling. Full disclosure, I do NOT have a HTC one, but this was the most useful thread I found on the problem.

    STEP ONE: Preventing future issues.
    To prevent this from happening in the future, first I did what DLeo suggested.

    On the computer, sign into your Goggle account. Open Gmail. Click the Gear icon to get to Settings, General Tab, scroll down to "Create contacts for auto-complete", Check "I'll add contacts myself".
    Be sure to click Save at the bottom of this screen.

    STEP TWO: Cleaning up bad contacts (still on the computer).
    Go into Contacts on the computer. Go to More, then Other Contacts (this took me to the "old" contacts, where you have to again choose "Other Contacts"). Go through the list that appears and delete all the email addresses you don't want. Heck, while you're here, you could go through all your contacts and clean them up...but "other contacts" seems to be where Gmail stored the addresses of everyone I ever emailed.

    STEP THREE: Log out, repeat steps 1 and 2 on the computer with other Gmail accounts you have. (I needed to log out and log back in before I could stop seeing the bad auto complete addresses on my computer.)

    STEP FOUR: Clear Data and Cache - in ALL mail apps!
    This is when I did many, many things on my phone. I removed my google accounts from my phone, re-added them. Cleared data and cache in the Gmail app. Cleared data and cache in the Contacts app (if you do this, make sure you have a backup first, somewhere). Filtered contacts in the Contacts app. Restarted phone. Synced contacts for Gmail. But every time I went into Gmail to test this, no matter which account I tried, I kept getting the list of auto-complete addresses that didn't seem to exist anywhere else.

    It occurred to me that I also have a hotmail address on my phone, in the standard Email app. Just on a whim, I went into Apps - Email and also cleared data/cache. A bunch of the bad addresses showing up seemed to be ones I had only emailed through the Gmail app, but still..I was desperate. After re-adding the info for my hotmail account back again, all the bad addresses finally disappeared everywhere, including from the Gmail app!

    (I went onto my hotmail account in the web browser on my computer and clicked on the menu to go to People. None of the bad email addresses showed up here, but I still cleaned up the whole contact list. Then I went back to outlook.com and went to settings, options, then Advanced Privacy Settings where I selected "only suggest people in my contact list" and hit save.)

    Super annoying problem, but glad I found this thread which sent me down the right path. I'd already suspected that Google tracks and remembers everything about me, and I know it for sure now.
    05-18-2016 05:00 PM
  25. mefl2011gmail.com's Avatar
    After trying several ways to remove the bad e-mail address, I discovered that all you need to do is
    1. open to key board add
    2. type in the e-mail address
    3. tap the ">" symbol to the right hand side of the e-mail address to display the bad address
    4. select the e-mail address then a box will be displayed "REMOVE" just select "OK" to remove the bad autofill word
    5. all should be fixed (P.S. this can be used to remove anything in the autofill fields"
    08-07-2016 02:59 PM
35 12

Similar Threads

  1. How to shorten DTMF, tones are too long
    By mpcook in forum Moto X
    Replies: 6
    Last Post: 09-27-2013, 07:01 PM
  2. Android 4.3--Coming to Verizon S4??
    By Seth_Overbury in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 09-27-2013, 05:45 PM
  3. How well does Verizon Hotspot work on the S4?
    By Deron Baker in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-26-2013, 12:54 PM
  4. How well does Verizon Hotspot work on Moto X?
    By Deron Baker in forum Moto X
    Replies: 2
    Last Post: 09-26-2013, 10:59 AM
  5. Can't get Hangouts to update on wifes phone; update worked on mine.
    By 1812dave in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 09-26-2013, 09:44 AM
LINK TO POST COPIED TO CLIPBOARD