1. JRLiger's Avatar
    First time this has ever happened to me, and I've been using the built in Music app for some time. I bought some music from Amazon. Attached my Rezound and copied it over (directory and all) to my SD card. Load up Play Music and the album isn't there at all - not a single song. If I open the build in Music app, it's there. If I go through my file manager and click on a song it plays in any app I want it to play in (Music or Play). I've restarted my phone and it still isn't showing up in Play Music

    Any ideas?
    07-24-2012 09:23 AM
  2. bellken's Avatar
    settings ->storage

    unmount and re-mount your SD card

    it sounds your SD card got lost
    07-24-2012 09:37 AM
  3. JRLiger's Avatar
    Not sure that's the issue. I've rebooted my phone, which mounts/unmounts the card, and that didn't solve it. Also, the album does show up in other music apps. The only app it fails to show up in is Play Music.
    07-24-2012 10:00 AM
  4. DestinedtoGame's Avatar
    I came across the same issue today. Restarted my phone too. Nothing but the music I bought from Google Play.
    07-24-2012 10:27 AM
  5. JRLiger's Avatar
    Think I got it. Had to clear cache, clear data, and force stop the app. It's now refreshing the music and I see the album.
    rimroot and XXZacXMorrisXX like this.
    07-24-2012 10:47 AM
  6. tazzy519's Avatar
    I have this problem too and this solution works for me also but I have to do it EVERY TIME I add new music or restart my phone..
    12-02-2012 01:05 PM
  7. mlbau's Avatar
    I have the same problem when I add music and go to the Google player there is nothing or only the music I last added, I have rebooted the phone and no joy, I have found though if I uninstall the last update and reinstall it all my music is back... there seems to be no help from Google and the problem persists
    12-05-2012 05:11 PM
  8. Terry Turner's Avatar
    If you find that certain songs are missing from albums, just go to that album in google play desktop, select all the tracks and right click... then select 'edit track info'.

    A box will appear with the information for you to edit, but you don't have to do a thing, just click on save and the tracks will then sync to your android device!

    Strange, but it works for me ;^\
    12-11-2012 08:16 AM
  9. Varden Soogrim's Avatar
    You probly have a .nomedia folder in yur sd card. Find it ,delete it and then remount yur sd card
    06-14-2015 12:12 AM
  10. rimroot's Avatar
    Think I got it. Had to clear cache, clear data, and force stop the app. It's now refreshing the music and I see the album.
    I had same issue. I bought album in Google Play and only half of them were visible. Clearing cache and data solved this issue.
    02-24-2016 05:34 AM
  11. akiraaisha's Avatar
    I think the latest version of Google Play Music has its bug. What I did is I Uninstalled the Google Play Music in Play Store, so basically it will go to its outdated version. But when I use it, It works fine now. I can play my musics fine and all.
    05-13-2016 07:53 PM
  12. Semi charmed kinda life 99's Avatar
    But when you clear cache and data doesn't that delete the music
    01-09-2017 09:15 PM
  13. Semi charmed kinda life 99's Avatar
    Think I got it. Had to clear cache, clear data, and force stop the app. It's now refreshing the music and I see the album.
    But when you clear cache and data doesn't that delete the music
    01-09-2017 09:16 PM
  14. LeoRex's Avatar
    But when you clear cache and data doesn't that delete the music
    No, all that's stored in your Google account. Clearing the data won't bother it.

    But yes, I've had this happen a couple of times and wiping Music's data usually clears it right up.
    01-09-2017 09:27 PM
  15. Tuyizere19's Avatar
    You probly have a .nomedia folder in yur sd card. Find it ,delete it and then remount yur sd card
    Thanks man helped, had the same issue
    02-09-2017 05:08 AM
  16. kmf1's Avatar
    I just started experiencing this issue where not all of my music on my sd card shows up in the Google Play Music app. After reading the above posts, I Force stopped the app and then disabled it, which brought the app back to the factory version. I restarted my phone and then enabled the app. All of my music is now there. I have not updated the app yet. I will wait a day or two before updating the app to see how things go. If, after updating the app, the problem re-appears, then to me, there is a glitch in the app...not our sd cards. I will test and get back in a few days.
    04-10-2017 10:30 PM
LINK TO POST COPIED TO CLIPBOARD