1. rolo99's Avatar
    When I first got my TB, I would get 4G speeds of 20-32mbps. Now I get 6-8mbps. Yesterday I was in a Verizon store, playing with the Samsung S3 getting 4G speeds of 25-30mbps. I have upgraded my 4G card, per Verizon's suggestion, but it didn't change anything.

    Sent from my ADR6400L using Tapatalk 2
    09-14-2012 08:38 AM
  2. dpham00's Avatar
    When I first got my TB, I would get 4G speeds of 20-32mbps. Now I get 6-8mbps. Yesterday I was in a Verizon store, playing with the Samsung S3 getting 4G speeds of 25-30mbps. I have upgraded my 4G card, per Verizon's suggestion, but it didn't change anything.

    Sent from my ADR6400L using Tapatalk 2
    My Tbolt has a subpar radio, even compared to my GS3. I too get about double the speed on my GS3, Rezound, Razr, Razr MAXX as I did on my Tbolt. In fact, my Tbolt never broke 30mbps. All of my other phones have broken 60mbps.


    My friend has a Tbolt, even side by side, hers seems to drop data much more frequently than my other phones.

    Sent from my Droid RAZR MAXX / Atrix Lapdock
    09-14-2012 09:19 AM
  3. anon(394005)'s Avatar
    It's because of ICS, it has magical powers to boost your speed. Seriously, I still see good speeds (average 20 up, 15 down). I've even seen over 30 from time to time, especially in a sparsely populated area where the tower is lightly loaded. The only time I see slower speeds is in a highly populated area where the towers have a high load on them. Keep in mind a fully loaded LTE tower is said to average data speeds of 5-12Mbps. Also, speed results can vary depending on test method (ex. app or web site) and what test server you're using.
    09-14-2012 10:53 AM
  4. rolo99's Avatar
    What I don't understand is that 18 mos ago, when I got my TB, I was getting 32 mbps, in my own house. Now I get 6-8, even in the middle of the night. The Verizon store is 10 miles away. But the store and my house are both in what is considered "central" Denver.
    09-14-2012 03:06 PM
  5. viper31573's Avatar
    I'm getting about 8 and 3 but there is no 4g in my city. I'm getting it from the city just north of me. Next time I'm in that city I'll have to check again

    Sent from my Thunderbolt using Tapatalk 2
    09-14-2012 06:11 PM
  6. anon(394005)'s Avatar
    What I don't understand is that 18 mos ago, when I got my TB, I was getting 32 mbps, in my own house. Now I get 6-8, even in the middle of the night. The Verizon store is 10 miles away. But the store and my house are both in what is considered "central" Denver.
    So you only get 6-8 regardless of location or test method/test server used? Are you using the stock ROM yet or a custom one? If using custom, see this thread that breaks down speeds by ROM: http://forums.androidcentral.com/thu...-vs-sense.html

    Something else to consider are the LTE antenna contacts in the battery door (upper right looking at internal of door). If they're tarnished at all or if the battery door isn't fitting very well anymore, it could impact their connection to the phone and signal strength/quality. You could try to carefully clean them with a pencil eraser. Be gentle as the metal is thin. Or try another door if you have one or get a new one. If all else fails, you could try a master (factory) reset just to get to a known clean state to see if that makes a difference.
    09-15-2012 07:20 AM
  7. bjboucher's Avatar
    My 4G speeds have been down ever since the switch to Gingerbread. When I got my phone in April of 2011 I was getting 30ish mbps too. I've gotten less than 10 ever since the switch last summer. This is comparing apples to apples....sitting at my desk in my house using the same Speedtest app.
    09-15-2012 07:46 AM
  8. rolo99's Avatar
    I'm on a custom ROM....Thundershed 1.5. I'll check out the ROM list.

    Sent from my ADR6400L using Tapatalk 2
    09-15-2012 10:11 AM
  9. androidguy916's Avatar
    With my original TB I was only able to get 7 down at best; I don't recall my upload speed but I believe it was 5 using the Speedtest app. Even after a factory reset no change. I did the contact cleaning routine but no change. I had my TB replaced a couple of months ago for a non-responsive section of screen and ended up with what appeared to be a brand new unit. Just for grins I tried using the Speedtest app again with the new phone and my download speeds are now 22+ consistently. For me, the issue was the phone itself. I don't use 4G since it sucks battery so quickly. There's nothing I need to do on 4G that I can't do on 3G. This is my 1st smartphone experience so I have no basis for comparison. 3G works for me.
    09-15-2012 11:38 PM
  10. wolf howl's Avatar
    When the TB originally came out it was the only 4G phone out there and now we're competing against a LOT of other 4G phones for the same bandwidth. If those other phones have better radios, which is very likely given they are quite a bit newer, this would all make sense to me.
    09-16-2012 10:05 AM
  11. gollum18's Avatar
    Simply put better radio. Look at the dates of when the Tb was released and when the s3 was released.

    Sent from my SPH-L710 using Tapatalk 2
    09-16-2012 10:25 AM
  12. viper31573's Avatar
    I tried changing my radios today. I couldn't get mobile data at all. Had to flash back

    Sent from my Thunderbolt using Tapatalk 2
    09-16-2012 04:47 PM
  13. mightyfacundo's Avatar
    I tried changing my radios today. I couldn't get mobile data at all. Had to flash back

    Sent from my Thunderbolt using Tapatalk 2
    Which radios did you try and with which ROM?

    Sent from my ADR6400L
    09-16-2012 04:55 PM
  14. viper31573's Avatar
    tried the raidos in this thread using jesters ICS
    09-16-2012 05:58 PM
  15. viper31573's Avatar
    Is there a difference between jesters and liquids? Is it possible if I switch some of the issues I'm having might go away?

    Sent from my Thunderbolt using Tapatalk 2
    09-16-2012 06:04 PM
  16. mightyfacundo's Avatar
    I think you should stick with the .19 radios with both of those ROMs. Those are the radios that Jester and Liquid used for testing their ROMs, and I haven't had any radio related issues when using them. I've used both of them, but to be honest, I'm back on Thundershed until they work out all of the little kinks. Plus, I really like the 4D app drawer animation in ADW Launcher Ex. What are the main problems you're having with them? And no, the ROMs are basically the same and based on Liquid's base. Jester just themed and modded his.
    09-16-2012 07:03 PM
  17. viper31573's Avatar
    Low wifi signal when I'm not basically on top of router

    Connecting to wifi when I first turn on phone

    Switching from wifi to data when I leave house

    Maybe I'll try thundershed

    Sent from my Thunderbolt using Tapatalk 2
    09-16-2012 08:44 PM
  18. steve0617's Avatar
    What I don't understand is that 18 mos ago, when I got my TB, I was getting 32 mbps, in my own house. Now I get 6-8, even in the middle of the night. The Verizon store is 10 miles away. But the store and my house are both in what is considered "central" Denver.
    Are you using the speedtest.net app? Try a different server out here. Use the 'Woodland Park CO' one even though it's far away. I'm in Roxborough.

    I ALWAYS get the fastest speeds from that one, while the 'Denver' one is always slower.

    My test (on Bamf Forever 1.09 with most recent radios) was just 18784/8561.
    09-20-2012 09:41 AM

Similar Threads

  1. Why does my 4G mode keep turning back on?
    By vaylen in forum HTC EVO 4G
    Replies: 7
    Last Post: 04-02-2013, 03:23 PM
  2. Why Does My 4G LTE Signal Vary So Much Doing Nothing?
    By GNex Girl in forum Verizon Galaxy Nexus
    Replies: 12
    Last Post: 02-08-2012, 10:40 PM
  3. Why Does My LTE GNex have a GSM only Setting?
    By GNex Girl in forum Verizon Galaxy Nexus
    Replies: 1
    Last Post: 02-07-2012, 10:30 AM
  4. Why does my new GN from Verizon store have 4.02 out of the box?
    By weboston in forum Verizon Galaxy Nexus
    Replies: 10
    Last Post: 01-20-2012, 12:12 AM
  5. Why does my TB think I'm in Seattle?
    By dokonak in forum Verizon HTC Thunderbolt
    Replies: 4
    Last Post: 07-13-2011, 02:52 PM
LINK TO POST COPIED TO CLIPBOARD