1. withravenoushunger's Avatar
    Every time I use Google Navigation or maps it takes at least a few minutes to find the directions and load the satellite map. When it does, the location is very inaccurate. When I first got the phone it worked fine. it was pinpoint accurate and the arrow went along smoothly instead of jumping. I've tried GPS Status but it didn't do anything.
    04-25-2011 03:07 PM
  2. Almightyclown's Avatar
    There should be an OTA rather soon that will help that. Mine is perfect at times and then at times can't even tell I'm already on the interstate.
    04-25-2011 04:56 PM
  3. realitydigg's Avatar
    I leave GPS off most times, when i turn it back on it takes a looooong time to get its bearings. This is one of the things reported fixed in the leaked version. People are saying it locks on almost immediately
    04-25-2011 05:31 PM
  4. potatolover1102's Avatar
    Never turn it off and you should be ok. I have never turned mine off and it takes less than 5 seconds to find me always! Even times in a building near a window I get lucky!
    04-25-2011 06:05 PM
  5. withravenoushunger's Avatar
    Never turn it off and you should be ok. I have never turned mine off and it takes less than 5 seconds to find me always! Even times in a building near a window I get lucky!
    That would destroy the battery
    04-26-2011 11:08 AM
  6. Chrisy's Avatar
    That would destroy the battery
    Leaving it on doesn't drain the battery. Using it does. I leave mine on all the time. I keep stand alone off unless I need it.

    I use Google Latitude with the VZW and Google assisted GPS on all the time, with little drain.

    Actively using stand alone GPS with Google Navigation and c:geo uses more battery.
    04-26-2011 11:20 AM
  7. Joe378's Avatar
    Will this be in the form of a software update and does it happen automatically or do I need to install it when it becomes available OTA.
    04-26-2011 12:19 PM
LINK TO POST COPIED TO CLIPBOARD