1. allaboutnewphone's Avatar
    Hi, Lately I haven't been receiving some text messages, I will get some and then some I don't. Reason I know this is, my husband had texted me before coming home from work, when he got home he said did I get his text?? I looked at my phone, no text from him. A friend of mine also texted me something that I never received. Also my sister who has the same phone (thunderbolt) send me text that I don't receive. Her phone is also having the same issues. Does anyone know what's going on? Anything to fix this problem??? I really don't want to do a hard reset on my phone.
    06-02-2011 12:38 PM
  2. phoenixone's Avatar
    I'm not sure if my problem is related to yours but I have trouble "sending" texts where my wife says she didn't receive my texts. Looking further, I realized that even though I pressed send, it was never sent. I went into the settings under messages and checked off play notification sound when messages are sent and show notification in status bar when messages are sent. Then I sent her another text message and I didn't get the notification that it was sent. About 15 mins later, I get a notification that both were sent and that's when she told me she received them.

    Check to make sure that when you send a message that it actually went through. Maybe that's why they are not receiving them.
    06-02-2011 12:48 PM
  3. allaboutnewphone's Avatar
    They are receiving my texts, I just don't receive all of theres, I will get some here and there but not all. I just called Verizon and they said there's nothing they can do about it??? WEIRD!!! I'm getting frustrated
    06-02-2011 01:09 PM
  4. dhendriksen's Avatar
    I would go to your sisters or husbands phone and make sure that they were actually sent from their phone, that they show up as sent messages. Maybe they failed to send and the problem is actually on their end.

    Like the other poster, I have had that issue as well.
    06-02-2011 01:32 PM
  5. GoldenEmu's Avatar
    I have the same problem. For me it seems to happen sporadically when I'm in a weird 1x area. I get a bunch of texts during the day and at some point they just stop. My texts go through to everyone, but I don't get anything coming in. Sometimes a reboot helps, but normally I have to wait until the next day when I get a flood of all my missing texts at once. There doesn't appear to be any way to force the phone to check for new messages.

    When I'm in my normal extended 4g area texting is fine. I never have any issues. My problem only happens in the 1x area (happens to be West Virginia).
    06-03-2011 04:35 PM
  6. Forgetful's Avatar
    Have youcleared the cache and data from your messaging app yet?
    06-03-2011 05:59 PM
  7. Wise.945's Avatar
    I cleared my cache and received a few MMS but can no longer receive them. It seemed like a temporary fix.
    06-04-2011 06:53 PM
  8. ttist25's Avatar

    I've been having a similar issue since receiving the OTA upgrade Monday (10/31/11). I receive notification of texts through vibrate and ring tone but, when I go to check the message, there's nothing there. It's an intermittent issue and I haven't been able to nail down any pattern.

    In testing I had my wife text me. I received notification of a text message from her shortly thereafter (she has her own ring tone for texts on my phone). I opened the Chomp SMS texting app and there's no message. I then open the stock messaging app and also there is no message.

    I use Chomp SMS after suffering a nasty divorce when a text - destined for my girlfriend - was routed to my now ex-wife's phone. Supposedly the "text roulette" issue has been fixed with this update but, as you might have imagined, I'm a little hesitant to give it a go.

    Another symptom I've noticed is that when I go to the apps screen to check the stock messaging app for the text, there are two "Messaging" icons on the screen. One is in the "m" location (alphabetically) and another is in the "v" position. One of them (I can't remember which) has a number 1 on it indicating that there's a new message but when I click it there's nothing there. Also, when I go back to the app screen the messaging app icon is replaced with a green Voicemail app icon.

    It seems as if maybe the new update tried to separate the messaging and voice mail apps (which would be welcomed by me if it worked because going to "messaging" for voicemail seems absurdly counter-intuitive to me).

    I reset the phone to factory and sent out a few texts through the stock app but haven't received any replies as of yet. Of course, that could be due to the fact that they haven't actually replied or, it could be that my messages are floating around somewhere in the ether.

    Anyway - YOU ARE NOT ALONE. Anyone listening Google/Verizon/HTC?
    11-02-2011 09:40 AM
  9. project.in.process's Avatar
    if you upgraded your radio in that update, that could be to blame.

    reason--i upgraded to the .3 radios from the RUU that was leaked & immediately stopped receiving texts.
    so, i downgraded my CDMA radio to the .2 leak (but kept the LTE radio the same) and instantly began getting texts again.

    just an option--but there's already a few threads on this issue here & on xda (in which i've posted the same thing & others have had the same success after trying this process)

    sloan31 likes this.
    11-02-2011 10:14 AM
  10. JerseyDubbin's Avatar
    for the sending portion i have been having issues as well, but only to numbers that have synced with fbook and fbook appends a +1 to the number. The messages will fail every time. Not sure if it's related but wanted to throw it out there.
    11-02-2011 01:37 PM
  11. sloan31's Avatar
    Having same problem here...I'm going to try downgrading my radio to see if it fixes it.
    11-11-2011 09:52 AM
  12. elvis692's Avatar
    Was having the same problem. I was using hancent with no problems, then i had to replace my phone after dropping it. Handcent no longer available so i tried chomp and had recieving problems off and on too. Verizon had me remove chomp amd the problem went away. Maybe after the last update the aftermarket text apps arent keeping up?? Frustrating!!
    11-11-2011 10:14 AM
  13. sloan31's Avatar
    Interesting...I'm using Chomp as well. I'll ditch that and see if it resolves my problems. Maybe try GoSMS, seems a lot of people are liking that.
    11-11-2011 10:22 AM