1. TheBull50's Avatar
    I have rooted my phone already and want to upgrade to Kit Kat. I have the ROM downloaded using ROM Manager as the app. Using the latest cyanogenmod mod ( cm-11-20140410-NIGHTLY-vs980 ). When I got to get into recovery mode, all I get is a Android Guy with a red triangle and an exclamation point on it. It is almost like I can't reboot into recovery mode. I tried factory resetting the phone once and still can't reboot into recovery mode. Any suggestions?

    I am trying to follow this youtube video:
    04-11-2014 11:18 AM
  2. SactoKingsFan's Avatar
    Do you have the most recent version of TWRP custom recovery?

    Sent from my G2 running PAC-ROM
    TheBull50 likes this.
    04-11-2014 01:56 PM
  3. TheBull50's Avatar
    I just downloaded TWRP 2.7 as a ZIP file. I saved it to my phone in the Download folder. I treid to used rom manger again and now all I am getting is a black screen. If I hold the power button in for about 10 seconds, the phone will restart. Kind of confused to be 100% honest. I know my phone is rooted so I'm good there. Do I run ROM manager and intstall the TWRP 2.7 zip file I have .. I tried that too and again.. black screen
    04-11-2014 02:07 PM
  4. SactoKingsFan's Avatar
    You can't install the zip file without custom recovery. Try the freegee app. It will install TWRP. Then you should make a backup in TWRP and flash the ROM through ROM manager or ROM Toolbox. I prefer ROM Toolbox since it has more features and has built in ROM installer and updater.

    Sent from my G2 running PAC-ROM
    04-11-2014 02:32 PM
  5. SactoKingsFan's Avatar
    You'll also need to flash KitKat Gapps in order to have access to Google play store.

    Sent from my G2 running PAC-ROM
    04-11-2014 02:34 PM
  6. TheBull50's Avatar
    I was reading that Verizon has a locked bootloader? Would that be why it isnt working
    04-11-2014 02:55 PM
  7. SactoKingsFan's Avatar
    It does have a locked bootloader, but it's also locked on my AT&T G2. Loki allows us to bypass the locked bootloader and flash ROMs.

    Did you accept an OTA update since getting the phone? Some of the updated G2 firmware is not fully compatible with custom recovery.

    Sent from my G2 running PAC-ROM
    04-11-2014 03:10 PM
  8. TheBull50's Avatar
    Not that i know of accepting any OTA
    04-11-2014 03:24 PM
  9. Crispy's Avatar
    Please follow instructions in the XDA thread. I'll link the relevant threads -

    [TOOLS] One click Root for 10b, 11a, 12b, 24a and TWRP for 12b tools - xda-developers
    [ROM] Malladus 2.0.0 - 4/9/2014 [KK 4.4.2] [stock based] - xda-developers

    You need to flash a TWRP, then 2.7, then Malladus 2.0 rom.
    TheBull50 likes this.
    04-11-2014 07:22 PM
  10. TheBull50's Avatar
    When i try to flash i only get a black screen. Im using rom manager and picking twrp 2.6.3 when this is happening.

    - - - Updated - - -

    And by flashing , im opening rom manager and choosing install from sd card, correct ?
    04-11-2014 09:09 PM
  11. Ronnie2's Avatar
    No, don't ever use Rom Manager to flash a rom. You need to do it manually through recovery. It's a bit intimidating at first but it's not difficult and it's something that everyone should learn to do if they are gonna flash roms. First you need a custom recovery like TWRP or CWM recovery. You can install TWRP with Goomanager on the Play Store. Once you have your custom recovery of choice installed reboot into recovery and flash from there.

    It's always a good idea to make a backup first before you flash anything. After you make your backup image it's time to wipe your device in preparation for flashing your new rom. If you don't wipe there will most likely be problems with your new rom since there are old files that may conflict with the new. After wiping everything (except the SD storage of course) you can now flash your new rom. Once it's completed just restart your phone and wait for the new rom to load.

    It will take a few min to load up your new rom the first time so don't freak out if it's sitting at the boot animation for more than the usual 30 seconds. After that you should be good, it'll take you to the setup screen to add your Google account and such. If it doesn't load then go back into recovery and try it again. If you get lost or don't know what to do next, feel free to come back here and ask. Most users on this forum would be more than happy to help you out. It's much better to ask questions if you are unsure about something rather than brick your device. Hope it all works out for you.

    Sent from my beastly LG G2 using Tapatalk
    04-12-2014 03:03 AM

Similar Threads

  1. Gapps after KitKat install
    By Mista_J in forum Sprint LG G2
    Replies: 13
    Last Post: 04-28-2014, 04:43 PM
  2. KitKat 4.4.2: can I go safely?
    By Giant Lizard in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 04-15-2014, 05:48 AM
  3. Moto X: Assist Sleeping
    By shadolyn in forum Moto X (2013)
    Replies: 9
    Last Post: 04-12-2014, 07:42 AM
  4. Going to canada to work for about 3 months
    By Serial Fordicator in forum Samsung Galaxy Note 3
    Replies: 4
    Last Post: 04-11-2014, 12:54 PM
  5. Transferring data from old phone to S5
    By RJLOMMD in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-11-2014, 10:24 AM