1. nekad2's Avatar
    About a month ago, the USB connection on my revo just flat out stopped working. I've been through just about every forum post on the internet and am left without a solution. If there's anyone who knows of a solution to this problem, I implore you to share it with me! I'll worship you at this point

    When I connect the phone to any number of computers (I've tried Win7, XP, Linux, and MacOS X) with any number of USB cords (of which I've tried 6 now), and the phone will generally just start charging but will not be recognized as a mass storage or connection device by any computer. I have tried every combination of mass storage mode, connection mode, with USB debugging turn on and turned off. I've also turned the "prompt me" option on and off to no avail. When USB debugging was turned on, my phone used to show the USB icon at the top after plugging it in. Now, it shows nothing.

    ADB does not recognize the device at all either. Under Windows, I've tried both of these drivers from the LG site:

    LG VZW United WHQL v2.5.2.exe

    These have no affect. I've installed and reinstalled and rebooted too many times to count.

    Note: this phone IS rooted but I have not removed any software from it. I have, however, used the factory reset just to see if that would make it work.

    In short, I've ruled out configuration issues, USB cord issues, driver issues, specific computer issues, and (with the factory reset) some type of funky software issue in android. The next and last thing I am thinking about trying will be installing a custom rom. Unfortunately, I'm going to have to find a way to do this without connecting it to a computer. I believe a boot loader can be installed directly onto the device but I haven't dug deep into the directions for how to do this yet.

    My question, then, is could using a custom rom possibly solve the issue or am I just wasting my time by installing one? Also, is there anything else - anything at all that could possibly cause this issue or is my phone just toast?

    Sorry for the long post. I wanted to get the point across that I've done all of the usual stuff. I'm far beyond that point. Thanks to anyone with answers/suggestions/advice!
    09-02-2012 10:43 PM
  2. I.M.famous XMAN's Avatar
    to install a rom you need cwm. go to their site and download recovery for the revo, rename it to cwmrecovery.img, and follow these steps: xda-developers - View Single Post - Easy V8 - V9 All in One

    If all else fails, I suggest unrooting and taking it back to a store.

    lg revo: BrokenOut ROM
    --BeastCandy theme
    nekad2 likes this.
    09-06-2012 10:14 AM
  3. nekad2's Avatar
    The USB connection in all modes is working again! I have the following hypothesis and I hope it will help others whom experience the same issue.

    Instead of removing the battery for 30 seconds or 5 minutes, I took the battery out over night. I also removed the sd card. After replacing the sd card and battery, wallah; it started working again. WHY it worked is interesting.

    First, I'm certain that the USB port got locked into a state where it thought it was already connected. This state persisted in RAM, even through reboots and battery removals.

    Second, I'm betting that the volatile memory in my phone doesn't work like memory in other devices. In most devices, RAM loses data within milliseconds to seconds from the time the device loses power. This is because RAM needs a steady flow of electricity to constantly refresh it's data contents. I'm guessing the phone's RAM isn't as volatile or is being supplied with electricity somehow for a longer period of time after battery removal.

    Hypothesis: To really clear the RAM in these phones (or at least the Revo), the battery needs to be removed for more than a mere few minutes. I don't know how long for sure.
    09-09-2012 12:26 PM