1. DLCPhototography's Avatar
    I have a stock, non-rooted Verizon GN3, which behaved pretty much flawlessly in general, and with Bluetooth Headsets in particular, prior to the KitKat update.

    This behavior occurs with both my BlueAnt S4 Visor device, and a Bose Series 2 Headset. When I turn either on, it quickly connects. With the phone locked, screen off, if I initiate the connection from either device, the Voice Dialer comes up, and I can initiate a call. The call connects, and I can hear and speak through the Bluetooth device. Everything works as expected.

    But if I then try to make another call, it takes at least 2 additional tries to get the Voice Dialer to come up. The first time, the screen comes on briefly, then turns off, sometimes with the grey screen preceding the Voice Dialer briefly appearing. After a couple of more tries, the Voice Dialer comes up.

    But after I have it place a call, the audio send/receive stays in the phone, and doesn't transfer to the Bluetooth device. This pretty much defeats the purpose of having it in the first place!

    If I turn off either Device, turn it on and reconnect, the same cycle starts up again. It works properly the first time, but messes up after that.

    With the BlueAnt S4, I removed the pairing from my GN3, effectively deleting the device, and then turned off the phone. I then did a complete reset on the S4. Turned the phone back on, re-paired, but this didn't fix it.

    This is extremely annoying, to say the least.

    I have examined all my settings, and they seem correct. I went to Google Search settings, Voice settings, and tried it with the Bluetooth headset ('records audio through Bluetooth headset if available') both checked and not checked, and observe the same behavior.

    I welcome suggestions on how to fix this, and getting it to work consistently and correctly, as it did before KitKat.

    I would consider a factory reset on the GN3, if I were convinced this would fix the problem. But I'd hate to go through that hassle, and encounter the same problem again.
    06-04-2014 10:01 PM
  2. DLCPhototography's Avatar
    Well, I've made some progress, and I think the problem originates in a recent update to "Google Search." I found many reports of Bluetooth related problems that were remedied when the update was rolled back.

    So, I went ahead and rolled back the Google Search Update, and in fact, went ahead and Turned if Off completely.

    I tried out my Bluetooth Headset (the Bose earpiece, haven't tested on the BlueAnt yet), and it works perfectly, as before. And better yet, when I touch the BT button, S-Voice comes up, rather than the plain Voice Dialer, so I can not only place calls, but initiate navigation, send a text, or whatever I would like to do. And it seems to respond each and every time.

    We'll see what happens over time, and if there are any unanticipated consequences to turning Google Search off, but so far so good.
    jdwx and skycross like this.
    06-05-2014 01:10 PM

Similar Threads

  1. Replies: 2
    Last Post: 06-27-2016, 02:03 PM
  2. Replies: 17
    Last Post: 11-18-2014, 09:02 AM
  3. Multi-Screen What Happened after KitKat?
    By ScottGeek in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 6
    Last Post: 06-05-2014, 04:07 PM
  4. Replies: 3
    Last Post: 06-05-2014, 01:55 PM
  5. problems with native email app since upgrading to OS 4.4.2
    By klhprice in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 06-04-2014, 05:27 PM

Tags for this Thread