1. nquizitor1's Avatar
    I'm still running my beloved Verizon Galaxy Note 3 (SM-N900V) as my daily driver. It's got stock Android 5.0 (Kernel 3.4.0). I have tried all the methods searching through Google to change the default browser but they have not solved the problem. The one that seemed most likely to work, Settings>Application Manager>Chrome (and Firefox)>Clear Defaults, both "Launch by default" are grayed out. I also recently updated the Chrome browser. After that update is when I noticed that Chrome is now the default browser and I want to use Firefox with uBlock Origin as the default. I'm also not getting any choices to pick another browser when a browser is launched. Does anyone have any ideas as to a fix for this?
    05-24-2017 03:44 AM
  2. donc13's Avatar
    I'm still running my beloved Verizon Galaxy Note 3 (SM-N900V) as my daily driver. It's got stock Android 5.0 (Kernel 3.4.0). I have tried all the methods searching through Google to change the default browser but they have not solved the problem. The one that seemed most likely to work, Settings>Application Manager>Chrome (and Firefox)>Clear Defaults, both "Launch by default" are grayed out. I also recently updated the Chrome browser. After that update is when I noticed that Chrome is now the default browser and I want to use Firefox with uBlock Origin as the default. I'm also not getting any choices to pick another browser when a browser is launched. Does anyone have any ideas as to a fix for this?
    Remove the default from chrome then you can add it to firefox
    05-29-2017 05:56 PM
  3. nquizitor1's Avatar
    Thanks for the reply donc13 and sorry for the late response. I didn't see your message until now. The "Launch by default" is grayed out for Chrome so I can't change anything. Anything else you can think of that might work?
    06-03-2017 03:37 AM
  4. donc13's Avatar
    Thanks for the reply donc13 and sorry for the late response. I didn't see your message until now. The "Launch by default" is grayed out for Chrome so I can't change anything. Anything else you can think of that might work?
    You have to go to the settings->general->default applications and under that clear HTML

    Then, go open any application that has a link in it (such as an email message) and tap on a link, you will get a dialog to open the link with optional apps listed FireFox should be there and chrome also. Hit your choice (I presume Firefox) and then the ALWAYS selector.

    That should do it
    06-04-2017 07:29 AM
  5. nquizitor1's Avatar
    When I go to "Default applications" there aren't ANY browsers listed (to clear the default settings). And when I choose an application that requires a browser, I don't get the option of selecting different browsers like I did before I updated Chrome (from my OP). In fact, there aren't any browsers listed in any settings where this Android 5.0 version shows default applications (that I can find). I could probably fix this by resetting the phone but I would prefer that to be the last option. Any other ideas?
    06-05-2017 02:39 AM
  6. donc13's Avatar
    When I go to "Default applications" there aren't ANY browsers listed (to clear the default settings). And when I choose an application that requires a browser, I don't get the option of selecting different browsers like I did before I updated Chrome (from my OP). In fact, there aren't any browsers listed in any settings where this Android 5.0 version shows default applications (that I can find). I could probably fix this by resetting the phone but I would prefer that to be the last option. Any other ideas?
    Under default applications, there *should* be sn entry labeled HTML and it's default application is htm viewer. Delete that default. Not required but a good idea...reboot the phone.

    Then, go to an email with a link in it, or come back to here and hit this link http://www.google.com and you will be given a choice of which browser to use, select Firefox and select ALWAYS


    That will make Firefox your default browser.
    06-05-2017 06:02 PM
  7. nquizitor1's Avatar
    Under "Default applications", the only options I see are

    Set defaults
    Home=Touchwiz home
    Messages=Messages
    Clear defaults
    ES File Explorer----Clear button
    Touchwiz home-----Clear button

    And that's it. No htm viewer or anything else. Also when I launch an email link to a URL or any other application that launches a browser, it opens Chrome. I don't get the option to choose any other browser and I don't get to select "Always". It skips that step and simply launches Chrome.
    06-06-2017 12:59 AM
  8. donc13's Avatar
    Under "Default applications", the only options I see are

    Set defaults
    Home=Touchwiz home
    Messages=Messages
    Clear defaults
    ES File Explorer----Clear button
    Touchwiz home-----Clear button

    And that's it. No htm viewer or anything else. Also when I launch an email link to a URL or any other application that launches a browser, it opens Chrome. I don't get the option to choose any other browser and I don't get to select "Always". It skips that step and simply launches Chrome.
    Then you have one other choice, under Application Manager, go down to Chrome, force stop it, then select DISABLE, it'll ask you if you want to remove updates, say Yes. When it's done. Go back to a link and hit it. You should now get a choice of FireFox. Or at the very least the link should open in Firefox.

    If you don't ever want Chrome, you should be good to go.

    If that doesn't work... I have no more options for you to try.
    06-06-2017 09:16 PM
  9. nquizitor1's Avatar
    That worked!! Thanks donc13!!!! When I disabled Chrome, a message said that there could be problems if I disable/uninstall Chrome. Do you know if this is a big deal? Hopefully not. Again thanks for the help and the screenshots!!!!!
    06-07-2017 03:13 AM
  10. donc13's Avatar
    That worked!! Thanks donc13!!!! When I disabled Chrome, a message said that there could be problems if I disable/uninstall Chrome. Do you know if this is a big deal? Hopefully not. Again thanks for the help and the screenshots!!!!!
    There won't be any problems, that 'warning' is simply Google's way of trying to stsy on the phone and generste revenue for Google.

    Chrome Browser does an awful lot of tracking and reporting back to Google, supposedly to give you better reccomendations... but in reality, so they can sell targeted ads.

    As long as you are happy with Firefox, then you're fine leaving Chrome disabled.

    Glad I could assist.
    06-07-2017 01:13 PM
  11. nquizitor1's Avatar
    Makes sense. Again thanks for the help!!
    06-08-2017 02:27 AM
  12. Kaera Neko's Avatar
    Edit: Sorry, wrong place to post this query, I'll go to the proper forum section.
    06-28-2018 07:23 PM

Similar Threads

  1. Replies: 1
    Last Post: 05-24-2017, 09:11 PM
  2. Can I use 360 Action Directoron more than 1 computers ?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-24-2017, 03:24 AM
  3. Replies: 0
    Last Post: 05-24-2017, 02:52 AM
  4. how do i change my lock screen passcode if i forgot it
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-24-2017, 12:28 AM
  5. Whenever I use my browser, the phone hangs up. How do I fix this?
    By Parthiv Purkayastha in forum Ask a Question
    Replies: 0
    Last Post: 05-23-2017, 11:59 PM
LINK TO POST COPIED TO CLIPBOARD