1. crtxn1's Avatar
    Hi,
    This is my first Android device, (I came from iOS), and I have an Asus AC-66R Router at home which has both 2.4 GHz and 5 GHz wifi simultaneous going. Now my wife still has an iPhone 4 and my computer both have to use the 2.4 GHz wifi. I know the GS4 does run 802.11ac on 5 GHz. I was able to get it to work by turning off the 2.4 GHz signal, and there is a noticeable improvement, but when both are on it seems that the GS4 always goes to the 2.4 GHz settings. I have to keep both up for the other wifi devices in the house, and for the life of me, I cannot find a setting on the Verizon GS4 to set 5 GHz as the priority over 2.4 GHz in the settings. Could someone please help me out, so I can optimize the GS4? Thank you for any help.

    Charles
    JKarhani likes this.
    05-26-2013 06:32 PM
  2. Patrick Schroedl's Avatar
    It should, by default, select 5GHz over 2.4GHz only if the perceived signal strength is higher. 5GHz WiFi signals lose strength much more rapidly due to physical or electromagnetic interference than 2.4GHz signals do, and so that may be part of the issue.

    Have you verified that the phone defautls to 2.4GHz even with direct line of sight of the router's antennae (and closer than 20 feet)? That'd be a quick way to determine whether it truly is disregarding the 5GHz signal entirely.
    05-26-2013 06:56 PM
  3. crtxn1's Avatar
    Yes, I have pulled up the router diagnostics and it has not used the 5 GHz signal at all, when I turned off the 2.4 signal, it then showed that it was receiving 5 GHz. I also notice a much faster speed. On 2.4 GHz I was averaging 45 to 51 mps download, and with the 2.4 off and on forcing the GS4 to only communicate of 5 GHz, I was getting between 65 to 72 mps. So there is a huge difference. I have the 5 GHz signal set to 160 mW and the 2.4 set to 80 mW. I am even sitting in front of the router and getting the same issue. So it looks like the default is the 2.4, instead of the 5.
    05-26-2013 07:08 PM
  4. majorpayne's Avatar
    I have the router also. Change is SSID of the 5ghz to something differrent and then make it forget the 2.4

    Posted via Android Central App
    pwscott and bbslam like this.
    05-26-2013 08:25 PM
  5. Jaycemiskel's Avatar
    Yeah I have two different SSIDS for mine also

    Sent from my SCH-I545 using Tapatalk 4 Beta
    05-26-2013 08:32 PM
  6. DreamSTi's Avatar
    I just wanted to chime in and say I have the same router and it kicks ***
    05-26-2013 10:47 PM
  7. thedeceiver's Avatar
    I have the router also. Change is SSID of the 5ghz to something differrent and then make it forget the 2.4

    Posted via Android Central App
    Same thing here. My phone knows both but reconnects to whatever it last connected to.

    Sent from my SCH-I545 using Tapatalk 2
    05-27-2013 12:05 AM
  8. crtxn1's Avatar
    Thank you so much, that was the issue, I had the same name for both SSID's!
    WOW is all I can say! I am now getting downloads on wifi of close to a 100 mps on 5 GHZ and only 45 to 50 on 2.4. Now I just have to reconfigure the router so I can print off of the 5 GHZ line, but that will be later.

    On a side note, I agree with all of you who own this router, it seriously kicks ---! I keep finding more and more of what the ASUS Router can do! If anyone is looking for a great router, this is the one to get!

    Thank you for your help in this matter, something so simple as the SSID, and you all made it so much better, Thank You!
    Patrick Schroedl likes this.
    05-27-2013 01:27 AM
  9. CCallahan's Avatar
    Ok...need some help here. I have the same router but for the life of me can't find where it will tell me what speed my S4 is connected to. Just because it connects on the 5ghz band doesn't mean it is connecting on AC instead of N correct? Just trying to make sure my device is actually connecting on AC.
    06-21-2013 06:36 PM
  10. trivor's Avatar
    ASUS routers are great - I had a high end Netgear (WNDR 3700) that was constantly needing to reboot and replaced it with an RT-56 and it has been great ever since (both 2.4 and 5 Ghz). If (when) I move up to an 802.11ac I will stay with ASUS.
    06-21-2013 06:53 PM
  11. DarkSorrow's Avatar
    I would go to the router's wireless link then click Professional and look for TX power adjust and change it from the default and set it to 200mW. I've been running mine like this and I can go down the road and still have a 5Ghz connections.
    06-23-2013 02:14 PM
  12. movielover76's Avatar
    I have a similar issue with 5Ghz wifi N and this phone, I have a Linksys E4200 running on 5Ghz and 2.4Ghz (for legacy devices) and the phone will connect to 5Ghz but it will not stay connected, constantly disconnects and connects to 2.4Ghz, if I make the phone forget the 2.4Ghz network (different SSID) it just disconnects from 5Ghz and goes to LTE, even standing right in front of the router.

    Router has zero issues with other devices. At this point, I've partially given up and just connect to 2.4Ghz because it's the only wifi this phone will connect to reliably.
    07-02-2013 11:42 AM
  13. snookasnoo's Avatar
    I'm using Apple's new 802.11ac router, had nothing but trouble with Asus routers dying on me with terrible support. Lots of people with the same issue if you read customer reviews.
    07-02-2013 04:55 PM
  14. Erol Fox's Avatar
    movielover76,

    I stumbled on this thread and have the same problem with my Nexus 5 (just received) and my Linksys EA6200 on 5GHz. Don't have any other device that drops the 5GHz.

    Did you ever figure this out?
    11-09-2013 12:01 PM
  15. Erol Fox's Avatar
    movielover76,

    I stumbled on this thread and have the same problem with my Nexus 5 (just received) and my Linksys EA6200 on 5GHz. Don't have any other device that drops the 5GHz.

    Did you ever figure this out?
    11-09-2013 10:17 PM
  16. Patrikvk's Avatar
    Hello, I believe I have the same problem.

    I can run both bands simultaneously, but if I do then my phone will connect to the 2.4Ghz band rather than 5Ghz.
    At the moment I run them with two different SSID's and I use the extremely simple App called "Wifi Prioritizer" so that my phone will always priorotize whatever wifi I choose, for example my 5Ghz SSID. If the 5GHZ SSID isn't available, it will automatically choose my second choise which I chose to be the 2.4Ghz SSID.

    However, I really want to use just one SSID, but if I do that then the Wifi Prioritizer app won't work and my phone will jump between 2.4GHZ and 5GHZ.
    It's so frustrating because I'm 1.5m away from the router and I get around 30DCB signal strength on the 2.4Ghz and around 45-55DCB on the 5GHZ, so that's why my phone switches back to 2.4GHZ if I'm not running Wifi Prioritizer.

    I hope anyone has found a solution to run both bands under one SSID and for the phone to connect to the 5GHZ and stay on it.
    07-15-2014 07:06 PM
  17. speedlever's Avatar
    WIFI Prioritizer crashes on my GS4/i337 running 4.4.2 (NC1).

    I found this thread looking for a way for my phone to prefer the 5GHz band. No luck thus far.
    10-15-2014 10:54 AM
  18. dresupreme's Avatar
    Hello all. I have a Linksys 1900ac router that is dual band 2.4ghz and 5ghz. I'm running a Samsung Note 3 on the 5ghz band, by changing the SSID name and password for 5ghz. I easily reach 75-90 mb/s down. However, since I also use my phone to connect to my Xbox one, I had to change the settings on the Xbox so it to can connect to 5ghz. Changing the name and password of SSID is what helped me. No problem since.
    10-20-2014 08:00 PM
  19. nospam nospam's Avatar
    @ major payne - your suggestion worked for me. It's an old thread, but is there a way to "upvote" this solution.
    04-19-2016 02:09 AM

Similar Threads

  1. 802.11AC on the S4
    By Parafly in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 05-05-2013, 08:57 AM
  2. Wifi 802.11ac Compliance
    By ItsaRaid in forum AT&T Galaxy Note 2
    Replies: 4
    Last Post: 12-08-2012, 12:07 AM
  3. 802.11ac
    By Krothie in forum General News & Discussion
    Replies: 5
    Last Post: 07-16-2012, 08:39 PM
  4. 802.1x Wifi Connectivity?
    By Strygun in forum Verizon Droid Incredible
    Replies: 7
    Last Post: 04-30-2010, 02:47 PM
  5. Looking for a wifi settings widget
    By mjesenovec in forum Motorola Droid
    Replies: 2
    Last Post: 04-24-2010, 06:20 PM
LINK TO POST COPIED TO CLIPBOARD