1. pbelfi's Avatar
    Crazy thing happened with my wifi....I am visiting someone in a rehab hospital, and they have wifi available.....when I put the password in, I made a typing error. Anyway now when I go to re-enter the password, the "connect" button is grayed out....is there anyway to reset the data for the connection?




    Sent from my Nexus 7 using Android Central Forums
    68bucks likes this.
    05-28-2013 11:34 AM
  2. Golfdriver97's Avatar
    Crazy thing happened with my wifi....I am visiting someone in a rehab hospital, and they have wifi available.....when I put the password in, I made a typing error. Anyway now when I go to re-enter the password, the "connect" button is grayed out....is there anyway to reset the data for the connection?




    Sent from my Nexus 7 using Android Central Forums
    Click on the connection, click forget. Back out, then click to reconnect.
    05-28-2013 11:40 AM
  3. pbelfi's Avatar
    Click on the connection, click forget. Back out, then click to reconnect.
    I don't have a "forget" option, just a "cancel" and "connect" option, with "connect" being grayed out.

    Sent from my Nexus 7 using Android Central Forums
    05-28-2013 11:51 AM
  4. Golfdriver97's Avatar
    I don't have a "forget" option, just a "cancel" and "connect" option, with "connect" being grayed out.

    Sent from my Nexus 7 using Android Central Forums
    Try long pressing the connection.
    05-28-2013 11:55 AM
  5. pbelfi's Avatar
    Nope same thing just getting the same window with the grayed out "connect" button

    Sent from my SCH-I545 using Android Central Forums
    05-28-2013 12:22 PM
  6. Golfdriver97's Avatar
    Nope same thing just getting the same window with the grayed out "connect" button

    Sent from my SCH-I545 using Android Central Forums
    Ok...so you have a blank field and a choice of 2 buttons. Can you type in the field?

    Sent from a M.O.A.R. Galaxy S3
    05-28-2013 06:01 PM
  7. pbelfi's Avatar
    Yes I can type in the field....but the "connect " button is still grayed out.....

    Sent from my Nexus 7 using Android Central Forums
    05-28-2013 06:20 PM
  8. Golfdriver97's Avatar
    Yes I can type in the field....but the "connect " button is still grayed out.....

    Sent from my Nexus 7 using Android Central Forums
    I am going to be honest....I am at a loss for what to suggest next. Sorry.

    Sent from a M.O.A.R. Galaxy S3
    05-28-2013 07:28 PM
  9. MBM7881's Avatar
    Yes I can type in the field....but the "connect " button is still grayed out.....

    Sent from my Nexus 7 using Android Central Forums
    Have you tried clearing data and cache? Go into settings, more, application manager, then scroll to wifi direct share and clear the data. That's the only thing i could think of sorry

    Sent from my GT-N8013 using Android Central Forums
    05-28-2013 08:04 PM
  10. pbelfi's Avatar
    Have you tried clearing data and cache? Go into settings, more, application manager, then scroll to wifi direct share and clear the data. That's the only thing i could think of sorry

    Sent from my GT-N8013 using Android Central Forums
    Thanks...I'm going back to the rehab again later today, and I just cleared the cache.....we'll see what happens later.....thanks again for all the help people!
    05-29-2013 07:35 AM
  11. pbelfi's Avatar
    I am going to be honest....I am at a loss for what to suggest next. Sorry.

    Sent from a M.O.A.R. Galaxy S3
    Please don't be sorry...I appreciate the help...thank you!
    Golfdriver97 likes this.
    05-29-2013 07:36 AM
  12. pbelfi's Avatar
    Okay...after unsuccessfully trying the suggestions in this thread, I've finally come up with a work around.....I downloaded an app called "Wifi Manager," and everything worked from there....just wanted to post the solution in case someone else needs a quick fix for this problem.....Thanks to everyone for the help!
    05-30-2013 02:03 PM
  13. ricebandit's Avatar
    Ok, this is lame, but I figured I'd might as well mention this since it comes up #1 in a Google search.

    It seems that Samsung's wifi password validation requires 8 characters. I have an S4 trying to connect to my work's wifi (which of course I can't change), which has only 7 characters as it's password. The connect button stays gray. But if I add another character it immediately becomes clickable (and of course is the wrong password. I guess we're **** out of luck because this issue has been around since as far back as the S2.
    06-17-2013 02:03 PM
  14. knight1fox3's Avatar
    Okay...after unsuccessfully trying the suggestions in this thread, I've finally come up with a work around.....I downloaded an app called "Wifi Manager," and everything worked from there....just wanted to post the solution in case someone else needs a quick fix for this problem.....Thanks to everyone for the help!
    Ok, this is lame, but I figured I'd might as well mention this since it comes up #1 in a Google search.

    It seems that Samsung's wifi password validation requires 8 characters. I have an S4 trying to connect to my work's wifi (which of course I can't change), which has only 7 characters as it's password. The connect button stays gray. But if I add another character it immediately becomes clickable (and of course is the wrong password. I guess we're **** out of luck because this issue has been around since as far back as the S2.
    Thanks for the info on this. Was having the same trouble as I just recently bought an S4. Is there really no other way to use the default Wi-Fi and have the password be any length?
    07-15-2013 10:18 AM
  15. AndroidJay's Avatar
    I hope this gets changed. At home, we have the power to change it, but while traveling, we don't. Granted, 8 or more characters is a good thing for securing a WiFi network. I hope Samsung is notified.
    07-15-2013 11:35 AM
  16. paintdrinkingpete's Avatar
    The reason for this is that the S4 is assuming that you are connecting to an access point with WPA/WPA-2 security, which requires at minimum an 8 character password. If the wifi access point you are connecting to is using the older "WEP" security, then it is possible that the password is less than 8 characters.

    I realize that this thread is a bit older and the OP has probably moved on, but here's something you can try if you encounter this issue (keep in mind I don't have access to a WEP network at the moment to test this, but here goes...)

    Go into "Settings --> Wi-Fi", and you'll see where it lists the available networks. Do not click on the network you are trying to connect to, instead, scroll all the way to the bottom and click on "Add Wi-Fi Network". Enter the SSID (a.k.a network name), keeping in mind that SSID *are* case sensitive. Under the security field, choose "WEP" (we're making an assumption here because the password is less than 8 characters), then enter the password. You should be able to hit the "Connect" button even if the password is less than 8 characters.

    If the network is in fact using WEP, then that should work, but again, I don't actually a way to test at the moment..
    AndroidJay, knight1fox3 and Bleezy like this.
    07-15-2013 11:46 AM
  17. Linda Boyd's Avatar
    I’m having this very same problem with my Galaxy tablet. I have had galaxy s2-s4 phones, nexus phones, LG phones, laptops… you name it… and never had a problem with connecting to the wifi with ANY of them. Then along comes this tablet that is requiring a longer password. This tablet belongs to my sister. I shouldn’t have to change my password just to accommodate one device. This is ridiculous. You mean to say there are no other ways to change the required number of characters to a smaller amount in settings somewhere? Talk about frustrating. Do you have a link to share that can get me in touch with Samsung about this issue in hopes that they can help fix it?
    11-19-2015 12:57 PM
  18. Jyoti Kumari1's Avatar
    I am going to be honest....I am at a loss for what to suggest next. Sorry.

    Sent from a M.O.A.R. Galaxy S3
    the option is generally greyed out if either you are entering the wrong password(which is less than 7or 8 chars as per password requirements) or you are entering a password which is lesser than those many characters. So have a look at the pwd if it meets the requirement and is right.
    09-18-2017 03:33 AM
  19. EdRevugh's Avatar
    My grayed out 'connect' button resolved itself when I selected "Do Not Validate" Under "CA Certificate"
    10-25-2017 08:38 AM

Similar Threads

  1. Wifi password too long.
    By Euroqueb in forum General Help and How To
    Replies: 1
    Last Post: 02-04-2015, 08:35 PM
  2. View WiFi Password
    By ZimLanfire in forum HTC EVO 4G
    Replies: 2
    Last Post: 01-23-2011, 12:24 PM
  3. Wifi Passwords Stored In Plain Text
    By egg_head in forum Verizon Fascinate
    Replies: 5
    Last Post: 09-29-2010, 01:37 PM
  4. My Girlfriend Lost Her WIFI Password
    By Mudvayne622 in forum The Android Central Lounge
    Replies: 10
    Last Post: 09-06-2010, 10:33 PM
  5. My Girlfriend Lost Her WIFI Password
    By Mudvayne622 in forum HTC EVO 4G
    Replies: 9
    Last Post: 09-06-2010, 10:29 PM
LINK TO POST COPIED TO CLIPBOARD