1. project.in.process's Avatar
    hey guys, forgive me as i just bought this off Craigslist--

    bought the VZW 1545 unlocked S4 (still on the build # that's NOT the latest, so it can be rooted fairly simple)

    do i need to root it & mod the APN settings (via app as system app) to allow for use on a GSM carrier like ATT/TMobile?

    i have a SIM from t-mo in my GNEX right now that works fine but am afraid of putting it into the S4 if in some event it bricks it or does something funky to it.

    thanks & any applicable info is helpful.
    07-20-2013 12:07 PM
  2. digitalslacker's Avatar
    hey guys, forgive me as i just bought this off Craigslist--

    bought the VZW 1545 unlocked S4 (still on the build # that's NOT the latest, so it can be rooted fairly simple)

    do i need to root it & mod the APN settings (via app as system app) to allow for use on a GSM carrier like ATT/TMobile?

    i have a SIM from t-mo in my GNEX right now that works fine but am afraid of putting it into the S4 if in some event it bricks it or does something funky to it.

    thanks & any applicable info is helpful.
    w/ or w/o root it won't work. VZW is a CDMA carrier and ATT and TMO are GSM. The radio in that device is completely different from what is required to run on a GSM carrier.

    welp i stand corrected...it's possible i guess since it's a penta band radio ... kinda of involved.
    xda-developers - View Single Post - [Q] HTC Vivid on Tmobile 3G/4G?
    and here for some background...[Q]OOC Verizon S4 on Tmobile? - Page 2 - xda-developers
    i would guess the apn settings are the same as they are for tmo's LTE.
    learn something new every day!
    project.in.process likes this.
    07-20-2013 12:34 PM
  3. NotJustAPhone's Avatar
    The Verizon GS4 does work on T-Mobile. I've confirmed that myself. You can get working voice and SMS by just putting your T-Mobile SIM in the phone. To get data and MMS working, you'll need to add the appropriate APN settings for T-Mobile in Settings/Connections/More networks/Mobile networks/Access Point Names.

    With the GS4, Verizon didn't lock the ability to add APNs so you don't need root to get data and MMS working on T-Mobile.

    Sent from my Nexus 4
    project.in.process likes this.
    07-20-2013 12:42 PM
  4. project.in.process's Avatar
    Awesome. Thanks guys.

    figured i needed to root to add the APN settings (as a system app, i think)--now it's just finding appropriate instructions for a Mac (all i have on the weekend).

    thanks for your quick responses!
    07-20-2013 12:50 PM
  5. NotJustAPhone's Avatar
    Awesome. Thanks guys.

    figured i needed to root to add the APN settings (as a system app, i think)--now it's just finding appropriate instructions for a Mac (all i have on the weekend).

    thanks for your quick responses!
    You don't need root to add the T-Mobile APN. The option is greyed out while your Verizon SIM is in the phone. Put in your T-Mobile SIM and you'll be able to add a new APN.

    Sent from my Nexus 4
    07-20-2013 12:52 PM
  6. digitalslacker's Avatar
    Awesome. Thanks guys.

    figured i needed to root to add the APN settings (as a system app, i think)--now it's just finding appropriate instructions for a Mac (all i have on the weekend).

    thanks for your quick responses!
    yeah no root needed

    when you get the phone

    [T-Mobile APN Settings] [LTE] [MMS] - xda-developers

    has the LTE apn settings for TMO.
    project.in.process likes this.
    07-20-2013 01:05 PM
  7. project.in.process's Avatar
    Thanks.
    Got the phone running with text and voice, but I'm only able to get Edge with the settings from the xda thread. Hopefully a call to tmobile customer service to reset it will help. Had to do that the first timei bought service with my gnex.
    07-21-2013 03:34 PM
  8. dpham00's Avatar
    Thanks.
    Got the phone running with text and voice, but I'm only able to get Edge with the settings from the xda thread. Hopefully a call to tmobile customer service to reset it will help. Had to do that the first timei bought service with my gnex.
    It may be that you aren't in a re farmed area, some devices will only get Edge

    Sent from my Verizon Samsung Galaxy Note II
    07-21-2013 04:01 PM
  9. NotJustAPhone's Avatar
    Thanks.
    Got the phone running with text and voice, but I'm only able to get Edge with the settings from the xda thread. Hopefully a call to tmobile customer service to reset it will help. Had to do that the first timei bought service with my gnex.
    If you're in an area where T-Mobile hasn't refarmed their 1900 MHz spectrum for HSPA, then you will get an Edge connection. Unlike the GSM version of the Galaxy Nexus, the Verizon GS4 don't doesn't support HSPA on 1700/2100. There's a website that shows the areas where T-Mobile has HSPA on 1900. I can't recall the name right now, but it shouldn't be difficult to find the information.

    Sent from my Nexus 7
    07-21-2013 04:05 PM
  10. NotJustAPhone's Avatar
    The APN settings from that xda thread are for T-Mobile's LTE network. These are the T-Mobile APN settings that I use with my Verizon GS4. May be worth trying these settings to see if it makes a difference.

    Do I need root to use VZW S4 on ATT/Tmo?-uploadfromtaptalk1374438189422.jpg

    Do I need root to use VZW S4 on ATT/Tmo?-uploadfromtaptalk1374438203517.jpg

    Sent from my Galaxy S4
    project.in.process likes this.
    07-21-2013 04:23 PM
  11. jinju0's Avatar
    i'm sorry i meant to reply to the above post. please ignore this post.
    06-24-2014 11:46 PM
  12. jinju0's Avatar
    You don't need root to add the T-Mobile APN. The option is greyed out while your Verizon SIM is in the phone. Put in your T-Mobile SIM and you'll be able to add a new APN.

    Sent from my Nexus 4

    so is this also true for an AT&T sim? i have a verizon galaxy 4s and want to use AT&T. when i went to add the pan settings for AT&T, i could not add a new setting. so i was trying to do it ahead of getting the sim from at&t so all i had to do was put the card in. but i am hoping that it will allow me to add a new setting once i put the new at&t card in. am i thinking in the right direction with this?
    06-24-2014 11:51 PM

Similar Threads

  1. HTC One randomly turns on
    By X9Cinema in forum HTC One M7
    Replies: 7
    Last Post: 10-17-2013, 01:00 PM
  2. my internet speed goes very slow whenever the tab's wifi is turned on
    By ibetbetbet in forum Samsung Galaxy Tab 2
    Replies: 2
    Last Post: 07-26-2013, 11:59 AM
  3. S4 bricked
    By s4user1 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 07-21-2013, 03:41 PM
  4. S4 Car Charger
    By SuperCK in forum General Help and How To
    Replies: 1
    Last Post: 07-20-2013, 12:04 PM
LINK TO POST COPIED TO CLIPBOARD