1. arretium's Avatar
    Device: Samsung Galaxy S4 (detailed phone info at bottom)

    Bottom line: I can't install apks. From anywhere EXCEPT Amazon Apps.

    Phone was rooted. While rooted I went to delete some samsung files (bloatware), I checked the internet before deleting samsung apks to verify that it was safe to do, and then after comfirming, uninstalled them, and then went into the installer directory and deleted them from there too. Made backups of everything before and after. Well two of those apks I deleted happened to be the preinstaller.apk and the samsung internet browser. I wonder if that was a mistake. I also deleted a bunch of other crap like the yahoo stuff and the aamzon book reader thing, but it was mainly all the samsung bloat ware.

    Everything was just fine. I rebooted, I was happy. I could install stuff. Everything was great. But then I decided I wanted to try something different. So I thought I'd factory reset and start over. So I factory resetted the phone. I went to towelroot.com to go get my super easy root first. But Chrome wouldn't open the file....that's odd I thought.

    So then I went to google play. I noticed that Google play immediately began annoying me by automatically downloading and installing updates. So I turned that off. Then I tried to install my own apps from Google Play Store, like the terminal emulator. But it wouldn't work. I kept getting a 406 error code. I tried it other apps, same result. In short, I can't get any app to install from Google Play. When I try to get them from Google play I get Error 406. I've tried getting them from Google Play using a different google play account, same result. I've tried it using Wifi versus cell data, same result. I've tried it using google play's https website, same result. It just won't download -- error 406. I've done all of the above, factory reseted the phone and tried again, same result.

    Here's where it gets crazy. You might remember that I said that google play started updating apps as soon as the first moment I stepped my foot in the store. Well here's what I found out...

    CRAZY - Google Play **WILL** update these apps
    Amazon Music with Prime Music
    Blurb Checkout
    Google Play Books
    Google Play Music
    Google Play Newsstand
    Google Maps
    My Verizon Mobile

    Google play will error 406 out and not update these APPS:
    AllShareCast Dongle S/W Update
    Chrome Brosser - Google
    Google Drive
    Google Play Games
    Google Play Movies & TV
    Google Search
    Google Text-to-Speech
    Group Play
    Samsung Link
    Samsung Push Service
    Verizon Cloud

    I have backups of everything, including the preinstaller.apk, but I can't open that file now. I can't open titanium backup either because 1) I can't install it on the phone and 2) I'm not rooted. It's rather annoying!

    I can't install APKs over the internet (chrome). Chrome will download the apks, but when I click on the downloaded apk file in the notification screen or use the file manager The Samsung Galaxy S4 will say "can't open file". That's annoying!

    I tried to open the APKs from the file manager, from my computer via USB, from the SD card...no go. I can't open APKs from the GMail account (google blocks alot of the apks I tried to install that way...like towelroot, but it didn't block all apks, in any event I get the "can't open file" on the ones google does allow me to get). It won't work from my own email account. I tried checking for "software update" under the device settings (MORE), rebooting, no dice. Tried the usb debugging settings in developer settings (No dice). YES... I did have the "Unknown sources" checked.

    So bottom line:
    I can't install other browsers to try to open APKs in other browsers.... get "can't open file"
    I can't install apks from notification, download manager, or file manager. get "can't open file"
    I can't install towelroot apk even though download, just get "can't open file"
    I can download stuff from chrome but can't install it because I can't open the file.
    I can't download anything EXCEPT the updates mentioned above in Google Play ... I get error 406.
    I tried installing an app installer from google play or the internet or my usb cable or my sd card, either "can't open file" or Error 406.

    I can't get towelroot to work so I can't go back and root my phone. If I could just root the phone and install the command emulator, I'd be golden.

    I tried to download the samsung apps from samsungapps.com. It also will download the stuff, but won't open or install.. I get the "can't open file" message regardless of whether I click on the big phone button or the little reinstall phone button.

    Phone otherwise works great. It will make calls, surf the internet, look at pictures, take pictures, etc, etc. SMS works great. MMS works. IT all works, I just can't update crap!

    It will install apps through Amazon Appps. How crazy is that? It would install Candy Crush Saga through the Amazon app installer. Facebook, twitter, drop box...an app installer that amazon had (i triued that, but it wouldn't install any apks)... opera browser (tried opening towelroot apk thru that, got no app can open file).

    Did I sorta quasi brick my phone?

    Anyone have an idea on what to do?


    Here's the phone info:

    Samsung Galaxy S4

    model number

    android version 4.4.2

    baseband version


    Kernetl version
    dgi@SWDD5015 #1
    Fri Mar 28 13:38:41 KST 2014

    Build Number


    SE for android status
    Fri Mar 28 13:38:29 2014

    Secure boot status
    Type: samsung

    Hardware version

    Security software version
    MDF v1.0 Release 2

    Sure would appreciate some help!!!

    I've tried installing apps via acan't download them from
    07-04-2014 04:34 PM
  2. Golfdriver97's Avatar
    You may have to consider reflashing a stock ROM through Odin. That should get you back to a state before you rooted the first time.
    07-04-2014 11:39 PM
  3. arretium's Avatar
    OK. How exactly can i do that?

    I have the kot49h boot loader. I couldn't get Odin to flash anything before (the whole point of rooting this device was to get a different rom, but I diagress). And I tried a cap load of stuff. I seem to remember KNOX has got everything shut down as far as being able to modify the bootloader and flash the rom.

    But there's got to be a way!!

    In other news, I downloaded a bunch of appinstallers from amazon and downloaded a unzipped program that can unzip apk files. Then mysteriously my Google play began working. I'm sure one didn't have anything to do with the other. But in any event, I'm now not happy with all the bloatware that is back so I'm itching to go reinstall everything again but hesitant due to the above...

    now I just need to figure out how to install androidmanifest.xml files so that if I do redo it I can at least manually install the apps that I need to get myself back out of it.

    In any event the problem seems unresolved but currently getting worked arounded. It was and is very weird.
    07-05-2014 02:22 PM

Similar Threads

  1. nexus 2012 screen problem.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2014, 02:50 PM
  2. Can I not move the "apps" button?
    By ShaneN. in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 07-05-2014, 02:34 AM
  3. Spen problem
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2014, 02:34 AM
  4. Alarm not working when phone off
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-04-2014, 11:24 PM
  5. MMS file size limit on Aio/Cricket?
    By mrsmumbles in forum Other US Carriers
    Replies: 2
    Last Post: 07-04-2014, 11:23 PM