1. Mewwy's Avatar
    A while back, my Galaxy S4 booted into recovery mode after it died when I plugged it back in. After a while of searching, I found out that holding volume down and power would make it boot regularly. However, when I tried to accept the latest update, it would get to a certain point in the update then reset every time. When I tried the volume down method, it booted but said it was optimizing apps for Android. It got stuck there for a few hours, so I removed the battery and tried again. This time, it got to the Verizon logo and stopped there. Every time I try booting it, it gets stuck there now. Please help! I tried wiping all my data, but that didn't help either.
    If this isn't in the right place, feel free to move it.
    10-21-2014 10:31 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You may have to try flashing the stock ROM via Odin. http://forums.androidcentral.com/amb...-via-odin.html
    10-22-2014 03:33 AM

Similar Threads

  1. On my bricked Samsung Galaxy S3 the bought jig didn't work, why?
    By Cody Vaughn in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 05-10-2015, 05:15 AM
  2. Anyone using the Zagg HDX on their Note 4?
    By Cward1138 in forum Samsung Galaxy Note 4
    Replies: 21
    Last Post: 12-22-2014, 09:55 AM
  3. Video Lollipop On The Galaxy S5!
    By Preach2k in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 11-21-2014, 07:15 PM
  4. How do I use multiple joysticks on a hub usb?
    By oslash in forum Ask a Question
    Replies: 1
    Last Post: 10-22-2014, 01:08 AM
  5. Replies: 0
    Last Post: 10-21-2014, 10:00 PM
LINK TO POST COPIED TO CLIPBOARD