1. Jurden's Avatar
    While I was out today the battery on my galaxy drained as expected. I go home and plug it in then a hour or so later go to use it. It was off, black screen, so I just hold down the power button. Nothing happens. After trying with a friends S4 and multiple batteries here is a run down of what is going on. I can, try to power on the phone or try to go into recovery and it will show the splash for about two seconds then black screen. After it goes black I will get no response from any buttons or button combinations. If I take out the battery and put it back in, then I can try to power on the phone or try to go into recovery but again it will show the splash and shut off. If I take out the battery and put it back then plug it in to charge it will show the battery for a bout two seconds then again black screen. I have let it charge, I have tried other batteries and other chargers. Did my phone just up and kill itself?
    Thanks for any help.
    10-29-2014 06:04 PM
  2. SpookDroid's Avatar
    That's odd :S Have you tried connecting it to a computer via USB and see if it at least tries to recognize it?

    I would also try to 'reset' it (not factory reset, we don't want you to lose your data, right?). Press and hold the power and home buttons for about 10 seconds or until your phone starts cycling on its own. I'd also remove any batteries and leave it like that for a couple of hours.

    BTW, does your battery work fine in your friend's S4?
    10-29-2014 06:14 PM
  3. kapp1088pti@hotmail.com's Avatar
    I am in the same boat here. Mine started running very slow on Saturday evening. Battery rapidly drained. I had it plugged in to charge. Attempted to get to the reboot option and got there after several tries. Phone then went through it's motions except it never turned back on.

    I can get a 2 second splash screen got the Galaxy s4 and that's it. If I remove the battery for a few seconds and place it back in I get splash again. If I pull battery, hold down the volume key I can get the custom OS load warning screen for 2 seconds.

    The only thing that had changed recently was I had received the verizon update a couple days earlier. This was the first reboot since getting it. Several apps updated at that time as well.

    Connecting it to a charger or PC doesn't do anything. I figured maybe my port had gone bad. I purchased a standalone battery charger from Amazon and let the battery charge to full this evening. Same thing...2 seconds of screen then off again.

    Looking for any option to power it up one last time to at least pull pictures off of the phone memory as at some point it switched from SD back to phone then back to SD. Several pictures i'd love to get back from my honeymoon trip.
    10-29-2014 08:49 PM

Similar Threads

  1. Please please please help me My Galaxy s3 d2vzw will not turn on custom rom slimkat 4.4.4.
    By Hunter Gregg in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 09-28-2015, 12:10 AM
  2. Replies: 23
    Last Post: 11-10-2014, 03:35 PM
  3. How is your battery life on the 2nd gen Moto G
    By hisense in forum Moto G (2014)
    Replies: 5
    Last Post: 11-03-2014, 02:11 PM
  4. Not so smooth Google Play Store
    By Tivadar Kiss in forum HTC One M8
    Replies: 4
    Last Post: 10-30-2014, 02:11 AM
  5. Bluetooth 4.0 on Note 3
    By dagold99 in forum Verizon Samsung Galaxy Note 3
    Replies: 3
    Last Post: 10-29-2014, 05:16 PM
LINK TO POST COPIED TO CLIPBOARD