1. amirh1's Avatar
    Hi,
    When I insert a battery the S4 powers up, shows the Samsung logo for 1 sec and dies. Power button doesn't do anything, booting with recovery mode has same effect (shows a blue text message with the Samsung Logo but then dies immediately). When it wasn't malfunctioning inserting a battery didn't power up the phone (until I press power button). Is it possible that this can be fixed?
    Tried it with several batteries, tried when it's plugged to power and not plugged, and symptoms are the same.

    Any help on what I can do, short of buying a new phone? BTW the phone is Verizon stock (not rooted or anything), running Android 4.4.2
    Thanks!!
    01-04-2015 05:07 PM
  2. Rukbat's Avatar
    Take a battery. Lay it on a flat table. Try to spin it around. (If it spins, find a place that takes discarded lithium batteries [they're toxic, don't just throw one in the trash] and get rid of it - it's shot.)

    Take a good battery (one that doesn't spin). Put it in the phone. Plug in the charger. Don't even look at the phone for 24 hours. Then see if it boots.

    It not, add a post to the thread.
    01-04-2015 05:20 PM

Similar Threads

  1. Best wallpaper app on galaxy note 4?
    By WilliamLundstrom in forum Samsung Galaxy Note 4
    Replies: 13
    Last Post: 07-11-2015, 03:24 PM
  2. Replies: 2
    Last Post: 01-17-2015, 10:05 PM
  3. Face down to silence notifications?
    By BlackDragon22 in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 01-04-2015, 04:04 PM
LINK TO POST COPIED TO CLIPBOARD