06-23-2017 07:53 AM
37 12
tools
  1. acannon420's Avatar
    I have two Galaxy S4 phones, purchased from Verizon 2 years ago... we're moving our phones to NEW numbers over on T-Mobile's network. T-Mobile sent new SIM cards to go into the Galaxy S4 phones. We've established connection to the T-Mobile network and can make/receive phone calls, we have data connection and can RECEIVE texts, but cannot SEND texts. Support from T-Mobile says that my MESSAGE CENTER number wasn't updated when we installed the new T-Mobile SIM cards. Also, there's no place in SETTINGS in MESSAGING that will allow me to change the MESSAGE CENTER number. T-Mobile has tried sending an over-the-air update which also didn't work. Their next idea is a 2nd set of new SIM cards. They're due to arrive Tuesday afternoon. In the meantime I wanted to check... is there any OTHER way I can manually change the MESSAGE CENTER number?
    THANKS SO MUCH in advance!
    07-19-2015 09:45 PM
  2. shel692's Avatar
    The new sim should automatically update that.... It more sounds like Verizon did not fully release and rebroadcast your numbers. Anyway... go to dialer and enter *#*#4636#*#* and once in the hidden menu settings, select phone. Scroll all the way down and you will see SMSC, it should be blank. Touch update and the new SMSC should be +12063130004 for T-Mo.
    07-19-2015 10:01 PM
  3. acannon420's Avatar
    ... go to dialer and enter *#*#4636#*#* and once in the hidden menu settings, select phone.
    Okay... stupid question... do I hit DIAL once I punch that in? Because if so, my phone tries to dial that saying it can't be called as dialed.
    07-19-2015 11:08 PM
  4. shel692's Avatar
    No you shouldn't have to. Hmm. I wonder if VWZ has that menu locked out.
    07-20-2015 12:10 AM
  5. acannon420's Avatar
    I don't know. All I know is if I key in that code, nothing happens. It just sits there... doing nothing.
    07-20-2015 07:54 AM
  6. shel692's Avatar
    I forgot Sammy was a little different.... try these steps...

    1.
    Find "Settings"
    Press Messaging.
    Press the Menu key.
    Press Settings.
    2.
    Save the message centre number
    Press Message Centre.
    Key in (appropriate smsc) and press OK.
    3.
    Return to the Home screen
    Press the Home key to end the session and return to the Home screen.
    07-20-2015 07:02 PM
  7. Trung Tran4's Avatar
    I am having same issues. moved from verizon to t-mobile 2 months ago. MMS works, phone calls works, SMS receive works, but SMS send does not work. (actually checking for systems update always gives "service unavailable").

    model: SCH-I545
    android: 5.0.1

    #*#4636#*#* does not work.
    there's no place in Messaging app to show SMSC.

    Worked with T-Mobile support and store employee for total of around 4 hours. They isolated to this being phone issue as SIM card was fine on a T-Mobile branded phone. A working SIM card from someone else would have the same problem on my phone. They also changed my SIM card a few times and it still didn't work either.

    On call with Samsung support (Smart Tutor enabled so he can remotely control my phone), but he can't fix it either. He can't find any way to view nor change SMSC number.

    Can someone help? Is there a programmatic way to change the SMSC directly?
    07-30-2015 11:47 AM
  8. donniedoomsday3's Avatar
    I haven't been able to find a fix but I have been using Google voice to text with a different number from my phone its my only work a round I'm sorry

    Posted via the Android Central App
    08-01-2015 01:51 AM
  9. nate_tran's Avatar
    Got the same exact problem. When I was running Kit-Kat I didn't have this problem, but when i manually updated the phone to lollipop, everything went downhill.
    09-24-2015 01:00 AM
  10. Lauretta Belk's Avatar
    I activated my phone with TMobile today and am having the same problem. Seems the problem is android; does anyone know if they're working on a patch for it? :/
    10-01-2015 10:45 PM
  11. Magicman08's Avatar
    I found that I was only able to SEND texts on the Verizon S4 on AT&T's network when on H or H+ and not LTE. If I was on LTE sending text messages always failed. Kind of sucks but this phone was a HUGE upgrade from my HTC One XL in just about every aspect.

    So I've learned to deal with it as I rarely am anywhere without wifi anyway and if I am I can manually switch to LTE and not send texts for a bit if I want to stream WWE network or SlingTv
    10-13-2015 01:20 AM
  12. vdots's Avatar
    Looks like you posted this a few months back, did you ever get outgoing text messaging to work for you? Were you able to reset the SMSC number? I have exactly the same issue.. went from Verizon to T-Mobile and lost text out capability. Talked to the store, T-mobile support, Samsung support, all in vain. Did anyone find you a way to update SMSC number?
    10-31-2015 01:27 AM
  13. vdots's Avatar
    Hi acannon420, did the new SIM cards work for you?
    10-31-2015 01:33 AM
  14. Magicman08's Avatar
    Did you read my post? I don't think it's possible...I have the "new" simcard and have done just about everything. AT&T anyway lte will not let me send text messages from the verizon s4
    11-01-2015 02:31 AM
  15. NewSeams's Avatar
    Same issue here. The only thing that is going to fix this is accessing and editing the Message Center. Without a fix or hack allowing users access to this, the problem will remain unsolved.
    11-04-2015 12:40 PM
  16. Trung Tran4's Avatar
    I never got it to work. ended up buying another phone.
    11-04-2015 12:42 PM
  17. tehjosheh's Avatar
    I solved this issue for my girlfriend's phone on AT&T. Not sure if this exactly applies but here is what I learned/what i did:

    After a few hours of research i discovered the issue was two fold:
    1) Phone cannot send text messages through 4G (so disabling 4G LTE - i know this sux, and instead using HSPA - not thaaat bad)
    2) Cannot change the SMSC phone number the texts will go through

    Here is what I did:
    1) Rooted her phone using Kingroot (very easy 1-click root tool)
    2) Downloaded and installed the app Advanced Signal Status
    3) Opened Advanced Signal Status app and clicked "Additional Info" (this opens the phone's hidden menu only accessible after rooting)
    4) Under SMSC I changed the field to "+13123149810" for AT&T and pressed update ***Note you will have to find the corresponding number for TMOBILE
    5) I changed the preferred network type from LTE/GSM to GSM Auto (this disables 4G LTE and only uses HSPA)
    6) Restarted the phone and it was able to send SMS messages thereafter.

    Hopefully this works for TMOBILE as well (not sure if they have HSPA coverage).

    Good luck!
    Jono Lach likes this.
    11-17-2015 02:28 PM
  18. Srmeister's Avatar
    The rooting option worked! Kingroot and Advanced Signal Status - super easy and no hassles!

    the t-mobile smsc number is +12063130004

    Changed the data settings to GSM auto and it worked! Didn't have to reboot either.

    tehjosheh Thank you for your hard work!
    tehjosheh likes this.
    11-30-2015 11:18 PM
  19. Lynette Stevens Hall's Avatar
    pretend I am a 54 year old lady - okay I am a 54 year old lady...I downloaded Kingroot and Advanced signal status....how do I "root"?
    12-09-2015 09:40 PM
  20. dreadful2's Avatar
    I was able to do all that (rooted, installed Adv Signal Status app & enter smsc #), but when I hit update, it would not save the number. Did you have any problem with this?
    12-12-2015 10:37 AM
  21. tehjosheh's Avatar
    I was able to do all that (rooted, installed Adv Signal Status app & enter smsc #), but when I hit update, it would not save the number. Did you have any problem with this?
    i did not have that problem, sorry =/
    12-29-2015 11:29 AM
  22. tehjosheh's Avatar
    pretend I am a 54 year old lady - okay I am a 54 year old lady...I downloaded Kingroot and Advanced signal status....how do I "root"?
    once you download Kingroot you will need to install the app before you can root the phone. to do this you will first enter your phone's settings, go to security, and check the box that says "Unknown Sources". After this is done you will open the app "My Files" and navigate to where you downloaded the Kingroot app .apk file (likely it will be in your download folder). Once you locate the kingroot .apk file you will open it and follow the prompts to install the app. After Kingroot is installed, open the Kingroot app and select to root your device. After it shows it successfully rooted your device, restart your phone and proceed with my steps outlined above.
    12-29-2015 11:34 AM
  23. cybor462's Avatar
    once you download Kingroot you will need to install the app before you can root the phone. to do this you will first enter your phone's settings, go to security, and check the box that says "Unknown Sources". After this is done you will open the app "My Files" and navigate to where you downloaded the Kingroot app .apk file (likely it will be in your download folder). Once you locate the kingroot .apk file you will open it and follow the prompts to install the app. After Kingroot is installed, open the Kingroot app and select to root your device. After it shows it successfully rooted your device, restart your phone and proceed with my steps outlined above.
    A note of warning first I am no techie but I have been looking for a root for my S4. After hours of looking I found the S4 with 5.0.1 cant be rooted because of Knox. I suggest those looking to root check on that. I read it can brick your phone. If the info I read is wrong would love to have someone steer my the right way to get a root from my S4. Thanks
    12-30-2015 04:36 PM
  24. pioki's Avatar
    Exellent suggestion!

    Those steps worked for me in principle but since I am on OF1 I had to use different steps to root:

    forum.xda-developers.com/galaxy-s4-verizon/general/root-of1-t3249971


    To see if you are on OF1 on your phone go to settings -> about phone and check the Baseband version. if it ends with OC1 you are good, but if it ends with OF1 follow steps from the link above.
    01-03-2016 11:26 PM
  25. JANE ROBINSON1's Avatar
    what were the steps you took to change the message center number...
    02-16-2016 04:28 PM
37 12

Similar Threads

  1. Auto Change Network Operators
    By farrsolo in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 08-17-2015, 05:52 AM
  2. Replies: 86
    Last Post: 07-27-2015, 12:29 PM
  3. Is the Serial Number the same as the IME?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-19-2015, 09:35 PM
  4. How can I have Hangouts read my messages using text to speech?
    By maximegousse in forum General Help and How To
    Replies: 0
    Last Post: 07-19-2015, 08:27 PM
  5. s4 ui failure
    By bj white in forum Ask a Question
    Replies: 0
    Last Post: 07-19-2015, 08:01 PM
LINK TO POST COPIED TO CLIPBOARD