1. brettt777's Avatar
    I have wi-fi with a repeater in my home. My tablets and laptop work on the wi-fi just fine; anywhere in the house I get good signal. My wife's Galaxy S4, and my LG G2 for that matter, seem to get good wi-fi signal but always seem to want to use the poor 4G signal for internet or facebook. Is there some way to set these phones up to have wi-fi as the preferred signal? Most of our data usage is done in a location that has wi-fi but both these phones seem to always want to use 4G which of course, uses data.
    09-20-2015 04:45 PM
  2. B. Diddy's Avatar
    Can they just toggle off mobile data while at home?
    09-20-2015 10:35 PM
  3. brettt777's Avatar
    Yes, that works, but I thought there might be a way to make the device use wi-fi as the priority, i.e. if wi-fi is available, it will use that over 4G.
    09-20-2015 11:52 PM
  4. B. Diddy's Avatar
    Go to Settings>Wi-fi, tap Menu>Advanced, and see if you have an option for "Avoid Weak Signal." Uncheck it if it's present.
    09-21-2015 01:31 AM
  5. MYKEL2014's Avatar
    B. Diddy.. I don't have that option .. any other suggestions as I too have the same issue as the OP?
    09-21-2015 08:45 AM
  6. B. Diddy's Avatar
    Another thing to try is to turn off Smart Network Switch in that Advanced Wi-fi menu.
    09-21-2015 11:03 AM
  7. MYKEL2014's Avatar
    Thanks that setting I do have. I turned it off and I'll see if it makes a difference. Thanks again!
    B. Diddy likes this.
    09-21-2015 01:27 PM
  8. brettt777's Avatar
    It's a weak 4G signal I'm trying to avoid, not a weak wi-fi signal.
    09-22-2015 01:46 PM
  9. B. Diddy's Avatar
    Right, but if the phone thinks the wi-fi signal is weak for some reason, it might be dumping you to 4G. Just try turning Smart Switch off for a day or so, and see if the problem persists.
    Dragoon#AC likes this.
    09-22-2015 02:33 PM
  10. latty's Avatar
    Turn on airplane mode then turn your wifi on.
    01-02-2016 12:51 PM
  11. Dragoon#AC's Avatar
    Right, but if the phone thinks the wi-fi signal is weak for some reason, it might be dumping you to 4G. Just try turning Smart Switch off for a day or so, and see if the problem persists.
    I'd discovered this earlier - it works, solved my problems, hope it works for you...
    B. Diddy likes this.
    01-03-2016 07:33 AM

Similar Threads

  1. Black or White Front?
    By Channan in forum Moto X Pure Edition
    Replies: 44
    Last Post: 10-02-2015, 05:29 PM
  2. Replies: 8
    Last Post: 09-24-2015, 01:34 AM
  3. Triangle by 4G and signal bars
    By ttfn92 in forum Moto X (2013)
    Replies: 3
    Last Post: 09-21-2015, 01:04 AM
  4. Replies: 1
    Last Post: 09-20-2015, 10:43 PM
LINK TO POST COPIED TO CLIPBOARD