1. Prince Phil's Avatar
    HI everyone. I need help on this one. My Google play service app has refuse to open on my galaxy S4. I wonder what might be the problem. I tried updating play store to no avail. I cleared cache, and tried all other android tricks but none worked. Phone has no gmail app installed. I installed one but I cannot sign into my Gmail account as play store is not working. I'm really tired and confused on what next to do. Can anyone help?
    01-26-2016 04:57 AM
  2. blade22222's Avatar
    Try clearing the data for Google play services also.
    01-29-2016 08:48 PM

Similar Threads

  1. Best way to read Kindle books on Tab S2?
    By Little Squirt in forum Samsung Galaxy Tab S2
    Replies: 3
    Last Post: 01-27-2016, 09:56 AM
  2. How to clear my removed apps and users?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-26-2016, 02:51 AM
  3. Replies: 0
    Last Post: 01-26-2016, 02:32 AM
  4. Replies: 0
    Last Post: 01-26-2016, 02:31 AM
  5. Replies: 0
    Last Post: 01-26-2016, 02:31 AM
LINK TO POST COPIED TO CLIPBOARD