1. jbonesy's Avatar
    So I got this LG Optimus Q through Wal Mart/Straight Talk back around Christmas. I rooted it with the LG Esteem Root and installed SuperUser and JuiceDefender on there to help with Battery Life, and everything was fine until last night when I forgot everything I'd done and tried to update the firmware.

    Since then, the phone goes into a boot loop on power-up, even flashing in My Computer as an external drive before it reboots and I lose the connection. While I can get to Emergency Mode, I'm a little unsure as to what to do next. I've found a couple of methods that could help but I'm not getting any good results with them.

    -Downloaded KDZ_FW-UPD and used it under CDMA - CS_EMERGENCY with a .kdz that I think is the correct version (V20L_00.kdz for Gingerbread 2.3.4?), but the program crashes midway and so it looks like nothing's happening. I can't think of why it would be crashing though?

    -Downloaded LG Utils 0.4.2 and tried running the KP500 program using one of two .cabs, but when the Phone Update program runs it hits a point where it says "Updating is no longer possible due to fatal error when LG software update" and I get this:

    10:57:28 : [C:\LGMobileUpgrade] 丮 õ
    10:57:28 : RemoveDirectory1 Error(2):C:\LGMobileUpgrade
    10:57:28 : Start Date : 2012-02-18 10:57:28
    10:57:28 : -------- Buyer Test mode ---------
    10:57:28 : [C:\ProgramData\LGMOBILEAX\Phone] 丮 õ
    10:57:28 : RemoveDirectory1 Error(5):C:\ProgramData\LGMOBILEAX\Phone
    10:57:28 : *****CheckOS Start********
    10:57:28 : Microsoft_Windows_Vista Home Edition_
    10:57:28 : *****CheckPCSyncPrograms Start*****
    10:57:29 : PCSyncPrograms Not Found
    10:57:29 : SetEmerModeAT()
    10:57:29 : _IsConnectedPhone Call
    10:57:36 : _IsConnectedPhone(2)
    10:57:36 : 0 - NotConnected.
    10:57:36 : 1 - Normal connect success
    10:57:36 : 2 - Emergency connect success
    10:57:39 : Checking the connection with the cell phone...
    10:57:39 : dwWaitResetTime(40000 ms)
    10:57:40 : Phone Mode(2)
    10:57:40 : *****GetPhoneType Start*****
    10:57:43 : Phone Type : CDMA
    10:57:43 : *****Start GetPreviousStep*****
    10:57:43 : _GetPreviousStep(dwStep:0xffff)
    10:57:43 : *****GetPhoneBinaryVersion Start*****
    10:57:43 : CSE mode -> Version Replace
    10:57:43 : *****Get ESN / IMEI / MEID Start*****
    10:57:56 : *****GetPhoneNumber Start*****
    10:57:58 : Phone Number : 00000000000
    10:57:59 : ˻ ĶŸ - ESN_IMEI : 00000000000, Model :
    10:58:01 : _GetAuthMark : wAuthMark(24557)
    10:58:01 : Wait 3Sec
    10:58:07 : _SetAuthMark Ok : wAuthMark(24557), PhoneMode(2)
    10:58:07 : *****CheckPCSyncPrograms Start*****
    10:58:07 : PCSyncPrograms Not Found
    10:58:08 : CLGMobileHttp Class Ҹ.
    10:58:08 : CLGMobileHttp Class Ҹ...
    10:58:08 : ****************CheckAndDownload********************
    10:58:08 : ******Extract Start C:\LS670ZVC_11.SC_11.P60674.cab*****
    10:58:08 : Model Dll Dir(C:\ProgramData\LGMOBILEAX\Phone\)
    10:58:08 : ExtractInfo Error(0)
    10:58:08 : Extract cab file error.
    10:58:08 : [C:\ProgramData\LGMOBILEAX\Phone] 丮 õ
    10:58:08 : RemoveDirectory1 Error(5):C:\ProgramData\LGMOBILEAX\Phone
    10:58:09 : !pUpgrade->StartProcessing ... PostMsg STEP_TYPE_ENV_ERROR
    10:58:09 : CLGMobileHttp Class Ҹ.
    10:58:09 : CLGMobileHttp Class Ҹ...
    10:58:09 : Page_Error κԴϴ
    10:58:09 : OnStepMsg STEP_TYPE_ENV_ERROR delete m_pLGCyonUpdate

    Which sounds ominous, but the error it cites there is an Extract cab file error, so maybe I'm just typoing something?

    One more thing, forgot this in the original write-up.

    I downloaded the SDK and tried to use adb through dos but I get an error response that the device cannot be found. The other methods seem to find the phone just fine, though, so I'm not sure what the problem is there. Is there a way to make the phone more "visible" through dos that I'm missing?

    Apologies for just sorta showing up with a problem and not a lot of experience with this stuff but I feel like I might be a quick learner. At this point I'd be happy to just get the phone working again, I'm not worried about any of my data on there. Thanks!
    02-18-2012 10:02 AM
  2. jcole20's Avatar
    Do you have a custom recovery on your phone? I usually update the phone before rooting it. Though just having root shouldn't have caused these problems above. Did you attempt an OTA update? Or did you try to flash an update? If an OTA update caused it I'd contact net10/st. If you flashed a .zip update... I hope you have a custom recovery installed. (These phones shouldn't have an update past the LGL55CV3 update.). IF you can get into a custom recovery wipe the /system partition (along with cache and dalvik cache) and flash a new rom. Is your imei really zero'd out like in the log? I wanna help you but you need to explain what you did exactly. An OTA update SHOULD NOT have done this. Your phone at worst should have told you it couldn't install the update... Try walking us through exactly what you did that caused this. If I go to update firmware my phone just wont let me.
    jbonesy likes this.
    02-18-2012 11:32 AM
  3. jbonesy's Avatar
    Hm, good questions, let me try to get through them. Nope, no custom recovery because when I rooted I thought for some reason that I'd never need it since I just wanted to tweak the power usage/battery life (stupid me). In addition to rooting it which added superUser, I installed Juice Defender (free version), and AutoKiller (free version, I forgot this in the OP). I didn't tweak anything special in those apps and stuck to the pre-set options since I didn't want to screw stuff up.

    The update I performed was through the phone menu/settings/update track, the standard update route since I had forgotten the root could screw stuff up. After that, I noticed it had gone into a boot loop and that basically brings us to now.

    I directly c/p'ed the log to the post so I don't know if the imei is for sure zeroed out/how to check that, especially since I'm not getting the device identified through dos/adb.

    It seems to make progress through KDZ but like I said it stops responding and closes out before it finishes anything. I've got no custom recovery, all I've got is the boot loop and Emergency mode as options (unless there's another boot mode I didn't know of; I'm learning as I go). Using LG Utils 0.4.2 I did try to flash LS670ZVC_11.SC_11.P60674.cab, but this was way later, after the initial update attempt bricked my phone. Or did I ruin the whole thing by trying to restore it?

    I haven't tweaked anything other than the initial root and apps, and even then I didn't mess with anything beyond the pre-sets. I'm not sure what would've caused this, but it's kinda confusing. Sorry it's not a lot of information but thanks a ton for the patience!
    02-18-2012 04:17 PM
  4. jcole20's Avatar
    Yeah that log showed your imei and phone number were zeroed out. If that's actually the case... just getting you running isn't gonna make ur phone work. To be honest I really don't know what to tell you. Hopefully someone else can chime in and offer you some help. I really don't know what to do for you at this point.

    Sent from my LGL55C using Tapatalk
    02-18-2012 11:31 PM
  5. jbonesy's Avatar
    Well, crap. So, if the imei/phone number weren't actually zeroed out, would there be steps I could take? I'm willing to try anything, and if it's really that bad nothing will hurt to try, right?

    I just need a coherent set of steps I can follow as opposed to looking at what other people have tried and trying to cobble together an understanding.

    Think of it as a thought experiment? Either way, I really appreciate the help
    02-19-2012 01:09 AM
  6. jcole20's Avatar
    Well, I do not know how to get your phone working... but if your imei is truly zeroed out, you'd need to flash the imei (with the imei your phone came with (should be on the box or the paperwork your phone came with)). Hopefully with the imei reflashed you could update the profile on the phone and get the number to sync. If you happen to get the phone up and running, you can see if your imei is zeroed out by going to Menu->Settings->About Phone->Status . Hopefully your imei isn't zeroed out and you can get it up and running, but you're going to need help from a dev or something. I would seriously call ST/Net10 and tell them you went to update and walk them through what happened. You didn't cut the phone off while it was updating did you? This is crazy, you're the only person I've read of bricking (at least soft brick) this phone in this way. I'm wondering if the phone was defective or if power was cut before the update completed.
    02-19-2012 01:02 PM
  7. jbonesy's Avatar
    Hmm, Well I called Straight talk and they're going to send me an envelope to exchange my phone for a replacement, which is neat. In the meantime I suppose I'll do some reading and make sure I know what I'm doing before I root the replacement.

    I should have the card from this phone; I'll try and work with that until I have to send this one away. And nope, I set the thing to update through the menu and went to bed. When I woke up I found it in the loop etc. I did plug it into the wall before going to bed, but it still had more than half-battery when I did so. I'm pretty bewildered, but it's comforting to know it's a generally confusing situation and not entirely my lack of expertise.
    02-19-2012 02:18 PM
  8. jcole20's Avatar
    I really suggest you update the phone. Then root it. Install custom recovery and make a backup before doing anything more to the phone. With a custom recovery you can create a nandroid backup and you should pretty much be brick proof, baring you dont try to flash an incompatible rom or anything like that. (eg flashing an lg optimus 2x rom on an lg l55c)
    jbonesy likes this.
    02-19-2012 03:05 PM
  9. jbonesy's Avatar
    Can do, thanks man. I'll also try and get my bearings on the forums and make sure I know what I'm doing next time.
    02-20-2012 07:39 AM